How to sync Zotero data to NAS on local or external network

I am using the standalone version of Zotero on a desktop Mac. I am trying to sync over my local network (at home) to my Zotero data on my home Synology NAS using WebDAV (instead of using the Zotero server) and am getting this error message when I use the external https IP address for my NAS:

"xxx.xxx.xxx.xx:5006 uses an invalid security certificate.

The certificate is not trusted because the issuer certificate is unknown.

The server might not be sending the appropriate intermediate certificates.

An additional root certificate may need to be imported.

The certificate is not valid for the name xxx.xxx.xxx.xx.

Error code: SEC_ERROR_UNKNOWN_ISSUER”

The regular http IP address also does not work.

Then I tried the local/internal IP address for my NAS and got this message:

"An error occurred during a connection to xx.x.x.x:5005.

SSL received a record that exceeded the maximum permissible length.

Error code: SSL_ERROR_RX_RECORD_TOO_LONG"

I have two-factor authentication set up for logging into my Synology account.

Does anyone have any guidance for how to help? I have tried the following Zotero documentation pages but nothing has worked so far:

https://www.zotero.org/support/kb/ssl_certificate_error
https://www.zotero.org/support/kb/incomplete_cert_chain
https://www.zotero.org/support/kb/cert_override

And here is a list of WebDAV services that Zotero says definitely work with its software:

https://www.zotero.org/support/kb/webdav_services

Thanks much in advance!
  • SEC_ERROR_UNKNOWN_ISSUER
    It's likely a self-signed certificate, so you'll need to follow the cert override instructions using Firefox 52 ESR as explained there.
  • Thank you for this tip dstillman -- I tried the cert override instructions already for the self-signed certificate scenario (the first of the two described in the link) but that didn't work -- not sure whether the second, custom certificate scenario in the link, the one involving Firefox ESR (which I don't use), is involved here
  • It'd be the first one.

    The instructions definitely work for a self-signed cert. It's possible that cert_override.txt either isn't used in newer versions of Firefox or the format has changed since Firefox 52 ESR, so your best bet would be to try with that version. (It's not a question of what you use for normal browsing — it's a question of the file formats that that version creates in your Firefox profile directory.)
  • Thank you again dstillman. So even though I am using the standalone version of Zotero I still need to go through this web-based, Firefox runaround? And also, once I install Firefox 52 ESR and try to run this fix again, can I thereafter revert to using my current, newer version of Firefox, or will I be bound to Firefox 52 ESR going forward in order to keep this fix going for WebDAV syncing purposes?
  • When you use a self-signed certificate, all programs on your system that make HTTPS requests to that server need to whitelist the certificate. In the case of Zotero, we don't have a UI for doing that and just rely on the underlying mechanism from Firefox, on which Zotero is based, that checks for that text file in the profile directory. Once you've created the file in Firefox and copy it to the Zotero profile directory, you don't need to change it again until the self-signed certificate changes.

    Note that you don't need to actually "install" Firefox 52 ESR on a Mac. You can just copy the app to a temporary directory and run it from there and delete it afterward. (You might even want to run it with a separate Firefox profile to make sure you're creating the proper file, and then delete the profile afterward.) To be clear, we have no reason to believe that cert_override.txt is different in newer versions of Firefox — no one has reported that — but that'd be something to try if you're having trouble.
  • Do you use the DDNS or the IP address for the sync setting? When I use the DDNS address https://mghachem.synology.me I get the message “could not connect to server” — and this is whether I try using the Zotero sync setting (“verify server”) or entering the address in a Firefox web tab. Should I be using the IP address instead, ending with :5006/home/zotero? This is getting a bit too complicated so if there are additional issues I will just concede and pay the Zotero unlimited storage fee!
Sign In or Register to comment.