Error updating document

This discussion was created from comments split from: Problem with Zotero tab in Word.
  • I'm hoping adomasven or some one can help. I have followed all of the instructions, here and on the troubleshooting page and I can no longer add citations in Word. The tab shows up, but when I click 'add citation' The error message says "Zotero experienced an error updating your document. Would you like to view troubleshooting instructions?"

    When I disable all macros with notification, I don't get a request to allow macros when I re-open word.

    I have also tried copying in an old .dotm from my back up before a computer update. That did not resolve the problem. I have also reinstalled Zoter. I can't reinstall Word without admin/ tech support.

    Also of note when I tired to reinstall Zotero, it installed a second copy as far as Windows is concerned, though there is only one zotero.exe. I can't uninstall it without tech support either.

    word is 16.0.4849.1000 64 bit.

    any help is appreciated. my paper revisions came back today and are due in <10 days and of course they want new citations in a numbered footnoted document.
  • edited 27 days ago
    Note that most of the things you're trying aren't in the Debugging Broken Documents steps linked from that error dialog. I'd strongly encourage you to post here rather than try random things, which can often make problems worse and make it harder for us to help you.

    Does it work in a new document? If so, follow the steps on that page to fix the problem in the existing document.
  • It does not work in a new document either. One of the first things I tried. I am aware they are not on the debugging broken documents, but the document isn't where the problem is. I tried those steps too for good measure.
  • OK, so you're saying if you open a new Word document and click "Add/Edit Citation" (not "Add Citation", right?), you get the "Zotero experienced an error updating your document." message?

    Can you provide a Report ID after that occurs?
  • The only button I have in my Zotero tab in the Ribbon is Add/edit citation, so I can't select just Add citation. The same is true for Add/edit bibliography. There is a screen shot of the tab in a newly opened document here: https://drive.google.com/file/d/1baHN53IYR-QhxgmE_GlRDP8us07MvrxT/view?usp=sharing.

    Of interest the macros for those do appear in things I can add to the Ribon or quick access. But they generate the same error if I try to use them and they have the standard Word Macro icon.

    Report ID 1027533174 for clicking on Add/edit citation


    [JavaScript Error: "couldn't open library C:\Users\lilly.136\Documents\Zotero\extensions\zoteroWinWordIntegration@zotero.org\resource\libzoteroWinWordIntegration.dll: error 1260" {file: "file:///C:/Users/lilly.136/Documents/Zotero/extensions/zoteroWinWordIntegration@zotero.org/components/zoteroWinWordIntegration.js" line: 51}]

    version => 5.0.74, platform => Win32, oscpu => Windows NT 10.0; WOW64, locale => en-US, appName => Zotero, appVersion => 5.0.74, extensions => Zotero LibreOffice Integration (5.0.20.SA.5.0.74, extension), Zotero Word for Windows Integration (5.0.14.SA.5.0.74, extension)

    Thanks!
  • Something is wrong with your installation. Have you manually installed the Word plugin somehow? Go to C:\Users\lilly.136\Documents\Zotero\extensions and remove the zoteroWinWordIntegration@zotero.org folder, then reinstall Zotero and try again.
  • Hello adomasven. I and the IT team here have reinstalled zotero after removing it and any folders or files named Zotero, and run a fix/repair for Word. it still gives the same error. And I still don't have the "add citation" button, just Add/edit for every new document. One question I have:

    the Zotero.dotm file is present and selected, however Zotero does not appear in the COM-add-ins even after reinstalling it. Though the Acrobate files are .dll trying to select the _64.dll from the newly installed zoteroWinWordIntegration@zotero.org generates a message from word saying that it is not a valid Plug in.
  • And I still don't have the "add citation" button, just Add/edit for every new document
    ("Add/Edit Citation" is what you're supposed to have — it was you who said "Add Citation" originally, so I was just clarifying that that's not what you meant.)
  • Ahh there is an other thread that says specifically to select "Add Citation" NOt "Add/Edit Citation"
  • That may have been referring to an older version of Zotero from before the buttons were combined or sloppiness in the wording by the poster (potentially me).
  • @perkytweakB75 Could you submit another Report ID after producing the error?
Sign In or Register to comment.