Erroeneous and empty {citation} fields remain in text (LibreWriter)

edited 9 days ago
Occassionally I will go to insert a citation and then decide not to. I press escape to "bail out" once the citation bar has appeared. However, the field placeholder eg" {citation} remains in my text document. Yes, I can delete it by hand, so it's more of an annoyance than preventing me from doing anything.

This only happens in Writer not word and only with bookmarks not reference marks. In word the {citation} fieldly disappears as expected. I'm using Windows 10, Zotero 5.0.69, Libre 6.2.4.2 (x64)

So to summarise, to reproduce:
>click insert citation,
>citation bar comes up in document as does {citation} field in text
>with cursor in citation bar, I press escape to close the citation bar
>{citation} field remains in the text

Any suggestions to stop this from happening?
  • That's certainly not normal behavior, and I can't reproduce it.

    Does this still happen after restarting your computer? After reinstalling the plugin from the Cite pane of the Zotero preferences with LO closed?
  • edited 17 days ago
    @dstillman yes, it still happens after trying both of those suggestions/
  • Does this happen in a new document, or only an existing document?

    If only the latter, see Debugging Broken Documents.
  • edited 15 days ago
    Thanks again for the follow up.

    -- It's happening for both - new and existing.

    Unsure if it's related, but the "add citation" box is regularly in the background when trying to insert a citation. The fix as per the link below doesn't seem to 'stick'.

    https://forums.zotero.org/discussion/63569/insert-citation-window-always-appear-in-background

  • Could you produce a Debug ID from Zotero?

    1. In the Help menu, go to Debug Output Logging and select Enable.
    2. Click the button for the Zotero citation in LibreOffice, then close the citation dialog when it shows up and wait for it or any progress bars to disappear.
    3. Before doing anything else, return to Help → Debug Output Logging and click Submit Output, which will disable logging and submit the output to zotero.org. A window should pop up containing a Debug ID. Click “Copy to Clipboard” and paste the Debug ID into this forum thread.
  • Debug ID: D213713392

    Let me know if any issues with it.
  • What version of Java do you have set up in LibreOffice (check under Options -> Advanced)?
  • When I originally checked - 1.8.0, but it looked like it was using a JRE filed under another program (SPSS) which was weird.

    I then changed it to the other one listed (1.8.0_211) to see if the issue repeated -- it does.
  • Could you download the newest version of Java from Oracle -- curently at 1.12?
  • edited 10 days ago
    I'm running 64 bit LO and java. It looks like the version of java I'm using is the most up to date. Regardless, I've reinstalled it. No change.

    Am I missing something?
  • You have the most up-to-date 1.8 version of Java. You should get Java 1.12 https://www.oracle.com/technetwork/java/javase/downloads/jdk12-downloads-5295953.html

    Additionally you can try updating LO to their latest version. I have tested with the latest version of Java and LO on Windows 10 all 64-bit and could not reproduce this, so we are first trying to nail down the basic setup of the software before troubleshooting in more detail.
  • edited 10 days ago
    Ok thanks. I'll report back later on.

    FYI, LO is up to date (6.2)
  • edited 9 days ago
    Thanks for the Java link. I've updated Java to v1.12, no change.

    It looks like the issue only happens with bookmarks not reference marks (I'll add this to the first posting too).

    FYI, (possibly unrelated, but in case it's useful) I have an ongoing issue that the citation box pops up behind the writer screen despite toggling the relevant setting under "config editor".
  • @ilc168 Try the Zotero Beta for the {Citation} bug.
    FYI, (possibly unrelated, but in case it's useful) I have an ongoing issue that the citation box pops up behind the writer screen despite toggling the relevant setting under "config editor".
    It is hard to make the citation dialog pop up reliably over LibreOffice unfortunately, but we know for sure that minimizing Zotero instead of just switching away to a different window can exacerbate the problem.
  • The beta version fixed the bug I listed.

    However, a different issue then arose. I can't delete a citation effectively. Work flow:

    > click "add/edit citation" within LO
    > enter a citation (e.g. "Winter 2018"), press enter and return to working LO document
    > attempt to delete the "Winter 2018" citation via the add/edit citation box i.e. click on citation>add/edit citation>delete "Winter 2018" entry>press enter (or escape)

    The Winter 2018 entry remains. Note, I can go back and edit the "Winter 2018" citation in other ways, such as add other authors, I just can't delete it via the "add/edit citation" box. I can delete it within the LO document with backspace etc but the bookmark remains in the LO document.

    If I try this with the classic citation window, I can remove the citations but there is no option to hit "OK", it's greyed out.
  • Yes, this has never been supported. You're not supposed to edit a citation and leave it empty. If you want to delete it - delete it in text.
  • edited 7 days ago
    @adomasven, noted, thanks.

    However, I assume the bookmark should be deleted along with the text?

    Eg. this is what is happening after deleting in text: https://www.dropbox.com/s/lyol7n2mf6qyycs/Bookmarks Zotero error.PNG?dl=0
Sign In or Register to comment.