«Loading items...» window freezes when opening Zotero in Linux Mint

edited 19 days ago
Zotero used to function very well, and suddenly, when I open it, the «Loading items...» window remains blank, and synchronization fails to complete.

Report ID : 1741938537
Debug output ID : D1155599000
  • database disk image is malformed
    Your database is corrupted. This usually happens if you have your Zotero data directory in a cloud storage folder or on an external drive that you unmount improperly.

    You can try the DB Repair Tool.
  • edited 18 days ago
    Thanks dstillman,

    I am a beginner in both Linux and zotero, but for the last few months, everything was working very well.

    As recommended, I first made a copy of my zotero folder (until now, I thought the synched copy was sufficient...). Then I found the zotero.sqlite file, saved it in another folder, and tried to upload it. Unfortunately I received this message from FireFox:
    "Secure Connection Failed. The connection to the server was reset while the page was loading. The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.
    Please contact the website owners to inform them of this problem".

    What next ? With many thanks.

    NB. I have no "cloud storage folder" except that of zotero.
    NBB. In my zotero bolder, I see two previous versions of zotero.sqlite : .sqlite.bak, and .sqlite.1.bak

  • That likely means your connection timed out — how big is the file? — but you'll either need to figure out a way to upload the database or use the manual repair instructions.
  • the zotero.sqlite weighs only 28.8 Mb.
    However, my archived zotero library is more than 280 Mb. But I am only uploading the much lighter .sqlite file, and the error message doesn't take long to appear when uploading zotero.sqlite.
    Can a beginner securely use the manual repair instructions ?
    Also, when in zotero preferences, searching for the location of .sqlite, I pushed the button "check database integrity", and received the answer that "no errors were found".
  • But are you getting no errors in a database that actually loads and shows you your data?
  • No, I receive this message (no errors) about the database that does not load when I open zotero standalone.
    When i upload zotero.sqlite, i am only uploading 28.8 Mb, not the 280 Mb of my library... as I understand it...
  • I read the documentation carefully, and I am planning something I would like someone to confirm, if possible: I intend to restore my Zotero library using Zotero syncing.
    My local library never loads, but my online library on zotero.org looks OK. I closed zotero and changed the name of the associated local zotero folder. Then I re-opened zotero. Now, as I understand the documentation, if I sync the new zotero instance with my online (zotero.org) library, the latter will be downloaded in my local library. Is that right ?

    Thanks for helping. I am a beginner in both Linux and zotero, and I am very afraid of worsening things instead of improving them ! :-))
  • There's no need to rename the directory and force it to redownload all your files. You can either delete just zotero.sqlite or revert to any previous version of zotero.sqlite with some of your data. When you sync, Zotero will simply download the recent changes.
  • So simple !! It worked perfectly !!!
    Thanks dstillman, and bravo Zotero !
Sign In or Register to comment.