Zutilo keyboard shortcuts and latest beta (5.0.66-beta.5+197d609f8) [FIXED]

edited April 15, 2019
Hello all,

Is anybody else using Zutilo keyboard shortcuts in the latest beta (5.0.66-beta.5+197d609f8)?

Keyboard shortcuts aren't working for me in that configuration.

Bjoern
  • They aren’t working for me either.
  • Would it be fair to assume it's a problem with the beta rather than Zutilo (as Zutilo hasn't changed?)
  • edited April 7, 2019
    Can confirm that there is an issue with Zutilo and 5.0.66-beta.5+197d609f8, (macOS, Zutilo 2.0.4). Zutilo's menu entries in Zotero's right-click window have disappeared and my Zutilo defined short-cuts are non-responsive. The issue may have started before the latest beta, but probably not much earlier; I use Zutilo's menu entries a lot and have only recently noticed their absence. Thanks for looking into this.
  • The Zutilo developer will probably need to take a look, but can you provide a Report ID after triggering this?
  • edited April 7, 2019
    Tried my Zutilo shortcuts and opened the right-click menu (with the missing Zutilo entries). Report ID is 1266670204.
  • Actually I completely lost the Zutilo contextual menu. I reverted back to the last "official" release (https://www.zotero.org/download/), and Zutilo menu re-appeared.
  • This is fixed in the latest beta.
  • Excellent. Thanks for the speedy fix. Zutilo back to normal – menu points appear in Zotero's context menu again, the Zutilo sub-menu is back, shortcuts are working again.
  • Thank you!
  • Has this issue resurfaced with the current beta (5.0.97-beta.29+2fd46157f) and version of Zutilo (v3.9.0)?

    After I specify a Zutilo shortcut key combination, that combination doesn't flag any conflicts but still doesn't work. And it continues not to work even after I restart Zotero, although the action for that key combination does work when performed from the Zotero menu.

    Thank you so much for your thoughts on this issue.
  • @dstark: The issue you're facing shouldn't be related to what has been discussed above. There's no general issue when using Zutilo and the Zotero beta.

    Please explain what you did providing more details. Are you a new Zutilo user? There are some open Zutilo issues, see for example https://github.com/wshanks/Zutilo/issues/122. I think there're also Zutilo issues that might be specific to macOS. If you just have general usage questions, we could try to clarify them here. You could also consider reporting Zutilo issues on GitHub.
  • Thanks @qqbb. I'm running Windows 10 on two machines and having the same issue on both in that Zutilo keyboard shortcuts apparently save but then don't actually work.

    Yes, I have just come across Zutilo recently. But when I'm on the shortcuts tab of the Zutilo preferences dialog box, I can seemingly specify a shortcut for anything (e.g., Ctrl+Alt+Shift+whatever). But after I apply the shortcut and even restart Zotero, that shortcut doesn't do anything.

    The issues at the link you mentioned don't seem to describe this kind of situation.

    Any thoughts about correcting this issue working would be most helpful.

    Thank you so much!
  • @dstark: Here's a script that might help with checking Zutilo's keyboard shortcuts. The first part of the script prints out your current shortcuts. The second part tries to set "Ctrl+L" as a new shortcut for the "Collections pane: Show / hide" function with the preference label "toggleZoteroCollectionsPane".

    Go to "Tools" -> "Developer" -> "Run JavaScript", and paste in and run this code:

    // Part 1: Show current Zutilo keyboard shortcuts
    var msg = `Current Zutilo keyboard shortcuts:\n\n`;
    var keyset = document.getElementById("zutilo-keyset");
    var keyLabels = [];
    var keyValues = [];
    for (let child of keyset.children) {
    if (child.getAttribute("key")) {
    let label = child.id.replace(`zutilo-key-`,'');
    keyLabels.push(label);
    let modifiers = child.getAttribute("modifiers");
    let key = child.getAttribute("key");
    let keycode = child.getAttribute("keycode");
    keycode = (keycode === "") ? null : keycode;
    let value = {"modifiers":modifiers,"key":key,"keycode":keycode};
    value = JSON.stringify(value);
    keyValues.push(value);
    let name = Zutilo.getString(`zutilo.shortcuts.name.` + label);
    msg += `Name: "${name}"\nLabel: ${label}\nValue: ${value}\n\n`;
    }
    }

    // Part 2: Try to set a new Zutilo shortcut
    var keyLabel = 'toggleZoteroCollectionsPane';
    msg += `\n\nNew shortcut for '${keyLabel}':\n\n`;
    var oldValue = Zutilo.Prefs.get(`shortcut.` + keyLabel);
    var newValue = `{"modifiers":"control","key":"L","keycode":null}`;
    var index = keyValues.indexOf(newValue);
    if (index < 0) {
    Zutilo.Prefs.set(`shortcut.` + keyLabel, newValue);
    msg += `old value:\n${oldValue}\n\nnew value:\n${newValue}\n\n`;
    } else {
    msg += `Value: ${newValue}\nis used for '${keyLabels[index]}'!\n\n`;
    msg += `Cannot use this as a new value for '${keyLabel}'!\n\n`;
    }


    Then check if "Ctrl+L" toggles Zotero's collections pane.

    (You don't need to restart Zotero after installing Zutilo or when changing a Zutilo shortcut.)
Sign In or Register to comment.