ZotEZ2 is finally out on the Google Play Store

Dear all,
after a long time in beta-testing, ZotEZ2 is finally available on the Google Play Store:

Here is a recap of all the new features that were missing in ZotEZ 1 and that are now incorporated in ZotEZ2

TL;DR: possibility of connecting through the Zotero API (which means no more debate over whether there are risks of corrupting the library database file), WebDAV capabilities, more user-friendly design for Collections and Tags, filters using combinations of tags...

and still what made ZotEZ great already: fully local capabilities, cloud synchronization for attachements and storage, choice of the SDCard for storing files, ...


Free features :
• **NEW** Syncing your papers' library directly from Zotero servers, and connecting to a WebDav for stored pdf or linked pdf attachments.
• Syncing of your papers' library with Dropbox, Google Drive or OneDrive. Or just accessing your local Zotero copy.
• **NEW** Option to choose from 3 different cloud types regarding the following three types of items: the zotero.sqlite library database, the standard "storage" PDF folder, and the remote "attachment" PDF folder.
• Listing of papers / books and displaying their main information (title, authors, publisher, year published, ...)
• **NEW** Option to display cards with full article info
• Downloading pdfs and notes of a document when available
• Accessing attached links when available
• Sharing the pdf of a document when available
• Searching within references
• Advanced settings:
- resetting library data and reference manager type
- deleting local files

• Local libraries: if you cannot put your library in a cloud, you can copy it on your local Android storage and load it into ZotEZ²! Read our tutorial for more information: https://zotez2.ezbio.net/index.php?p=blog&id=7
• Secondary storage: you can choose to store the downloaded PDFs either on the internal memory or an external SD card!
• (Beta) Fast Loading of papers: if you have a large number of papers, you can choose to load them at the same time as they are displayed, so that you can access them while the others are still loading.
• (Beta) Altmetric scoring.

Extra features:
• Sorting options (by tags, titles, types, authors, etc.)
• Search filter for papers (by tags, titles, ...), authors and collections
• Author’s tab: visualize your library directly from an author's perspective
• Collection’s tab: organize your library with your collection tree
• **NEW** Tag's tab: browse your library from your favorite tags (colors included, combinations allowed)

Important Note: all the extra features are available for evaluation (for FREE) when selecting the option "or try the demo library". You will be presented with a curated set of papers (as well as links to our tutorials) in order to get a glimpse at our cool features.

Future updates :
• Broader data complexity management (multiple libraries, etc.)
• Automatic downloading of entire collections.
• New cool features based on your feedback (email us at info@ezbio.net)

More information, Frequently Asked Questions (FAQ) and Privacy Policy on http://zotez2.ezbio.net/index.php?p=privacy. If you like the app, please rate it and leave a review. Thanks.

To learn how to configure Zotero for third-party Cloud syncing on your computer, look at our tutorial on YouTube:
- Zotero + Mac/Windows + Google Drive: https://zotez2.ezbio.net/index.php?p=blog&id=3

  • There has been a few bugs since the official release, but two updates will have fixed most of them. Here is the update log of the past three days:

    *** 2019-03-11: Major Update (v2019.2.1-b25):
    • Fixed many crashes and potential regressions from b24
    • Under the hood: changes in crash reporting

    *** 2019-03-08: Major Update (v2019.2.1-b24):
    • Fixed crash when using WebDAV on Android Pie (9)
    • Fixed pdf download problems in demo version on Android Pie
    • Fixed some rare crashes when downloading the library directly from Zotero servers
    • Fixed some crashes when loading articles, when attachments had no names.
    • Minor bug fixes.

    Don't hesitate commenting on this.
  • I installed the app, but I can't figure out how can I read an actual paper. I can see all my papers, but if I click on one, it just shows me the metadata of that paper, similarly with what you have on your right in Zotero. That's cool and all, but I also need to be able to read the papers. How can I do this?
  • Hi,
    you have to click on the "file" icon on the left of the Title of the paper. It will open a list of all the documents related to your item, like the notes, attachments, links, etc.
    It works in a similar way as the arrow in the Zotero Desktop app.
    Hope that helps.
  • Hi,
    I I have purchased extended storage and have saved most of my references in a shared folder in Zotero shared with my wife's zotero account which does not have extended storage. Earlier I used to use Z lite on android which I didnt not use much as it took a long time to load but at least I could see the shared folders. I uninstalled Z lite and tried to re install it in my new phone but didnt find Z lite. In stead I found ZotEZ2 which I am hoping will be better but so far I am able to see collections in only my folder even after purchasing the pro. Am I missing some configuration? How do I access the shared folders?
  • Hi,
    You're not missing any configuration. Groups will only be available in the next update, if that's what you mean by 'shared folders'.
    The release date of the next update is 'anytime soon', but I am facing a few problems that prevent me from publishing it right away.
    Thanks for your patience and support.
  • Hi Diyoyo!
    Thanks so much for this! It looks great.

    Quick question - I'm having trouble setting up the file storage sync using 'Syncthing' as a syncing program instead of dropbox (open source syncing software). I use the Zotero site for database syncing. This setup works well across multiple computers.

    However ZotEZ2 can't seem to find the .pdfs, even when 'Main storage location' is set properly to the synced folder as on my other machines. Does ZotEZ2 use the 'relative paths' option in Zotero? Anyone else having issues with this?

    Thanks again,
  • edited May 30, 2019
    This looks good, but I have a problem with the WebDAV. In the settings you ask for the root of the webDAV server. But my installation is actually in a subdirectory, like https://domain.tlp/owncloud
    If I just give the domain, it doesn't have a webdav server to connect to, but when I type in the full url, your programme doesn't seem to accept that. I also tried the whole webdav url https://domain.tlp/owncloud/remote.php/webdav/zotero with and without the zotero at the end, nothing works.
    What can I do?
    I get the idea, explained on your website, that it's easier to type in only the domain, but please can you have the option of typing the whole path too?
  • having trouble downloading files from googledrive cloud folder. I have the same file path for remote attachment location as is listed in my desktop app for linked attachment base directory, but when i click on the file download from cloud icon it says "please set up your remote cloud attachment first"

  • Hi,
    a new update has been release one week ago and should have solved many problems.
    Please let me know if you still experience issues.
    Also, groups and feeds are now available so don't hesitate to let me know what you think about it.
  • Hey, I just tried to install, setup and use the app. I am still having issues with downloading attachments to read.

    Screenshot of error message here: https://drive.google.com/open?id=1NGN8pJl7xNqYW2Tm7XT7Mp-PVHAx61kR
  • Hi,
    are you talking about regular attachments (pdf icon in Zotero) or "linked attachments" (pdf icon with chain link) ?

    In the first case, then you need to use the 1st field (Sync Location) in the 2nd step of the setup (like mentioned for WebDav in the 1st tutorial: https://zotez2.ezbio.net/index.php?p=blog&id=11#fig3

    In the second case, then you need to use the 2nd field (Attachment Location) in the 2nd step of the setup.

    Also, if you are using an academic or corporate GSuite account, it is possible that the Google Drive login will not succeed.

    Let me know whether it helped.
    I have not been able to reproduce this bug so far.
  • Hi, thanks for the reply.

    I am using linked attachments, and believe I set it up correctly.

    I am using an academic GSuite account to store my documents, which may be at the root of the issue.

    I expect that many of the other primary users of Zotero are also at academic institutions and may be using academic cloud services.
  • Hi, I just tested it on 2 academic GSuite accounts and 1 corporate GSuite account with double step authentication, and all of these worked fine.
    Which means there is another bug somewhere.
    Here are my current guesses:
    - maybe you set up so many times ZotEZ2 that it thinks that you already gave it permissions to access your drives (GDrive and/or local phone storage) and does not ask you for it anymore. In that case, a complete uninstall reinstall should help.
    - maybe you are using a plugin like ZotFile which creates a complex hierarchy in the attachment folder, and maybe this is not well taken into account in ZotEZ2 yet (it worked for me using simple /y folders)
    - maybe there are mistakes in ZotEZ2 when parsing the path to your attachments, but this should return error 404 and not 400.

    Please send an e-mail to info@ezbio.net so we can continue the conversation privately.

  • Hi

    I have been using ZotDroid and it works well for me but I am always interested in new developments so I thought I'd try ZotEZ2 for comparison - it looks like it has a lot of nice features.

    I've jotted my initial observations and questions here in case this is of interest to others:

    1. I use WebDav to pCloud for my attachments. Set up in ZotEZ2 is quite confusing and complicated for this, with options which leave me not very confident that I have set it up correctly. ZotDroid configuration seems to be more straighforward and has a helpful 'Test WebDav' button that provides reassurance!

    2. I think I have configured the app correctly: it shows 1294 items which tallies with my library, but ZotEZ2 refers to them as 'Articles' in the header, which is incorrect - they are items.

    3. It was not clear how I get to the metadata for an item but I discovered that a long press appears to to it. Why not just a single tap?

    4. I cannot see or open attachments (e.g. PDFs). How do I do this? It may be that my link to the WebDav storage is not working correctly but how do I tell? I could not find instructions and there is no feedback.

    5. I cannot see 'Notes'.

    6. I cannot see 'Related' items.

    7. I really like the look of the app - it is clean and clear in its appearance.

    8. The additional search and sort options available in the paid version look to be very useful functionality but I cannot comment on them yet as I want to confirm that the basics (points 1-6 above) work before I pay.

    This looks like it could be a very worthy competitor to ZotDroid, providing options for Zotero users on Android. If @diyoyo can help with answers to my points above I look forward to exploring it further.

  • Hi @richard.masters ,
    thanks for your comments, these are really valuable.
    I'll try to answer shortly:
    1. There is a tutorial available here: https://zotez2.ezbio.net/index.php?p=blog&id=11

    2. Sorry for the semantics, I come from another reference management software. You are totally right, they should be referred to as Items. Maybe I'll do the switch in a future release.

    3. It was originally just a one-tap, but this led to unwanted display of the metadata, just when tapping by mistake. Indeed the instructions on this were only disclosed as part of the update's release notes, which are now far away is the update log. So, again, this is a good feedback for improvement: I'll add it to my "tutorial ideas"'s list.

    4. You have to click on the item icon. This triggers a popup where you can choose which attachment you want to open. As for "there is no feedback": there is a feedback button in the "about", "settings" and "labs" tab so that you can ask as many questions as you'd like.

    5. That's not normal, that's a potential bug. please contact me directly at info@ezbio.net to discuss about it.

    6. This option is not implemented yet.

    7. :D Thanks a lot. Even more improvements are on their way but I slowed down a bit their development during summertime.

    8. I hope answers 1-6 are not too far away from your expectations. Also, please feel free to send your opinion on the business model to info@ezbio.net too. I am still looking for the best balance between free and premium features, whether to insert ads or not, etc.

  • Hi @diyoyo - many thanks for the fast and comprehensive reply. I have followed-up via email to troubleshoot to attachment issue.

  • edited August 20, 2019
    Hi @diyoyo.

    I've installed Zotetz2 yesterday, and finally I can open PDF's synced by Onedrive from the Zotero db in my tablet! And I've happily paid to access the full capabilities to support development. However I needed kind of a hack to do so, and it looks like the linked attachments don't work as they are supposed to do.

    I use linked attachments using a base directory and relative paths, and most (or all) of my PDF's are located inside a single directory under the base one (only one level, base-directory/directory). The relative path of every file, with this directory, is shown in both Zotero desktop, browsing the db with a viewer and the web app, in the two latter as "attachments:secondary-directory/file-name.pdf".

    Initially, I had set the "Remote Attachment Location" setting of Zotetz2 as local, with the synce base directory in the desktop app as the directory. However, when I tried to open a pdf, it showed "Error 404. No File Found". I copied a pdf from the secondary directory to the base directory, and created a new linked attachment. After resync, I was able to open that pdf from Zotetz2.

    Later, I changed the Zotetz2 directory to the one where most of my papers are located, and now I can open them! However, this shouldn't work, because the file relative path stored in the Zotero db includes the directory. If it were be an issue with my sync app and how it syncs and manages secondary directories, the files inside a relative directory shouldn't open anyway. Obviously, after the directory changed I couldn't open the copied file used for the first test. However, after copying it to the same directory where the others are (it had a "2" added before linking it in Zotero) and syncing, I could open it now in Zotetz2, even without changing anything in Zotero. So it could look like Zotetz2 uses only the name of the file and not the relative path.

    However, in a previous post in this forum it is mentioned that Zotetz2 supports directories created by Zotfile. I don't know if there is any issue to obtain the attachments' path with Zotero API.

    Right now I have something that works for me, but I think that Zotetz2 should use the path of the files, so they could be classified inside directories. I've only tried local directory, because the files are under a university provided Office365 or Sharepoint OneDrive with a university account, so I can't use the OneDrive option of Zotetz2. I use OneSync to sync this directory.

    Edit: for completion, the database is syncronized by the Zotero account, not locally.
  • Hi @diyoyo! Thanks for continuing to develop ZotEZ and for the major update that ZotEZ2 is. I'm excited to have a much better way to use my Zotero database on my Android tablet. I just got the extra features to help support further development :)

    As a couple of other people above, I'm encountering issues when downloading attached PDFs. I exclusively use Zotero's native file syncing/online database. When I try to download and read a PDF, I get the following error message:

    > The operation has been cancelled! java.io.FileNotFoundException: https://api.zotero.org/users/4719589/items/PAVLDUM7/file

    Could you please shine some light on why this might be happening and how I can solve it?

    Thank you so much!
  • @richards and @milacsantana, I'll have a look soon.
  • #BackToSchool September-only Discount on your @zotero client for #Android : get up to 35% off* on the Full Premium Pack, in addition to the current 20% off.
    Pack includes all the features: Sorting, Search, Authors' tab, Collections' tab and Tags' tab!
  • I'm very much enjoying the app, and looking forward to continuing improvement. My apologies if this has already been covered. Is there a way that attachments downloaded and annotated on my tablet can then replace the file in the cloud? I would like an easier way to save annotations to the attached pdf, rather than finding the file in the directory after downloading from ZotEZ2, sending it to my PC and then replacing the attachment manually.
  • First off all; Thank you for the app! It is already quite well in the direction of what is needed. I first had some troubles with my own setup; but that is working now thanks to your blog and this discussion. Perhaps this info can be more integrated in the app, since I don't like giving up and that was the only reason I kept on redownloading the app and retrying.

    I definitely want to add my voice to the request of Pettigrew; this is also a big one for me. After that, I really can use it on my ereader; giving some rest for my eyes and the trees.
  • Hi, I have the same problem with connecting to my owncloud webdav as reported by Smathhie on May 30th; coukd you please help.?
  • Hi @diyoyo

    I notice that you have released a couple of updates to ZotEZ2 - fixing a bug with logging into WebDav and another about attachments.

    This continued development really is good to see.

    However, I am unsure why the issues I am still having - not being able to download attachments from my 'Main Storage Location' (Webdav) or 'Remote Attachment Location' (OneDrive) - remain unfixed.

    This is extremely frustrating and I wonder how many other customers are having these same issues. I am very happy to supply information to help debug this (as you know) so do let me know if I can help.

    Best regards,
  • I face the same issue, my pcloud webdav does not synchronise attached files. I emailed the developer a few weeks ago but after a few emails I wasn't able to find if he was able to reproduce the bug.
  • Hi @diyoyo

    I wonder if you have checked for any limitations that my library might have exceeded? My libary has 1500 items, most of which have attachments in pCloud & OneDrive. What size library have you tested against?

Sign In or Register to comment.