Zotero Data Directory migration (has files, but shows blank)

Hello and sorry if this has been asked before (I did my best to check, but found nothing, if the answer to my question has a link, please let me know).

I started using Zotero around 2014-2016 and even have a synchronized account under this username (except it doesn't seem to have the pdf files anymore). Last I recall I was using it with the Zotero standalone of that time (can't recall the version, but it was around 2015). At some point, I stopped using it but had tons of notes attached to the PDFs that I studied. I decided I'd save my data folder because I wanted to use it later.
Fast forward to today.
I downloaded the latest version (5.0.58 mac 10.13.6 highsierra) and tried to point Zotero to the directory (it was not in the home location but in a google drive directory that I'd intended to share with other machines, but not yet, at least not till this works). Zotero seems to know the data directory is correct because it does not complain when I select it. This directory has the following files
zotero.sqlite (5.1mb)
zotero.sqlite-journal (426.6kb)
zotero.sqlite.1.bak (1.1mb)
zotero.sqlite.77.bak (1.1mb)
zotero.sqlite.bak (5.1mb)
ZoteroTemp.rdf (1.4mb)
and the following folders
files , locate , pipes , styles , translators
I read on some troubleshooters there should be another folder, but this is all i have.
my pdf files are all in the 'files' directory and it seems the ZoteroTemp.rdf file has copies of my notes (seems like it).
the problem is when I open up my Zotero program with this data file that it seems to know exists, the "My Library" folder (the only one that shows up) is the one you get when the program is new without data ("empty"). there is no sign of any of my pdfs or my notes.
I was even wondering if maybe my sqlite file was somehow overwritten with one that tells it it's empty despite having my pdfs there!
I even moved the data folder to my home directory so it will be in the DEFAULT location, but no dice.
what am i missing?
thank you!
  • A 5 MB database can be empty, and if there's no 'storage' directory, this almost certainly wasn't the data directory you were using before. So you should look elsewhere on your computer to see if you can find another one.

    "ZoteroTemp.rdf" and "files" also don't belong there. That would've been an export you did at some point — possibly in lieu of a full backup of the data directory. So if you can't find another data directory and it looks like all your files are in 'files', you can make sure auto-sync is off and then import that into an empty database and see how it is, and if it has all your data replace the online library from the Sync → Reset pane of the Zotero preferences. Note that with an import you'll lose any links to citations in existing documents as well as the Date Added/Modified time of the items.

    Ideally, though, you can find the data directory you were using before.

    Either way, you'll want to make sure you keep the data directory out of Google Drive if you're pointing Zotero at it, or else you'll corrupt your database.
  • it seems the import suggestion you offered worked. thanks!
Sign In or Register to comment.