Citations not updating on refresh

This discussion was created from comments split from: Word does not refresh the changes made on Zotero standalone.
  • edited November 13, 2018
    I would like to give this topic a little push.

    I'm having the exact same problems which can be solved by deleting and re-inserting the refrence.
    This is a lot of work for a long document and seems rather akward.

    I tryed to create the same problem with a new document and just one citation but there it seems to work fine.
    I assume that this problem only occurs after working on a document for a while.
    I'm not sure if an update of zotero which may have happend during that time could cause this problem or where it originates from.

    I really like using Zotero but this is a serious issue so I would really appreciate it if someone could help finding the reason for that issue.

    Thanks in advance!

    I've realized that some of the citations do refresh, meaning that they 'communicate' with zotero and get changed.
    The ones that do are the rather recently added refrences.
    So it doesn't seem to be a general problem with the file or the way of importing them or something but really that the 'old' citations are disconnected from the zotero library in some way.
  • Note that the thread you posted to was from over 4 years ago — in cases like that it's almost always better to start a new thread, since the problem you're experiencing is quite likely different.

    First, what OS and exact word processor version is this?

    If you put your mouse in one of the citations that's not refreshing, is it highlighted in gray? If this is Word and you right-click on the citation, do you see "Toggle Field Codes" as an option? If they're not active, this could've occurred if the document was opened and resaved in another word processor (e.g., Google Docs).

    If they're still active, you may have made manual edits to the citations in the document — instead of in Zotero — and told Zotero not to overwrite them when prompted. In that case, I believe changing the citation style to another style and back would cause those to be updated, though someone can confirm that.

    There could be other issues, but we'd need more details to say more.
  • I'm using Windos 7, Word from MS Office Professional Plus 2010, Version 14.0.7224.5000 (32-bit) and Zotero 5.0.54.

    Yes the citation is highlighted in grey and when I press Edit citation the Zotero interface opens where I can see the citation.
    I do get the option to Toggle Field Codes as well.

    I haven't done any manual changes to them as far as I remember but I also changed the style to a completley different citation style (Elsevier - Harward in this case) and changed the name of one of these citations in Zotero, then refreshed the bibliogrpahy in the word document and still nothing changes.
    The option 'automatically update changes' in the word pluggin is also enabled by the way.
  • Start by upgrading to 5.0.58 — 5.0.54 is outdated.

    If the citation was set not to update, when you press Add/Edit Citation on that citation and then press Enter, I believe it should override it and revert to automatic updates (at least as long as you're using the default citation interface with the red bar and not the "classic" interface). We can debug it further if that's not happening with the latest version.
  • If you're updating items in your Zotero library and the changes are not reflected in the document it means that the cited items in your document are not linked to any items in your Zotero library. This could be due to a variety of reasons:
    1. You originally cited the items in the document with Mendeley
    2. You had duplicate items for the same article and cited one, but deleted the other one
    3. You accidentally removed some items from your Zotero library at some point and added them back later

    Whatever happened, there currently is no automatic process to relink cited items that are not connector to items in your library, so manually reinserting is your only option.
  • Thanks for all your responses.

    I've updated but that didn't fix the problem.
    Manually editing the citations in the red bar (so deleting the 'old' citation and re-adding it) does solve the problem as mentioned before.

    1. I've never used Mendeley
    2. I'm quite sure that this is not the reason since that was the case for all my citations (about 70) and I certainly didn't have duplicates of all of them
    3. Again this seems unlikely that I've deleted all of them

    You are certainly right that they are not connected with the library but this must have happend through a complete disconnect of all the citations at once.
    I belive that this may have happend when I switched from using my laptop to edit things to doing it on my work computer.
    Back then I didn't use the sync function via the online account but I've exported the library on my laptop and imported it to the computer.

    Can you confirm that this could be the reason?
    What is the best way of handling such a switch from one device to the other or working on multiple devices at once?
    Would synchronizing the libaries via the online account avoid this problem?

    Thanks again!
  • The export and import indeed would be the reason. If you don't want to sync your library, you can copy the Zotero data directory from one computer to another and Zotero will pick it up for you.

    If you still have access to your previous computer and the data within, you can still do this, as well as restore an older version of the doc where the items are all linked to your original Zotero library.
  • Back then I didn't use the sync function via the online account but I've exported the library on my laptop and imported it to the computer.
    yes, that's absolutely the case. Export/import breaks the link between a Zotero library and citations in Word documents (in technical terms, it doesn't preserve the internal identifier).

    Both options described here: i.e. syncing or moving the data directory, do not have that problem.
  • Alright, thanks a lot! :)
Sign In or Register to comment.