Problem enabling group file syncing

This discussion was created from comments split from: Syncing problems with group libraries.
  • Still not seeing the stored copies of references I copied from my own library to the group library. Here is what I have:
    1) I own the group library
    2) Got data and file sync enabled
    3) Have an unlimited file storage plan
    4) all references have an attached stored copy of the file in cases where a pdf had to be associated with a parent item.

    Why do none of my referenced files end up in the group library?
    Thank you!
  • (generally better to start a new thread, especially since this one is 1 1/2 years old)

    Let's start with: can you manually attach a file to an item once it is in the group library?
  • The "attach link" and the "attach stored copy" is grayed out, so no, I cannot.
  • On this website, click on "Groups" at the top. Then, right below the group in question, click "Manage Library"
    At the bottom of that screen, what is selected under "File editing"?
  • No group file storage.
    When I change it to "any group members"
    I am getting an error: "There was a problem saving your settings."
  • OK, so this is the reason dragging items with attachments doesn't work. Obviously the error message shouldn't occur, though (or at a minimum it should be more helpful). What type of group is this (private, public/closed, public/open)?
  • After reading about issues with group libraries not syncing the document attachments, I switched it from initially public to private.
  • and you're still getting that error when you try to enable file storage?
    @fcheslack I think that's you?
  • Probably.
    I can't reproduce any trouble switching between various group settings states. It's possible it was a temporary problem modifying the group. Let us know if you still get the error when trying to enable file storage.
  • Thanks @adamsmith.
    I switched to private group.
    I still cannot drag and drop any parent items with the associated child pdf from MyLibrary to the Group, without losing the child item.
    I can however, manually re-attach the child item using the "attached stored copy of file" but it seems like this should be automatically done when moving any parent item into the group folders.
  • edited October 31, 2018
    The way things currently work, if the item already exists in the group library, you'll need to delete it and empty the trash, and then drag again.
  • edited November 1, 2018
    Well, after deleting all items in the group library, I made sure all trash is empty.
    Still not taking the child items with the drag and drop.
    Note, there are still items in "unfiled items" (whatever those are) in the group library.
  • Unfiled items are items that are not in any collection.

    Could you try the following:
    1. Create a new item in "My Library"
    2. Attache a PDF
    3. Drag that item to the group

    Does that work?

    If it doesn't, check in your Zotero preferences in the General tab. At the bottom it says under "Groups" -- "When copying items between libraries...". What are the settings there?

  • edited November 1, 2018
    I crated a test parent item and attached a stored copy of a file, then dragged that item to the group library. It worked.

    Now, having learned from this here is what I did.
    1) deleted all the existing folders in the Group library, emptied trash
    2) create a new folder in Group Library.
    3) drag and drop seven items that each contained a pdf attachment from MyLibrary into the newly created folder in Group Library

    Result: Only 4 out of the 7 items now in the Group Library, still contained the attachment after the drag-drop.

    Edit/Preferences/General/Group: all four selection options are selected
  • deleted all the existing folders in the Group library, emptied trash
    Did you delete all items, or just all collections? Again, if any items were previously dragged to the group without attachments, you'll need to delete them and empty the trash for the new copies with attachments to transfer.

    (We'll be improving this, but this is how it works at the moment.)
Sign In or Register to comment.