Zotero unable to load translators and styles

Hi. My error code is: 1462009180

My zotero has suddenly become unable to load translators/styles. I am unsure how this happened. I use a default folder for the database. I have tried resetting styles/translators in settings, didn't work. I have tried re-installing zotero, didn't work. I have tried changing to a new folder, but whenever I do this, nothing happens - it keeps using the same default folder.

Any ideas?
  • Zotero is getting a very generic error when trying to write in the data folder. This could be interference from a security software, wrong permissions on the data folder, etc.

    A Debug ID from Zotero for translator/style reset might shed more light:

    1. In the Help menu, go to Debug Output Logging and select Enable.
    2. In Zotero preferences click the button to reset translators and styles and wait 30s.
    3. Return to Help → Debug Output Logging and click Submit Output, which will disable logging and submit the output to zotero.org. A window should pop up containing a Debug ID. Click “Copy to Clipboard” and paste the Debug ID into this forum thread.
  • Hi,

    Thanks for this! I did it and the debug code is: D941699465

  • Have you tried restarting your computer? Do you run any security software?
  • I tried restarting (I have also restarted word and zotero several times); I run security software - I can try with it turned off...
  • [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsILocalFile.create]" nsresult: "0x80004005 (NS_ERROR_FAILURE)" location: "JS frame :: chrome://zotero/content/xpcom/file.js :: Zotero.File</this.createDirectoryIfMissing :: line 999" data: no]
    I'm afraid there's not much more we can tell you. Zotero is just getting a generic error from the system when trying to create a directory, so something on the system — likely some form of security software — is preventing it from writing to the disk.
  • edited October 18, 2018

    Thanks for the help. I'm not sure how this has happened, as it never has before... I only use windows defender.

    The weird thing is that database the folder is in a network drive (which I know is not recommended), but I can't even change it - Zotero reboots when I try, but then keeps using the same folder!

    Edit: I tried disabling the security software, rebooted, ran Zotero as administrator (after checking it has permission to read and write), and the error appeared again. I tried doing the debug one more time, with the ID: D1234105527

    Does this make the error clearer?

  • Oh, if this is on a network share that's the problem.

    Don't run Zotero as an administrator. (You might've actually caused more future problems by doing that.)

    With Zotero closed, move your data directory to the default location on your local hard drive, which is "Zotero" in your home directory. When you next start Zotero, it should notice that your custom data directory location is missing and offer to use the default version instead (though depending on your exact setup, you might run into other problems).
  • (Zotero can work with the data directory on a network share, but it entirely depends on the specific share and how well it emulates a real hard drive. If you're having trouble, the only real option is to move it off.)
  • This worked.

  • Same problem as abouve D723652927
  • Win error 5 during operation open on file C:\Users\[…]\AppData\Roaming\Zotero\Zotero\Profiles\jq8h4hjc.default\addonStartup.json.lz4.tmp (Access is denied.
    )" {file: "resource://gre/modules/DeferredTask.jsm" line: 313}]

    [JavaScript Error: "Component returned failure code: 0x80520015 (NS_ERROR_FILE_ACCESS_DENIED) [nsIZipReader.extract]" {file: "chrome://zotero/content/xpcom/schema.js" line: 1172}]
    You're getting various permissions problems, both in the Zotero profile directory and the Zotero data directory. Security software on your computer may be interfering with Zotero's ability to perform certain operations.
Sign In or Register to comment.