Error 864127696

Two computers use Zotfile to connect to a NAS drive via WebDAV. The computer on which this error occurs is trying to sync data that were updated on the other computer. The data includes (a) metadata in Zotero on the other computer and (b) documents stored on the NAS drive.

I've tried this several times, and this error occurs repeatedly.
  • Your WebDAV server returned an HTTP 403 error for a PUT request.

    If you receive this message repeatedly, check your WebDAV server settings or contact your WebDAV server administrator.
  • @dstillman
    I've met with this bug for many, many times, and finally I figured out a way to fix it. Maybe you can deduce what was happening through the way I solved it.

    In fact, more frequently I got this error:

    WebDAV server returned an HTTP 403 error for a GET request

    as I mentioned in this thread:

    When I opened the zip files indicated by the error report, usually what was happening was that there were two pdf files, one has normal size, the other has the size of 0 byte. When I found the file in my Zotero interface, the little blue dot indicating there are attachments is hollow. If I delete the attachment through 'right click -->move to trash', most of the problems are gone, though I don't have the attachment anymore. Sometimes I would go to my WebDAV and find the zip file as well as the prop file and delete them. After fixing all of the mentioned files in the error report, there was no error anymore.

    So I think this is a problem of the program, not my WebDAV provider. Because even though this error occurs, I can still sync other files without 'zero-size' problem.
  • edited July 19, 2018
    A 403 error is an authentication error from the WebDAV server. It's not a problem in Zotero. For a GET that error happens before Zotero downloads anything, so the contents of the ZIP file are irrelevant.
Sign In or Register to comment.