Zotero Standalone for Windows opens a blank window

It started today when I updated my NVIDIA driver. Now, whenever Zotero opens, it is a blank window with only close and minimize buttons. Is there any technical error with Zotero or is a problem specific to my computer and settings?
  • Hi, I'm having the same issue. I've tried to roll back the Nvidia driver without success. There's obviously something happening in the background as I can add citations in Word and if I click and drag in the blank Zotero window I see the 'highlighted' reference entry.

    Windows 10 Home - Version 1803
    OS Build 17134.137

    Nvidia - 1050ti graphics
    Driver version - 391.35 (also tried 391.36)

    I've tried reinstalling the graphics drivers and Zotero without luck. I can't say I've been impressed with the NVidia driver process so far - I've had previous issues following upgrades, but they've largely been solved by reinstalling manually.

    Any help or guidance would be greatly appreciated.
  • edited July 6, 2018
    You can check whether it's related to this issue.
  • Thanks for the prompt reply. The issue was resolved today by removing another software package from my desktop called Duet Display (allows the use of an iPad as a second monitor). Zotero worked perfectly. I then reinstalled Duet and the problem reappeared, so it seems to have an adverse effect on Zotero. I add it here in the event someone else experiences similar issues.

    Over the last 6 months or so I've experienced some relatively minor problems that I attributed to the Nvidia drivers, but I suspect the problems may actually be a combination of the Duet software and Nvidia drivers.
    Thanks again.
  • @damianmcf you do me a big favor,exactly as you said´╝îI solved it by Disable discrete graphics(1066),not the best approach but you can both use duet and zotero same time,maybe you can use Nvidia panel to select which app to use the discrete card,I haven't try whether it works since I can' t open my Nvidia panel now,:P
Sign In or Register to comment.