Freeze issue in Windows 10 1803 when use UTF-8 as default code page

Windows 10 1803 (April 2018 Update) introduced a new feature, "Use Unicode UTF-8 for worldwide language support", it can be found in "Region" - "Administrative" - "Change system locale" - "Region Settings". When it enabled, Zotero will freeze after launch.
  • How reliable is that? As in, if you disable that, it works, and if you re-enable, it freezes, and back and forth?

    There've been numerous reports of freezing after the April 2018 update, which appears to be a general problem affecting many apps that was fixed in the latest version. So make sure you've updated to OS Build 17134.48 or later, and post to that thread if you're still having trouble.
  • It's pretty reliable. I disable that, it works, and I re-enable, it freezes. I have the latest version of both Windows and Zotero. I don't think it's the same question of your links, because this option is not enabled by default.
  • edited May 18, 2018
    +1, I have exactly the same issue. Windows 10 Pro 64-bit 1803, OS Build 17134.48 and Zotero 5.0.47. Freshly installed Zotero freezes when `Beta: Use Unicode UTF-8 for worldwide language support` option is ticked under `Region Settings`.

    No other app or program seem to be affected, for me it's just Zotero that misbehaves at this point. On the other hand, LibreOffice, which also picks up language settings from the OS locale AFAIK, works fine regardless. Needless to say, deselecting that option allows for Zotero to start normally too.
  • Hi, I can also confirm that disabling UTF-8 support fixes problems. It seems that when Microsoft says "beta" means "not really working but let's wait and see"...
  • @mu-sick If it is working for most apps except Zotero and maybe a few others that we have not heard of, that is a good beta.
  • You are right, I may have rushed to conclusions...
  • +1, I have exactly the same issue, it bothers me a lot this week until I found this page, disabling UTF-8 support fixes problems, pretty happy now. Thanks and Cheers.
  • Reproducible with Juris-M.
  • I have this problem. My Zotero was freeze immediately after 1803 update for Win10 successfully. It is resolved by this method. I waste 4 – 5 hours for this issue.
  • I can confirm it too and also that I have found a second affected application (Citavi).
  • Here I had the same issue with Zotero 5.0.51 with Windows 10 Pro 1803 Build 17134.112. And disabling the beta feature solved the problem.
  • edited July 9, 2018
    Also having this problem (but not when I disable the beta feature again) on Windows 10 Pro 1803 (Build 17134.137) with Zotero 5.0.52. Specifically, the freeze happens while the Better Bibtex extension says, "Waiting for Zotero database..." Maybe this is a problem with an existing database not matching the expected codepoint?
Sign In or Register to comment.