Citations in LibreOffice not working

Hi all,
I am having an issue with the citations in LibreOffice. After I do the RTF scan in Zotero and open the document in Libre, I click the "set document preferences" Zotero link. The citations are then all converted to the format {citation} (literally says citation, not the author, year for APA format) and I get an error message that says Zotero encountered an error. "IDX is not defined."

Any suggestions on what the problem might be and how I might resolve it? I am using the most recent version of Zotero and LibreOffice 5.4.6.

Thank you.
  • I assume that's ODF Scan, right?

    Which Zotero version exactly (under Help - About Zotero)?

    And can you replicate that with a super simple document with just 1 or 2 citations?
  • Zotero version 5.0.47. Yes, ODF scan.
  • I tried reproducing the problem with only 1 citation in a document. But that worked without a problem. In other words, after I did the RTF scan in Zotero and then updated the citations in Libre to APA format, the citation marker was properly updated to reflect APA in-text citation format.
  • The error is related to this:

    If I had to guess, one or more of the citations you link to are not actually in the Zotero library you're citing from and instead of failing gracefully, the current iteration of the Word add-on is throwing an error.
  • Thank you, @adamsmith. I'm assuming there is no way to figure out which citation is causing the problem?
  • @adamsmith, disregard my last comment. Libre is now picking up the problematic citation and giving me the option to replace it. Libre was not doing this previously which made it a guessing game as to which citation marker was the problem. I think I'm all set now. Thanks for your help!
  • Actually, now Libre is sporadically identifying the problematic citation. Sometimes it gives the error message only (IDX is not defined) and sometimes it will highlight the problematic citation and give the option to replace it. Given that, it seems this is probably a Libre problem, and not a Zotero problem.
Sign In or Register to comment.