Zotero is ignoring Word Bibliography style format

I am having the same problem this person had, except I have the latest os x, word 2016 and zotero. I have followed the zotero guide to update the Style, but Zotero ignores it whenever I refresh.

which was:
'I'm using Zotero 1.5 Beta and the Word for Mac 2008 alpha plugin (I'm running the most recent versions of Leopard, Word, and Zotero; all just freshly installed). When I add citations, they do not take on the formatting style of the surrounding text. This is true in footnotes and bibliography. When I block the text and then change the style to match the surrounding text, that works only temporarily. As soon as I use Zotero's "refresh", it all reverts back to Time Roman. In the footnotes, this is even worse, because changing the style eliminates all italics.'

The final post from the thread is from two years ago and is a lengthy workaround. Has this been fixed to work without a workaround please?
  • edited January 27, 2018
    This is a bug caused by the just-released new version of Word for Mac (16.9.1)—unrelated to the older thread.


    As a workaround until the bug is fixed, you have two options:
    1) Click Document Preferences in the Zotero tab and change "Store citations using" from Fields to Bookmarks. Bookmarks are more fragile than Fields and aren't generally recommended, but they will format correctly for the time.
    2) Set the Bibliography style in Word how you want it (font, spacing, indents, etc.), then select all of the bibliography text and click that Style in the Word Styles pane.
  • Thanks. A new problem surfaced around this time, not sure if related, where Zotero seemed to 'forget' the citations. So when I would change citation style, say from APA to IEEE, in document preferences, it wouldn't update the references, footnotes or bibliography. I 'fixed' this by loading it on Windows and manually deleting each reference and reinserting it... which wasn't enjoyable! :)

    I will probably just not touch it on Mac now :(
  • I had a similar problem. Windows, Word 2013 and Zotero 5.0.47, using APA 6th edition as format.

    Solved it other way:
    1.- Opened "Document Preferences" in the Zotero tab.
    2.- Changed Language to "English (US)".

    That did the trick.

    Didn't change "Store citations using" from Fields to Bookmarks...
  • I have this problem too, using Word 365 + Zotero Standalone. Changing the document preferences to store citations as bookmarks fixes it, but I don't find that an ideal solution and would rather store them as fields for easier sharing of documents with others.

    Any updates on this?
  • Hi,

    I encountered the same problem and the only way I found of avoiding it is to change the corresponding Word styles before introducing the citations and the bibliography.
    Basically, when you start working on the document.

    Hope this helps.
Sign In or Register to comment.