Plug-In Issue: "Word could not communicate with Zotero."

Hi there,

Since getting a new computer, I have been unable to connect Zotero and Microsoft Word and now receive the error message "Word could not communicate with Zotero. Please ensure that Zotero is open and try again," whenever I try to insert a citation or bibliography, though Zotero was open at the time of trial.

I've reinstalled both Zotero and the plug-in and still am having no luck. Any suggestions are greatly appreciated as I get to work on a paper!


  • Does the Zotero for Word add-on show as enabled under Tools--> add-ons in Zotero?
  • Hi Adam, yes, the add-on is enabled. I tried disabling then reenabling, but still no change.
  • Could you submit a Report ID?
  • @adomasven Report ID: 1659933333
  • Also tried to debug - Debug ID: D679396277
  • How about a startup Debug ID from Zotero?
  • @adomasven Debug ID: D679396277
  • What version of Word are you on?
  • Place this file in Word Startup directory. After restarting Word you should see an "add-ins" tab, with Zotero actions. Pressing the action should display a prompt with some text. Please copy that text and paste it here (if there's sensitive information like your username you can *** it out).
  • edited December 15, 2017
    export Apple_PubSub_Socket_Render="/private/tmp/"
    export CFFIXED_USER_HOME="/Users/*****/Library/Containers/"
    export HOME="/Users/*****/Library/Containers/"
    export LOGNAME="*****"
    export OLDPWD
    export PATH="/usr/bin:/bin:/usr/sbin:/sbin"
    export PWD="/Users/*****/Library/Containers/"
    export SHELL="/bin/bash"
    export SHLVL="1"
    export SSH_AUTH_SOCK="/private/tmp/"
    export TMPDIR="/var/folders/3h/xff0lp7111vb88jvk98y1zpc0000gn/T/"
    export USER="*****"
    export XPC_FLAGS="0x0"
    export XPC_SERVICE_NAME="0"
    export __CF_USER_TEXT_ENCODING="0x1F5:0x0:0x0"

    @adomasven is this correct?
  • (there's nothing dangerous about this, but you still have your username in line 4 above, in case you care)
  • You may remove the file.

    So this is really weird. With Zotero open if you open the terminal (in Applications/Utilities, or find it via spotlight) and paste
    echo 'MacWord2016 addEditCitation' > ~/Library/Containers/
    what happens?
  • @adomasven the "Zotero - Document Preferences" window opens to set citation style. after selecting my preferred style and pressing "ok," the quick citation bar pops up that you would typically see in word when inserting a new citation. when I try to insert in word, however, I'm still receiving the original error message.
  • What version of the Word extension do you see in Zotero Tools -> Add-ins?
  • @adomasven Zotero Word for Mac Integration 5.0.3.SA.5.0.31
  • HI All,

    can anyone assist me with a similar problem, I have a mac and word 2017 and am unable to get word to communicate with Zotero. Any advice?
  • I am having the same issues, with Mac and word 2017. Zotero shows up as an add-in in Word but does not communicate with Zotero. Running Zotero Word for Mac Integration 5.0.3.SA.5.0.32. Tried restarting and reinstalling multiple times with no luck. Thanks.
  • which Word version exactly? 15.41? Something else?
  • Yes 15.41 (171205)
  • I am having same problem. It is getting very frustrating, I have tried multiple ways to try and fix it. Can anyone help with this?
  • @adomasven -- this seems like it might be a 15.41 issue -- suddenly a lot of reports by Mac users.
  • @adomasven Yes, 15.41 is what I'm using as well.
  • Just for some more information—I'm also running Word 15.41 (171205) on High Sierra 10.13.3 Beta (17D20a). The Zotero integration (Zotero 5.0.32-beta.2+7d98f04bd; Integration 3.5.14.r10158) is working fine for me.
  • @eanimmons could you go to the Word startup folder, zip the Zotero.dotm file and email it to with a link to this thread?
  • edited December 20, 2017
    For everyone else, who have checked that Zotero Word for Mac Integration is present in Zotero Tools -> Add-ons and Word, you have Word 15.41, are on High Sierra 10.13.2 and it still doesn't work: could you go to the Word startup folder zip the Zotero.dotm file, email it to, include a link to this thread in the email and then post in the thread here?
  • I tried all the above and still getting same message that it can not communicate. After I zipped it it just opens up to a blank word document, there is nothing to email or share on this link.
  • Also, how do you know if you are on High Sierra 10.13.2 ? I am Word for Mac 15.31 (170216)
  • @jenieery You should update Word -- the newest version is 15.41 and we know versions before 15.38 to have problems with add-ins in general.
  • @adamsmith I update to Word 15.41, but now the zotero and Add-ons tab in word is gone. What next? Thanks
Sign In or Register to comment.