Your Zotero profile cannot be loaded. It may be missing or inaccessible (Windows)

I've been a long-term Zotero user via the firefox plugin. Having now been forced to change to the stand-alone version, I cannot get it to run. I've tried installing both version 4.0.29.17 and 5.0.29 and for both the only thing Zotero produces is a dialogue box with "Your Zotero profile cannot be loaded. It may be missing or inaccessible." Really anoying!

I'm on Windows 7, and yes Zotero will happily create a "Zotero" subdirectory in both my AppData/Local and AppData/Roaming directories - but it leaves these empty except for a further Zotero subdirectory. I've tried all the things suggested on various forums including -ZoteroDebug or -profile flags on the command-line, deleting the directories and letting it recreate them, putting in a dummy profiles.ini file, all to no avail.

Any ideas on how I can at least get a sensible error message (or preferably a fix to make Zotero start)?

  • Have you tried temporarily disabling any security software you're running?
  • This is a Mozilla message, by the way, so any troubleshooting advice you find for that message pertaining to Firefox would apply here as well. But really it just means something is preventing Zotero from accessing that directory properly.
  • Not running any special security software. However, given that Zotero can create the directories, surely it can put stuff into them. Whether it's the Firefox part of the code or something else, there must be some way to figure out what it can't do or to manually create whatever it is looking for. I've tried all of the firefox flags from the command line but none of them have allowed me to get past this first error box. As it is, Zotero is completely unusable for me :-(
    only option I have is to go back to an earlier version Firefox to run the old zotero within the browser. Not really an ideal solution.
  • I'm afraid there's not really much else we can tell you. This obviously works fine for the vast majority of people, so it's something particular to your system that you'll need to debug. Bear in mind that people have been using Zotero Standalone for the last 6 years, so if this were a standard problem with a standard solution, we'd know about it.

    If you have a Firefox installation, you can try copying its Profiles folder to C:\Users\:username:\AppData\Roaming\Zotero\Zotero\Profiles and seeing if that works. (If so, you can clean it up a bit after.)

    Failing that, you might be able to monitor disk access with a separate tool (e.g., DiskMon, though I'm not sure if that shows the actual files that a process tries to access).

    (There are also some low-level logging options for Mozilla code that you could use if you have Cygwin installed, but if you don't know what that is, it's not worth worrying about, since it's pretty complicated and unlikely to actually show anything useful.)
  • For anyone else struggling with this: the solution turned out to be manually editing permission flags for directories that Zotero created. Not sure how it happens that Zotero can create a directory but not able to create any files within them, but turning on "FullControl" within the "Security" tab of the AppData/Local/Zotero folder properties and running Zotero in administrator mode seemed to do the trick (not sure which of these was the crucial step).
  • edited December 14, 2017
    Just to note for others who come across this, you definitely shouldn't need to run Zotero in administrator mode, and we strongly discourage it (both for security reasons and because, once you do, it becomes much more likely that you'll need to do so in the future to fix other problems, unless you correct a lot of file permissions). The fix here would just be figuring out what's preventing your current user account or Zotero from being able to write to the profile directory (within C:\Users\username\AppData\Roaming\Zotero\Zotero\Profiles) or the cache directory (within C:\Users\username\AppData\Local\Zotero\Zotero\Profiles). That could be permissions, the Windows Read-Only attribute, or security software.

    Again, the code here is from the underlying Firefox components that Zotero uses — Zotero's own code isn't even running at this point. It's possible that some security software could flag Zotero as being part of Firefox and prevent it from writing outside of expected Firefox locations, but that's purely speculation.

    Also note that this error is entirely unrelated to the Zotero data directory at C:\Users\username\Zotero.
  • edited May 31, 2018
    Hi all,

    After updating to Zotero 5.0 on macOS 10.13.4 I too got the dreaded "*Profile missing* Your Zotero profile cannot be loaded. It may be missing or inaccessible."

    The profile folder at ~/Library/Application Support/Zotero has the usual (and right) permissions. I have no special security software installed, but am running the default macOS security settings.

    Besides the current thread, I've looked into a couple related ones:
    https://forums.zotero.org/discussion/68433/your-zotero-profile-cannot-be-loaded-it-may-be-missing-or-inaccessible
    https://forums.zotero.org/discussion/68736/profile-cant-be-loaded-after-installing-zotero-5-0-on-linux

    The otherwise extremely helpful guru dstillman has unfortunately not been able to help anybody with this problem, pointing out that it must be a user problem. I doubt that. I suspect it is not a one-sided, but rather a multi-faceted problem in the way that Zotero tries to interact with my computer.

    The only way (for now), how I've been able to get Zotero to run is by calling it as a superuser from the terminal:
    sudo /Applications/Zotero.app/Contents/MacOS/zotero

    As dstillman points out above, that is far from desired, but it will give me access to Zotero on the short run while I figure out what is going wrong in the interaction between Zotero and my computer. Wish me luck.

    cheers,
    Lennart
  • The otherwise extremely helpful guru dstillman has unfortunately not been able to help anybody with this problem
    You just linked to two threads where we resolved the person's problem.

    The problem is as I say in my previous post above: something preventing Zotero from writing to either the profile directory or the cache directory. You don't say if you checked the latter.

    Rename both /Users/:username:/Library/Application Support/Zotero and /Users/:username:/Library/Caches/Zotero to Zotero-Old and try again as a normal user.
  • Brilliant, that brought me on the right track. I had not noticed a mention of the cache directory in the threads or knowledge base. But your swift response helped me identify the issue.

    The /Users/:username:/Library/Cashes folder was owned by the 'root' user, not by :username:. With the permissions set to 755 that did not allow Zotero to access the cache directory when run as a regular user. Changing the permissions to 775 (or changing the owner, of course) gave Zotero access and solved the problem.
  • Hi,

    I have the same error message, but the two Profile folder mentioned above are empty [the profile directory (within C:\Users\username\AppData\Roaming\Zotero\Zotero\Profiles) and the cache directory (within C:\Users\username\AppData\Local\Zotero\Zotero\Profiles)].

    Is there a way to recreate the files which are supposed to be in those folders ?

    Thanks,

    François
  • They're recreated automatically, so if you don't have any data, you can just delete them.
  • So many thanks,

    François Maurice
  • I recently had the same problem after upgrade to Win10 (Enterprise). I was able to resolve it by deleting all Zotero-related files from my local computer, doing a clean install, and then re-syncing.
  • To be clear, you definitely don't have to delete your Zotero data directory ("Zotero" in the home directory by default) and resync. As I say above, the only folders you would have to fix permissions on (or delete and allow to be recreated) would be the profile or cache directories.
  • edited 9 days ago
    I'm having this problem under Linux, too. I recently reformatted my hard drive, reinstalled my operating system, and restored my documents and settings from a backup. This is the first time I've tried to open Zotero in a few days, and I'm getting the same "Your Zotero profile cannot be loaded. It may be missing or inaccessible." message.

    I checked that the Zotero profile and cache directories are accessible:

    sudo chown -R patrick:patrick ~/.zotero
    sudo chmod -R 777 ~/.zotero
    sudo chown -R patrick:patrick ~/Documents/Zotero\ Storage/
    sudo chmod -R 777 ~/Documents/Zotero\ Storage/

    ... but that doesn't avoid the message on startup. I haven't yet tried running the executable as an administrator for fear of introducing new problems.

    I'm running the Zotero Standalone executable from a terminal by typing ~/bin/Zotero_linux-x86_64/zotero-bin under Linux Mint 18.2.
  • edited 11 days ago
    The cache folder on Linux is in ~/.cache/zotero. (It'd be good if you could check the permissions within that before fixing it to see what the problem was.)

    (Unrelated to Zotero, but note too that, while it doesn't matter too much on a personal system, you should never run chmod -R 777 on a Linux system, even when troubleshooting. Since you run programs as your own user, if the directory/file is owned by you then only the user part is necessary, and you don't want to set non-executable files as executable by you or anyone else. You can fix these recursively using find /path/to/folder -type d -exec chmod 700 {} \; and find /path/to/folder -type f -exec chmod 600 {} \;.)
  • Yep, that was it: ~/.cache/zotero was owned by root. I'm not sure why this is: rsync seems to have done some weird things with permissions when restoring, and I've tripped over several.

    Thank you, dstillman. Quick follow-up question: is there anything in the Zotero data directory or in ~/.zotero that SHOULD be executable, or can I just run `chmod -R a-x` on both directories?
  • edited 9 days ago
    The commands I give above are the way to correct this. If you run `chmod -R a-x` on a directory you'll break access to it and all subdirectories.
  • OK. Which of those commands do I run, and on which folder?
  • Or do you just mean that I should run both on ~/.zotero and/or ~/Documents/Zotero\ storage ?
  • Both on both. One fixes directories and the other fixes files.

    If you run the second command on a directory that's supposed to have executable files, you'd have to fix the permissions on any executables separately afterwards.

    But we can't really get into general Linux advice here, so you'd want to look elsewhere for that. I was just pointing out that `chmod -R 777` is never something you want to do.
  • (But you shouldn't really run any terminal command if you don't understand exactly what it does, so if you don't understand the ones I gave, you should research those first.)
  • No, that's enough information for me -- thank you again. I just wanted to make sure that I understood correctly. Thank you, dstillman.
Sign In or Register to comment.