Zotero won't start: Report ID:1967994057

I am trying to start Zotero and it would not start.
The message keep coming up : There was an error starting Zotero.

Anyone know this problem?
  • This is for Macbook by the way.
  • So first, your Report ID is from Safari 9, which is too old for the current Zotero Connector. You should upgrade to Safari 10 and install the current version of the Zotero Connector.

    For the problem with Zotero itself, see Reporting Startup Errors.
  • Thanks very much!

    I just finished all the updates on my Mac. I though this would have sorted the issue.
    My Zotero is updated as well.
  • I just updated the Safari to Safari 11. And then installed the latest version of Zotero and Zotero Connector.
    Still the same issue.
  • Just did that and below came up:

    Timestamp: 11/28/17, 3:45:18 PM
    Error: 1511883918319 addons.xpi-utils ERROR Failed to write add-ons list to profile directory: [Exception... "Component returned failure code: 0x80520015 (NS_ERROR_FILE_ACCESS_DENIED) [nsIFile.moveTo]" nsresult: "0x80520015 (NS_ERROR_FILE_ACCESS_DENIED)" location: "JS frame :: resource://gre/modules/addons/XPIProvider.jsm -> resource://gre/modules/addons/XPIProviderUtils.js :: writeAddonsList :: line 1494" data: no] Stack trace: writeAddonsList()@resource://gre/modules/addons/XPIProvider.jsm -> resource://gre/modules/addons/XPIProviderUtils.js:1494 < checkForChanges()@resource://gre/modules/addons/XPIProvider.jsm:3829 < startup()@resource://gre/modules/addons/XPIProvider.jsm:2826 < callProvider()@resource://gre/modules/AddonManager.jsm:272 < _startProvider()@resource://gre/modules/AddonManager.jsm:759 < startup()@resource://gre/modules/AddonManager.jsm:941 < startup()@resource://gre/modules/AddonManager.jsm:3145 < observe()@resource://gre/components/addonManager.js:65
    Source File: resource://gre/modules/Log.jsm
    Line: 748

    Timestamp: 11/28/17, 3:45:19 PM
    Error: NS_ERROR_FILE_ACCESS_DENIED: Component returned failure code: 0x80520015 (NS_ERROR_FILE_ACCESS_DENIED) [nsIRDFRemoteDataSource.Flush]
    Source File: resource://gre/components/nsHandlerService.js
    Line: 392

    Timestamp: 11/28/17, 3:45:19 PM
    Error: [Exception... "Component returned failure code: 0x80520015 (NS_ERROR_FILE_ACCESS_DENIED) [nsIRDFRemoteDataSource.Flush]" nsresult: "0x80520015 (NS_ERROR_FILE_ACCESS_DENIED)" location: "JS frame :: resource://gre/components/nsHandlerService.js :: HS_store :: line 392" data: no]

    Timestamp: 11/28/17, 3:45:28 PM
    Error: A promise chain failed to handle a rejection. Did you forget to '.catch', or did you forget to 'return'?
    See https://developer.mozilla.org/Mozilla/JavaScript_code_modules/Promise.jsm/Promise

    Date: Tue Nov 28 2017 15:45:19 GMT+0000 (GMT)
    Full Message: Unix error 13 during operation move on file /Users/amir/Library/Application Support/Zotero/Profiles/2mmq83qm.default/sessionCheckpoints.json.tmp (Permission denied)
    Full Stack: JS frame :: resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js :: register :: line 199
    JS frame :: resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js :: completePromise :: line 711
    JS frame :: resource://gre/modules/Task.jsm :: TaskImpl_handleException :: line 455
    JS frame :: resource://gre/modules/Task.jsm :: TaskImpl_run :: line 331
    JS frame :: resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js :: process :: line 925
    JS frame :: resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js :: walkerLoop :: line 806
    JS frame :: resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js :: scheduleWalkerLoop/< :: line 742
    Source File: (unknown module)
    Line: 0
    Source Code:
  • OK, right, so something is preventing Zotero from accessing files in the Zotero profile directory. That could be file permissions (e.g., if you migrated files from another machine or use account) or it could be security software (which isn't that common a Mac).
  • Thanks Dstillman! is there a way to fix files accessing problems?
  • edited November 28, 2017
    You can do that from the bottom of Finder's Get Info pane (after unlocking), but since that's unrelated to Zotero it's not really something we can walk you through. But you'd want to make sure that all folders and files under the profile directory were owned and writable by your current user account. To be clear, though, they always would be by default.
  • I have checked all the files. Still no luck.

    I noticed this problem started happening straight after I updated my OS on Mac.
  • You can try simply renaming /Users/<username>/Library/Application Support/Zotero to /Users/<username>/Library/Application Support/Zotero-Old and then starting Zotero.

    If that works, you can close Zotero and copy the prefs.js file and 'zotero' folder (if there is one) from within the Zotero-Old profile to the equivalent location in the new one.
  • Thanks! Now Zotero is starting up. I can see my own collection.

    However, I cannot cite while I write on Word.

  • What's happening?

    First thing to try is reinstalling the Word plugin from the Cite -> Word Processors pane of the Zotero preferences.
  • Have done this already!
  • You'd have to say more about the problem, then.

  • My bad.

    Report ID: 809759349

    I am using Microsoft Word Version 15.40 (171108).

    My Zotero plugin for Word is updated.

    However, I am unable to use citations as before.
    While I can see the Add/Edit Citation tab in word, clicking on it to add item to the document does not do anything.
    Zotero is open by the way.

    I have just restarted the system just now as well.
  • Do you get a message prompt from Word saying that Word could not communicate with Zotero or is nothing happening at all upon a click? How about when Zotero is closed?
  • No message! Nothing happening at all.

    When Zotero is closed then it says not able to communicate.
  • Can you submit a Debug ID for an attempt to click the Word button that results in no response or error message:
  • Here is the debug ID: D1691744940


  • Okay, the Zotero developers will look at that and see if they can see what is happening.
  • "Unix error 13 during operation remove on file /Users/[…]/Zotero/storage/BBNZ4H6A/all.js (Permission denied)
    @mohammad.anwar: There's a large active sync in that debug output, so it's hard to see anything about Word integration, but you're still getting lots of permissions errors, now in your Zotero data directory. Something seems to be wrong with permissions across your files — I don't know if you copied files from another Mac or there's some other cause, but you'll need to fix these permissions or various things won't work properly.

    Separately, I would try to remove the Zotero.dot/Zotero.dotm files from your Word startup folder, restart Word and ensure that the plugin is gone, and then generate a Debug ID for reinstalling from the Cite pane of the preferences (and post it here if the plugin still doesn't work). Make sure that there's not an active sync when you generate the Debug ID.
  • @dstillman: I did not copy any files from any other Mac.
    I am not sure how to fix permissions since I am not literate in technical stuff.
    I have old back up on a time machine. Can I delete these files for Zotero and copy them from one of the old ones?
    By way here is the Debug ID D902082987.
  • Just to let you know Zotero is starting. I can see my libraries and references as stored. I can add references on Zotero manually and directly from the Safari.

    But Word seems to be having problem.
  • There still is a sync activity in the debug log. If you are getting a perpetual sync that never ends, the first thing to do there would be fix file permissions. Incorrect permissions are also most certainly the cause of Zotero not working with the word processor, since the Zotero and Word communicates through a file descriptor.

    Zotero needs to be able to access and write to /Users/[username]/Library/Containers/com.microsoft.Word/Data for Word plugin in addition to the profile directory and data directory

    Dan wrote above:
    You can do that from the bottom of Finder's Get Info pane (after unlocking), but since that's unrelated to Zotero it's not really something we can walk you through. But you'd want to make sure that all folders and files under the profile directory were owned and writable by your current user account. To be clear, though, they always would be by default.
  • I have checked the permissions and those are all owned and writable by me (user).
    I found two folders named Zotero and Zotero-old
    Can I delete the old one?
Sign In or Register to comment.