Not working with word on mac

I've been using zotero with word on mac with no problem for the past year but a few days ago word started playing up. It will stop responding and has gotten to the point where I can't do any work using it because it will not allow me to edit or even save a document.
A word document with no references etc. from zotero works fine but one with anything form zotero doesn't whether zotero is open or not.
The tool bar that I also used to have in word has also disappeared.

Does anyone know why this is happening and how I can fix it?
  • What specific version number of Word (e.g., 15.39)?
  • I'm pretty sure it's 14.4.9 as it's the 2011 version of word and I updated it when it first wasn't responding to see if that was the issue
  • The latest (and probably last) version of Word 2011 is 14.7.7. If you're using Word 2011, make sure you have that.
  • Just checked. That's the version of word 2011 that I've got
  • Does it happen in a new document (or other documents with Zotero references), or only this one? If it's only this one, you should run through these steps
  • Unfortunately it's any document with zoetro in
  • So just to confirm, what exactly occurs? Does Word freeze completely or is just slow?
  • It begins to lag and then it will freeze completely and stop responding. This happens within a minute of me opening a document. If I could get hold of word 2016 is it likely to fix the problem?
  • Word 2011 should still work fine (and does for me), so this is likely something specific to your setup.

    When exactly does it begin to lag? Just when you open a document and wait a minute, or after clicking one of the Zotero buttons? If the former, what has to be in the document for this to happen? A new document without anything in it? A document with a single citation?

    Also, have you tried restarting your computer?

    It may be helpful to open Activity Monitor, sort by "% CPU" descending, and see if anything is using a lot of CPU when this happens.
  • Normally with a minute of opening the document. I'll scroll down to get to any part of the document and it will begin to lag then freeze. The document has to contain something from zotero whether that's a single citation, lots of citations, a bibliography or citations and a bibliography. I thought it might have been the bibliography but I remove that and I still have the same issue and I've tried it on multiple documents.

    Yeah, I've tried restarting it along with uninstalling zotero and reinstalling it.

    When I look at that everything is normal but as soon as it lags word jumps up to about 60% and I can't work out why although I'm not particularly computer savvy.
  • Yeah, that would be a problem with Word or something else you have installed — again, Zotero doesn't do anything except when you interact with it.

    You could also see if inserting another kind of field — e.g., a date field — causes the same problem. (There's more data in a Zotero field, but the fact that this is happening for even a single citation suggests that something is very wrong with your Word installation.)
  • If you have any other add-ins in Word, you should try disabling them.
  • Would it be worth uninstalling word and then reinstalling it?
  • we rarely recommend this, but if that's possible, yes, I'd give it a try.
Sign In or Register to comment.