WebDAV Error: Please enter a WebDAV URL

I'm trying to sync my file attachments using WebDAV. I've entered a URL, my username, and my password and when I click to Verify Server, a popup box says, "Please enter a WebDAV URL." I'm not sure what the issue is, as I have entered a URL in the appropriate field.

In case it matters, I'm trying to set this up with Box using "dav.box.com/dav" in the URL field.
  • Can you provide a Debug ID for a Verify Server attempt?
  • I had the same issue. Ignore the message and click OK. Then, re-open settings and you'll see the WebDAV address and username in, but the password is now blank. Enter that, click the the "Verify Server" button, and everything should work!
  • Ah, it looks like there's an issue if you click "Verify Server" instead of pressing "Enter" after filling in the last field. We'll fix that.
  • Hi, the Debug ID is: D1437491350. Thanks!
  • If you just click on Verify Server twice, or press Enter in the text box instead, does this work, though?
  • Yes, I have gotten it to work by pressing enter. When I just opened it up and clicked on Verify Server, that worked as well. Thanks!
  • Thanks butsuriboy. I just had the same issue (trying to use 4shared.com). Saving and exiting preferences, reopening preference, re-entering password, and then verifying worked.
  • edited 9 days ago
    This problem has still not been fixed, but I can confirm that typing the enter button works while clicking the 'verify server' button with your mouse does not work.

    It then created a new link, closed out my preferences, then I had to open up preferences again, and hit the 'enter' button and it worked (I can't remember, but I think I may have clicking 'verify' by my mouse and it may have worked the second time).

    Thanks for posting the solution here. I hope it is fixed soon.
  • Zotero 5.0.25 on Windows 10 Pro 64-bit, the problem is still not fixed. The workaround provided by @butsuriboy (thank you!) still works though.
Sign In or Register to comment.