[SOLVED] Zotero 5 opens pdf in Libre Office, how to change?

edited August 22, 2017
Sorry if it is a silly question, but I cannot find the solution.

Zotero 5.0.11 in Mageia linux 6 x64.
When I double click on a pdf attachment zotero insists opening it with LibreOffice Draw, which besides being slow shows wrongly many pdfs. I tried several things including (under preferences -> advanced -> config editor) setting extensions.zotfile.pdfExtraction.openPdfLinux to "okular %U" but nothing happens. What to do?

Regards,

Fernando
  • Hi, Fernando!

    Do you setted file association? I use KDE and in Setting have a option to define file association, in this case PDF to Okular. You can right click in file, "Open with", select Okular e select checkbox to "always open with this application".

    This is the easy way. I have a similar problem years ago and here is the solution:

    https://forums.zotero.org/discussion/34566/show-file-not-open-file-manager

    Best regards.

    Mario
  • Hi Mario,

    File association is set correctly in KDE: if I double click on a pdf it is properly open in okular. Furthermore, in zotero "Show file" opens dolphin and form there I can double click to open the pdf in okular, which is the workaround I have now. But I would like to have thinks working as expected: directly opening from zotero.

    Setting extensions.zotero.fallbackLauncher.unix to /usr/bin/kde-open, as suggested by M B did not help, either.

    Still searching ...

    Regards

    Fernando
  • Hi,

    Thanks Dan, but none of these suggestions worked. After more searching , I found in /user/share/applications/mimeinfo.cache that the line
    "applicationpdf=" had as first item "libreoffice-draw.desktop", then okular, etc. Removing that reference to libreoffice-draw solved the problem.

    Thank you all. Z 5 looks very good.
  • Thanks, I had the same problem and the solution worked. The file location was slightly different: /usr/share/applications/mimeinfo.cache
  • Hi,
    Glad to know that it was useful. The location is the same: "/user" above is a typo.
  • 4 years later, still a problem, and the above solution still works!
  • edited 19 days ago
    Nowadays, you should probably install the Zotero beta and use the new built in pdf reader and annotater
Sign In or Register to comment.