"Show file" not open file manager

Hi all,
I am using Zotero 4 (standalone and plugin) on GNU/Debian. When I select some reference and right-click to "Show file", Zotero open my mp3 player (Audacious). If I uninstall Audaciou, Zotero open correctly my file manager (Dolphin). I try find confs to correct this, but I not found.
Anyone do know how to fix this?
Best regards,
  • Hi Dan,

    I find conf to fix this.

    When I install Audaciou, it change the follow line in "/usr/share/applications/mimeinfo.cache"


    I set the first app to dolphin and work fine here.

    The confs in GNU/Linux sometimes is crazy, but it is better that others O$.

    Best regards,

  • I had the same problem with Zotero 4.0.22 and KDE 4.14.0. I`ve simply disassociated *.pdf and GIMP in file settings, so now this function works correctly.
  • I had the same problem: 'Show file' would open Gwenview and I followed the suggestion of Mario Jose. It worked like a charm!
  • M B
    edited October 4, 2014
    You can try open about:config and change value in
    from /usr/bin/xdg-open
    to kde-open gnome-open or exo-open

    How to automatize in scripts? Some suggestions:
    if environement variable $XDG_CURRENT_DESKTOP=KDE , or $DESKTOP_SESSION=kde-plasma or kde-plasma-safe or kde, you should use kde-open

    if $XDG_CURRENT_DESKTOP=gnome or GNOME or Unity, or $DESKTOP_SESSION=gnome, you should use gnome-open

    if $XDG_CURRENT_DESKTOP=XFCE , you should try exo-open.

    But for me it seems that this does not help at the moment – I must change line in $HOME folder file ~/.local/share/applications/mimeinfo.cache
Sign In or Register to comment.