Change date format in Zotero 5

2»
  • @fbennett, sorry but is there any place to enter such values?
  • In any date field. Zotero and the processor will parse it.
  • Same problem with locale es-ES. System (MacOS Mojave) set to Spain, all applications (but Zotero) behaving proper with DD/MM/YYYY. Firefox Javascript tests good. Tried to change language, then locale parameters through advanced configuration, to success. All dates (added, modified) showing as MM/DD/YYYY.
  • I too would like the UI "Date Added" "Date Modified" etc to use the ISO format YYYY.MM.DD (as does my OS settings, but US English) instead of m/d/yyyy. Not sure how to do that- seems a setting in Preferences would be helpful?
  • I was getting the date format previously in the d/m/y style. My windows machine is probably set to American. The latter format is prehistoric, they never changed to metric either. In order to get the y/m/d style on Zotero I set my language preference in the Preferences, Advanced, to Canadian English (Canada). It worked like a charm. (I had already introduced some in the latter where I could. Don't think that had an effect.)
  • Thank you CoNsTaN5foz. Took me nearly a year to see your reply, but it was helpful and does the trick.
  • edited May 20, 2021
    Related, but slightly different question: is there a way to only display the year of publication? Having month and day just messes up my library: it is inconsistent (I don't have the full date for every paper) and forces me to expand the column of publication date beyond what is necessary (year won't show up for day-month dates when I squeeze the column, see image here https://postimg.cc/bspf4skh). Any hint as to how to do this would be most welcome!
  • There is a “Year” column in the column selector
  • cheers, I hadn't noticed!
  • Greetings - new EndNote convert here. So glad to be leaving that cult of stagnation.

    As of Mac OS Big Sur (v11.4), Zotero still won't respect my OS settings (to display files in the ISO format (YYYY-MM-DD) + military time.

    Thank you to @CoNsTaN5foz -- the most important part -- the date formatting, is now correct using the suggestion to change to English (Canada) from the May 22 post above.

    Any ideas on how to get it from HH:mm:ss a.m./p.m. Goodness it takes up precious laptop screen real estate (yes, I know I can resize columns to somewhat improve this but the downsides are also obvious). I'm used to HH:mm and that's all I need when using the 24 hour clock instead of 12 hour with a.m./p.m.

    Suggestions? Reward offered!
  • edited July 4, 2021
    No reward needed -- all help here is free. The program developers read and respond to help requests throughout the day and night USA-time (as do others -- many with more expertise than I have).

    As @CoNsTaN5foz said in 2020, there is a local language setting in Zotero/Preferences/Advanced that when set to "English (UK)" will give you dd/mm/yyyy 24-hour time. I used to have my Zotero with that setting. But somehow with my switch to the beta stream [probably my own fault] I lost that setting and until your question I had not tried to find it again until today. I still cannot get YYYY-MM-DD + 24h time but I'd love to have that format available.

    See:
    https://forums.zotero.org/discussion/62550/zotero-time-format-in-date-added-and-date-modified-fields/p1

    People have requested this since 2016:
    https://forums.zotero.org/discussion/60740/time-format-settings-24h-am-pm/p1

    Please do NOT attempt to use
    Preferences/Advanced/Advanced Configuration/Config Editor :Believe the warning:
    unless and until you have received very specific guidance from one of the true experts here.
Sign In or Register to comment.