save pdf to zotero 5 standalone

Hello all,

I have just installed the newest version of Zotero Standalone and I can say this is a very inspired change! I do have some issues and I don't know if they are due to the change or they will be implemented at a later date. I use Zotero with chrome now that it is not part of Firefox anymore and I have noticed that when I open a pdf in the browser, the connector does not offer to save that pdf to zotero. I have to download it and then add it myself. The old usage was to save directly to zotero and it would automatically pull the necesary info too.

Is this feature gone now? Or is it going to be implemented at some point?
  • Clicking on the Save to Zotero icon does not change the PDF? I thought it did and it's supposed to. The (slightly less comfortable) alternative is to drag the URL to Zotero Standalone by click&dragging on/from the left of it.
  • In chrome, I click on the save to zotero and I only get to save a snapshot. If I try to save the file localy I don't get the save to zotero option like I used to do in Firefox. How do you drag an URL to zotero?
  • Yes, you can just click the save icon when you're viewing a PDF, but you need to be viewing the actual PDF, not an HTML frame.

    Can you share the URL where you're seeing this?
  • sorry I am an idiot! I click on the save to zotero and I get the window to save the file in zotero. The annoyance is that it obtains the metadata and creates an entry for the file downloaded, but it also creates a blank entry with no title, only some information about the webpage I downloaded the file from. It does not merge the file with this info.

    Sorry for the confusion! I am still getting used to the new system!
  • edited July 16, 2017
    The annoyance is that it obtains the metadata and creates an entry for the file downloaded, but it also creates a blank entry with no title, only some information about the webpage I downloaded the file from. It does not merge the file with this info.
    No, what we're describing would result in a just a standalone attachment item in Zotero (which you could later run Retrieve Metadata from PDF on). You can test this at

    If that's not the behavior you're seeing, we'd want an example URL. Most likely it's an HTML frame.
    How do you drag an URL to zotero?
    To drag, you drag either the padlock/globe area to the left of the address bar or the tab icon into Zotero. But clicking the save button should be identical.
  • You guys were right! The problem was on my side! All good now. As I said it will take some getting used to the new system.

    I am now at work and I was trying to install zotero 5 on linux and all I get is an archive which I unpack and I can run zotero from there but I can't figure out how to add zotero to my start menu so I can find it easily and not dig for it in my home dir. But that's a question for another topic I suppose!

    Thank you for the assistance!

    (But yes, start a new thread if you have trouble with that.)
  • I'm having the same problem.
    For this journal, there is a "download the pdf" button on the lower right.

    I right click and see the "save to zotero" but nothing happens when I click on it.
    I open the PDF in Adobe Acrobat pro and don't see a way to save it to zotero. I can drag the file from my download folder but that's really a pain compared with the beautiful 1-click from Mozilla. Otherwise, however, I love the standalone. I added zotfile but that doesn't seem to do anything to help this either.

    Also, I can't seem to have new entries go straight into my desired folder--they always go to "unfiled." Is there a fix or trick? Thanks.
  • 1. If you open the File in your browser rather than in Acrobat, you can click the Save to Zotero button at the top right to download it to Zotero

    2. Items still go into the currently selected collection -- it's just the collection selected in Standalone.
  • I think I'm having similar issue. I recently installed version 5 standalone but I can no longer save a pdf directly to Zotero. When opening/downloading a pdf, the dialogue box that comes up no longer gives me this option. For example, if I was to click the pdf in the first entry in Google Scholar here,5&q=biesta+good+education&btnG=&oq=biesta

    Thanks Helen
  • @helencrump: Firefox no longer provides a way to modify the save dialog.

    See "Are there any features that are no longer available?" in the FAQ for the many other ways to save PDFs.
  • Thanks. That's a black mark for Firefox. What about Chrome does that support that feature? It was so handy.
  • No, no browsers support this. (The new Firefox extension framework is modeled after the Chrome extension framework, and though it's expanding on the Chrome one, features like this that modify native browser UI are unlikely to be added.)

    But as noted in the FAQ, the recommended approach is just to save from the article page, which will generally save both the metadata and the PDF without requiring the less-accurate "Retrieve Metadata" step. If you really want to save from a PDF without going to the article page, you can change Firefox back to the default setting of previewing the PDF in Firefox and then use the Save to Zotero button while viewing the PDF. (To get the open/save dialog again, you then just click the download button in the viewer toolbar.)
  • Hi,

    I have a similar problem with Zotero 5.0.33 Standalone and Zotfile and the SSRN website. For instance this link I can save the page to Zotero but the PDF is not saved due to the SSRN long standing problems. My FF can't view PDFs in the browser due to other problems which I haven't been able to debug out. So I used to save to zotero the page and then save to zotero the actual pdf via the save to dialogue. Now that this feauture is removed I tried to use all other approaches:
    - Zotfile. Just doesn't work. No matter what I upload in the folder there are no changes in Zotero. It used to work great in Z for FF though
    -Dragging the pdf link to Z standalone doesn't do anything. Draggin the tab just creates a new FF window.

    The only way that i found that works is by downloading the pdf manually to a folder, opening that folder and dragging that pdf with win explorer into the entry in Z which is suboptimal.

    Any recommendations? Am I missing something? Thank you in advance!
  • I have the same problem in both Firefox and Chrome (even with Firefox set to Preview PDF files), with Zotero Standalone.

    If I open the PDF within Firefox or Chrome itself, the Zotero button doesn't change to the PDF symbol, it stays as the usual "blank" light blue icon. When I click that, nothing happens at all. It doesn't matter whether Zotero Standalone is open or closed.

    This issue seems related to the way a website chooses to deliver PDF files. If it allows the file to open in the browser, in Chrome at least the Zotero button changes to show the PDF symbol, and I can save it to Zotero fine. But if a website only allows a PDF file to be saved/downloaded, even if I save it and then open it in Chrome or Firefox, the Zotero button stays light blue and unresponsive - it doesn't allow the PDF to be saved.

    I know you can download the PDF then attach it to a Zotero item, but that's several extra steps for every PDF I want to save.

    A few months ago, I could open any PDF within Firefox and save it to Zotero. Now it's impossible unless (in Chrome at least) the site allows you to open the PDF within the browser.

    Could this be looked at and fixed please? Thank you.
  • Sorry I forgot to say, I have standalone 5.0.33. It could be a coincidence but this problem started after the last standalone update, I don't recall an issue (in Firefox at least) with PDFs before that.
  • @wqmul: The connector won't work on local (file://) URLs. If you've downloaded a PDF there's no need to open it to the browser, though. Just drag it to Zotero.
  • @dstillman thank you for the tip. In the past, you could open a PDF in the browser then save it directly to Zotero with the button, creating an item as well as attached PDF.

    If you drag a PDF to Zotero Standalone, it seems you still have to manually create the item for the PDF. Is there a way to drag AND create a new item for the PDF at the same time please?

    Also, I've tried to drag several selected PDFs from Windows Explorer to Zotero but it only copies one across. Is this how it works, or am I missing something or is it a blip with my system?
  • dragging multiple PDFs to Zotero should work and does for me on Windows 10. Do you get cursor feedback? WIndows should show you a 2 while you're dragging those two files.

    Zotero hasn't attached PDFs to empty items for a long time (if it ever did, I don't remember). The idea is that _if_ you import a single PDF you'll most likely want to either drag it to another item or run retrieve metadata, so there are fairly few cases where you'd want it attached to an empty item (which then also creates two steps -- drag it out, delete parent -- as opposed to the single step --create parent item-- going the other way)
  • edited January 15, 2018
    I think @wqmul is referring to the Retrieve Metadata checkbox in the save dialog modification in Zotero for Firefox.

    @wqmul, as noted above, that's no longer possible in Firefox, so you have to add the PDF (one way or another) and then run either "Retrieve Metadata for PDF" or "Create Parent Item".

    We're hoping to optimize this in a future version so that metadata retrieval happens automatically when you add a PDF and it automatically falls back to creating an empty parent item on failure.
  • @adamsmith @dstillman thanks very much for your further replies.

    I think the multiple PDFs dragging apparently not working was due to some lag with Zotero Standalone - they did show up eventually. I don't know if it's just my setup but I do find Standalone much slower than Firefox, e.g. if you click on another folder to view items in it, it takes a long time to display them whereas in Firefox, the first time you clicked to view Zotero items it took some time, but after that moving around folders was quick. Is there a way to speed this up please?

    I believe there was a Zutilo shortcut that enabled me to save a PDF opened in Firefox to Zotero, even if opened via file://, and automatically attached it to an empty item bearing the title of the PDF file. That is no longer usable now of course. But @dstillman having a future version with the functionality that you suggest would be exactly what I need, many thanks for taking that issue on board!
  • I am not having any lag in display of items when I change collections, on a Windows 10 machine. (Note that collections are not folders, but are analogous to playlists.) So maybe it is something in your particular setup?
  • Sorry for the slow response. The lag I experience is intermittent, e.g. if I try to view a folder immediately after I've saved an item, sometimes it won't display. Other times it will, and changing is quick. In Firefox the first time I opened Zotero after booting I'd get a lag, but after that it would be fine, but with Standalone this keeps happening on and off. As this is presumably unrelated to the PDF issue, if it persists I'll start a new thread. Thanks to everyone for your suggestions.
Sign In or Register to comment.