Zotero 5.0 Proxy failure

The upgrade to Zotero 5.0 Standalone out of the browser version has not been so smooth. Zotfile, Zutilo links are broken and must be reinstalled manually. No big problem. But the biggest single issue is that the Zotero Connector is broken if you are wanting to use a proxy. I cannot get it to save a proxy link. This is in my humble opinion a major bug. I can imagine many people when working out of their university of work network might make use of that proxy.

Any ideas on how this can be fixed so that the proxy can work?
  • I can imagine many people when working out of their university of work network might make use of that proxy.
    Because of this, the fact that you're the only one reporting issues with that suggests this isn't a general issue but specific to you. Could you provide details on what type of proxy, what's not working, etc.?
  • The connector is not asking for a proxy location automatically ( I have it set up in the default automatic mode). That was the behavior in the old Firefox add-on. I have attempted to manually add a host proxy name and a particular site but neither are saved. It simply reverts to empty fields.
  • BTW. I have found other questions on the forum with similar if not exactly the same problem. Can you provide documentation for setting up the proxy manually? I have not had success with that either but likely that is owing to my lack of knowledge of the syntax for the proxy.

    Is there perhaps some examples that can be provided for how to set the proxy link manually?
  • I'm still not quite sure what you're after. There are two different types of proxy services: proxies that are most commonly used by universities to authenticate remote users, like EZproxy, by inserting a string into specific URLs visibly and proxies that work for every URL on a browser or system that are configured for the browser or system as a whole. I'm not sure which of the two you are referring to. If you are referring to the former, could we get an example of such a proxied URL for your institution?
  • I am trying to use my local university library (NC State library location: http://lib.ncsu.edu/) as a proxy. I am not using a proxy for every URL, just those select locations that were in my previous list (now lost with the upgrade)

    There is nothing on the NC State website that I have seen listing a specific format for a proxy string. What I have as an example is found in a reference from my library https://www-ncbi-nlm-nih-gov.prox.lib.ncsu.edu/pmc/articles/PMC3550200/

    On the previous version of Zotero (v 4.0.x) I do not recall ever setting up the proxy. The add-on automatically did that in the background as it was set for automatic proxy redirecton. Now, nothing is happening at all. Still wondering why the proxy configuration was not retained in the upgrade?
  • I contacted the NCSU library and a person there provided a proxy link. Now the question is can I get the connector to accept and save the link. So far no luck on that score either. Do you have detailed instructions for setting up the configured sites and the host name within the connector?
  • So one last item. The proxy link provided by the NCSU library works fine. But Zotero connector is not recognizing that I am using a proxy and is not asking if I would use that proxy in the future. So I can state fairly well that the connector is broken. Not sure why at this point in time.
  • The Zotero Chrome connector should (and does for me) automatically recognize those proxies.
    You really shouldn't need to add this by hand, but if you want to, the configured proxy should be
    https://%h.prox.lib.ncsu.edu/%p
    and for the sites you just use the host url, i.e. www.ncbi.nlm.nih.gov in your above example and similarly for other sites.
  • I have the proxy working for one site - and only one site - PubMed. I added this host name manually using the NCSU proxy in the address bar. I have not had any success with other sites. Seems that the login sequence for the proxy is one time only and it will not go directly to the host site (eg Science magazine) through the proxy. I can only get to science magazine through Pubmed link. That page link is not saved in the hostnames. Before that was an automatic event.

    I set the proxy up in Chrome as well and am having the same issues.

    Not at all like the behavior of the old connector which worked completely in the background without failure. Still not understanding why the proxy configuration was not retained in the upgrade.
  • Please do stop the editorializing. We'll be happy to troubleshoot why the proxy redirection isn't working as it should, but this is going to be much easier (and, frankly, more pleasant) if you just stick to reporting what's going on (and not).

    So just to clarify what _should_ happen: the first time you acccess a page on a given host (i.e. the basic part of a url up to the .edu/.gov/.com like www.ncbi.nlm.nih.gov) through a proxy, Zotero remembers that host (automatically) and then inserts the proxy on subsequent visits. So let's start by making sure that's actually not working.
    Go to
    http://science.sciencemag.org.prox.lib.ncsu.edu/content/357/6347/146
    and see if you get the yellow bar that signals Zotero is recognizing and adding the proxy. It would be listed in Chrome under chrome-extension://ekhagklcjbdpajgpjgmbionohlpdbjgc/preferences/preferences.html#proxies when you click on the NCSU proxy
  • What should happen is not happening. The above link opens but the connector is not automatically associating or recognizing the use of the proxy or saving the host information in the connector.

    I recreated the link above by manually putting the following URL into the address bar. http://proxying.lib.ncsu.edu/index.php?url=http://science.sciencemag.org/content/357/6347/146 That link was recognized as being through a proxy and I was so notified and accepted the use of the proxy.

    But I have done the same on about a half dozen other journals and while the proxy redirect occured the associaton was not saved in the connector. Also, if I access PubMed through the proxy, the associations also fail to occur. Within Pubmed a link to the article would or should link out using the proxy. That does not happen.

    I am not using Chrome, I am using Firefox if that makes any difference.

  • But I have done the same on about a half dozen other journals and while the proxy redirect occured the associaton was not saved in the connector.
    what's an example for that?
  • @adomasven any reason you can see why this wouldn't be working?
  • One more.
    http://www.nature.com.prox.lib.ncsu.edu/ncb/journal/v13/n2/full/ncb2152.html

    This link was derived in a slightly different way.

    I searched on Google Scholar which had a link to the Pubmed citation. The link took me to Pubmed using the NCSU proxy. So far so good. That citation was linked to the Nature article which I jumped to successfully (the proxy worked this time and stayed on the link). But the link opened and - no yellow band of recognition that this was a new host.

    When I surveyed the proxy properties however, I now note that I have two proxies: The first is https://%h.prox.lib.ncsu.edu/%p which is a secure protocol. The second is http://%h.prox.lib.ncsu.edu/%p an unsecure protocol. The latter is now associated with the hostname www.nature.com.

    So in this sense maybe the problem is kind of resolved but still, there are no obvious notifications coming up that the connector is associating the proxy with a specific host. And why is there now a distinction between the secure and unsecure proxy?

    I will speak with an IT person at NCSU tomorrow that may be able to help resolve the matter.
  • there is now a distinction between the secure and the insecure proxy because this simply didn't use to work before. I think we may have made an exception and hardcoded this into the pubmed import, but in general https proxied pages simply didn't work before the 5.0 connectors -- the proxy redirect didn't work and, more importantly, import didn't typically work either.

    I can't say why you're not getting notifications, though (is the jbc.org page added to the proxy too?)
  • I uninstalled the connector, uninstalled Zotero 5, refreshed Firefox and reinstalled all Zotero components and software. I also uninstalled a couple of security addons (Ghostery and Noscript) that might have caused some trouble. In the end they were not a source of concern but I checked anyway.

    With that I took great pains to make sure to check the proxy that uses the https:// path. It definitely does not work with PubMed. Failed to even recognize the link (404 error). So I abandoned that secure proxy link and am just using the http:// proxy link. That does work to reliably get me to Pubmed and I can download citations. I am seeing that some, though not all, hostnames are being written to the connector proxy page. But it is definitely spotty. And I have no reason to know why or even if they get detected since I do not get a notification. I can only know that there has been a hostname recognized by opening the connector and looking at the list of hostnames.

    For the near term I can get around this problem by working out of Pubmed through the NCSU proxy. After a couple of weeks I will revisit the connector page and see how many host sites have been saved.

    I do regret now having updated to Zotero 5 without fully investigating the consequences. In retrospect I should have saved the proxy hostname listing to add back to the new version manually if need be. Saves a whole lot of time. Sorry for editorializing. Thanks for your help and comments.
  • @adomasven may have some ideas on why it's not working properly for you. We should also be able to restore the previous proxy list from 4.0 in an upcoming connector update.
Sign In or Register to comment.