Editing citations in a document that was created by someone else

Working in a Word document created by a colleague with his own Zotero library, I ran into the following problems:

- I was not able to edit a citation to change its format from (Author Year) to (Year).
- After importing his library, I still could not edit the citations. Moreover, the imported references were treated as new references: when I tried to add a reference that was already inserted in the document by my colleague, I would get (Author Yeara) and (Author Yearb) for the exact same reference.

Obviously, I don't understand how Zotero links citations to library elements. Any help is appreciated.

Zotero standalone:
Windows 7
Word 2013
  • In this instance, the easiest thing to do is to set up a group library that's shared between you and your co-author, then cite from that library, not from either of your personal libraries. Obviously, if you're pretty far into a big manuscript project, you'll have to weigh the value of re-creating those citations so they reference the group library--this can be time-consuming. Another way that avoids a group library is to use the Remove Field Codes tool in Word, effectively stripping out the Zotero references behind your colleague's citations. You can then replace your colleague's citations with those from your own library.

    My understanding is that your colleague's citations are referencing locations that don't exist on your computer. Even when you add the exact same sources to your library, those are given different reference numbers. If you work from a group library, the reference numbers stay the same.

    Regarding changing the format from (Author Year) to (Year), unless you're working from a group library, it's my understanding that you can't edit citations added by others. (Also, you're using the "suppress author" feature to do this, correct?)
  • Mostly what denlinkd says but this:
    it's my understanding that you can't edit citations added by others. (Also, you're using the "suppress author" feature to do this, correct?)
    actually isn't quite right. While you cannot edit the underlying data, you can, with default settings (store references in document) edit citations, change citation style, etc.
  • Thanks for the clarification! Noted.
  • Thanks for the detailed answers!

    Yes, I was trying to use the "suppress author" feature.

    @adamsmith: I'm not sure I get it (with respect to my question). Should I still be able to use the "suppress author" feature ?

    Thanks again!
  • yes, what happens when you try?
  • At work (Word 2013), I get this window, which does not link to the reference (so even if I click on "suppress author", it doesn't let me press Ok).

    At home (Word 2010), I get this window, which allows me to click on "Suppress author", but then nothing happens to the citation (it remains (Author Year)).
  • At home, have you tried clicking supress author and then return? The citation in the red bar won't change, but the one in the text really should.

    For work, make sure the "Use classic add citation dialog" checkbox is closed in the "Cite" tab of the Zotero preferences.
  • At work: I will

    At home: I was missing the return key (I had tried everything else: refresh, update fields, close and reopen, and combinations of those actions).

    Thanks for the quick and efficient support!
This discussion has been closed.