[5.0 Beta] - error on linux related to libnss3.so

  • have you tried installing libnss3-dev?
  • @adamsmith It's already installed. Always been. This happens to me on multiple machines as well.
  • Installing libnss3-dev solved it for me.
  • This issue also happened to me. Installing libnss-3-dev only fixed the problem temporarily.

    Only applying the fix from njs fixed the issue for now.
  • Hello, I'm running

    OS : Linux, Debian Buster (10)
    Kernel: 4.19.0-8-amd64 #1 SMP Debian 4.19.98-1 (2020-01-26)
    Zotero: 5.0.83

    and this error exists on my system as well now (didn't a while back).

    I attempted the workaround script provided by @njs and I can confirm it "solves" the issue.

    I then undid the script work-around and installed "libnss3-dev" (which depends on "libnspr4-dev") per @kktkht and this ALSO solved the issue.

    Personally, IMHO, the script workaround is a cleaner solution since nothing else requires additional packages...especially 'dev' packages when not developing.
  • I've just downloaded the zotero binaries and the zotero start script doesn't set LD_LIBRARY_PATH -- what workaround did you apply?
  • I've also just installed the debs and I can open PDFs without issue.

  • I created a script called "zotero-evince" which contains:

    exec evince "$@"

    Make sure you make it executable and then point Zotero's config to use this script as the custom PDF viewer (Preferences -> General -> Open PDFs Using...).
  • I'm still curious why that has helped. I can open evince without issue in Zotero on Ubuntu 19.10, and I can't find the string LD_LIBRARY_PATH anywhere in the Zotero source.
  • edited March 5, 2020
    I also get this error on a recently installed Zotoro 5.0.84 on Ubuntu 19.10.
    I've also experienced this problem randomly off and on in the past.
  • Thanks Denis Becquet!

    I indeed solved my problem with:
    sudo apt install libnss3-dev

    Restart Zotero. Then everything works!
Sign In or Register to comment.