troubleshooting translator issues with EBSCOhost

edited 10 days ago
Also posted at the following discussion (wasn't sure if my reply would be seen or if a new post is required)
https://forums.zotero.org/discussion/66086/troubleshooting-translator-issues-error-message

Issue with saving from EBSCOhost to Zotero standalone as of about an hour ago (saving is working fine from other sites I've tried such as Amazon). Tried with Safari and Firefox, tried restarting Zotero, computer, and browsers. Zotero and extensions up to date.

Example URL:
http://eds.a.ebscohost.com/ehost/detail/detail?vid=7&sid=1b653467-807e-4b73-a7cc-99b2b8cf47f7@sessionmgr4006&hid=4102&bdata=JnNpdGU9ZWhvc3QtbGl2ZSZzY29wZT1zaXRl#AN=79003348&db=a9h

Report ID: 1881248519

Steps to reproduce:
Open Zotero standalone
Load desired article in EBSCOhost (tried several; none worked)
Click on translator icon: "save to Zotero (EBSCOhost)"
Receive error message "could not save Item, An error occurred while saving this item, Check troubleshooting Translator Issues"
  • Update to above:
    I tried saving a few other EBSCO articles. For most, the same error message ensues. However, for some, it will work. I am unable to determine a pattern.

    URL to one that will work:
    http://eds.b.ebscohost.com/ehost/detail/detail?vid=21&sid=64d6469e-e345-452a-9343-3ab56932d37c@sessionmgr104&hid=127&bdata=JnNpdGU9ZWhvc3QtbGl2ZSZzY29wZT1zaXRl#AN=67421451&db=eue
  • Works for me -- what setup is this on exactly? (versions of Zotero, browser, Zotero browser plugin, OS).
  • edited 10 days ago
    Mac OS 10.12.3
    Zotero standalone 4.0.29.15
    Safari (and Firefox) plugin - whatever the most up-to-date version is from zotero.org (I tried uninstalling and reinstalling earlier today)
  • and this is happening with both the Safari and the Firefox add-on?
  • edited 10 days ago
    yes and no - with Firefox, I still cannot save, but the translator icon stays greyed out (remains unclickable), vs on safari I can click it and then get the error message. When I navigate to amazon (on Firefox) the icon 'activates' and I can save to my standalone Zotero
  • @danstillman or @adomasven could you check the error report ID in the first post?
  • edited 10 days ago
    another update:
    Issue remains with Chrome extension on a different (Windows) computer in my office - same error message for the same article(s) when trying to save to my Zotero Standalone.

    Report ID: 2031571210

    PC info: Windows 7 Enterprise
    Zotero standalone version: 47.0.0.0
    browser: Chrome

    URL of another article not working:
    http://eds.b.ebscohost.com/ehost/detail/detail?vid=12&sid=a8b86392-9490-475f-85da-9b4398a5d695@sessionmgr101&hid=114&bdata=JnNpdGU9ZWhvc3QtbGl2ZSZzY29wZT1zaXRl#AN=18105664&db=aph
  • Zotero version 47.0.0.0?
    Do you mean Chrome version? In that case, this would be expected. Chrome 47 is outdated, unsafe, and no longer supported.
  • edited 10 days ago
    My apologies - I'm not too familiar with PCs. Under 'properties' for the Zotero Standalone application it says "File version 47.0.0.0" which I assumed was the software version. It also says "Product version 1.0.0". I downloaded the software on April 17, 2017 but will see right now if there is a more up-to-date version.

    For the Chrome connector under 'manage extensions' it says "5.0.5" - can try to see if there is a more up-to-date version as well. However, I am dubious that this would be the cause of the problem, as the exact same issues are occurring on a different computer with different browsers with updated software.
  • The Chrome connector is up to date. I'd check Chrome. Do you happen to know how you're authenticating to EBSCO?
  • Okay - chrome extension is current as well as standalone software - finally found the version number for the PC computer: 4.0.29.17
  • edited 10 days ago
    I'm authenticating through my institution (Johns Hopkins University). I also have an EBSCO account which I only had to create 2 days ago after logging in through my institution. Tried to sign in through that just now but the same error message appeared.
    ----
    Had a colleague try logging in and accessing EBSCOhost with her credentials and she received the same error message (using the same computer trying to save to my Zotero standalone)
  • @adamsmith a bunch of

    JavaScript Error: "Same origin HTTP request redirected to a different origin not handled

    which are coming from here. I should probably know more about this, but I haven't really looked into this code. AFAIK, these are some tricks and magic to make cross-origin/different protocol requests work properly (or to some extent at least, where possible).

    I cannot reproduce this either behind ezproxy.
  • and you're on campus at JHU? I guess with Adomas and me unable to replicate this on various set ups and different connections/universities and you being able to replicate this on multiple accounts where you are, this really is most likely to come down to the details of your connection, so any more details you could provide on how EBSCO know that you're at JHU might help.
  • I was first in a cafe (off campus), then at home (also off campus), and then finally came in to the office (on campus). So the issue is occurring with three separate internet connections, on different browsers, with different Hopkins accounts, on different computers.

    Regarding how EBSCO knows my connection to JHU, I first log on through the Johns Hopkins portal (https://my.jh.edu/), and from there I have access to the Johns Hopkins library page that directs me to various EBSCO databases
  • and the URLs you give above are exactly as you see them, right? And 2.) here describes what you're doing, yes? http://welch.jhmi.edu/welchone/Off-Campus-Remote-Access

    How about when you go through the JHU library to access EBSCO: go to www.library.jhu.edu/ pick out the database on the right and authenticate though the secure portal.

    I'm suspecting the problem is that we can't handle whatever browser-based VPN solution JHU employs.

  • @mgcoffee I've created a ticked for this. If you're willing to help us troubleshoot this with custom builds of the connector we might be able to find a fix. If you are I will post in this thread some time later, once I get around to looking at that code and seeing what's up.
  • (Although if @adamsmith has ideas for a way to work around this, let's try those first)
  • well -- I think going through a proxy (which is what JHU library does) rather than the VPN (the my.jhu.edu portal) has a good chance of working, but it'd be nice to have both options available so that other people on similar set-ups don't run into this issue.
  • @adamsmith yes, the URLs are just copied exactly as I see them. I don't use the Welch library specifically, but one of the other Hopkins libraries (the Sheridan libraries). As far as I can tell, the protocol is the same.
    When I go through the JHU library site, I've already logged in to the Hopkins portal and I do not need to re-authenticate again. I've been using Zotero and accessing the databases this way for almost 2 years and today is the first day I've run into this issue. I haven't made any changes to my hardware or software so I have no idea what caused the issue to come about.
    @adomasven I am definitely willing to help in any way I can, just let me know what I can do.
  • edited 10 days ago
    I'm not quite sure what you mean by the proxy vs. VPN in terms of what I need to do. Whether I go through the Hopkins portal page first and then navigate to the library page, or start with the library page and try to access the databases, I end up having to go through the Johns Hopkins Enterprise Authentication screen (in the former case starting there, in the latter being redirected when I click on databases)... and receive the error message when trying to save to Zotero all the same. If the library is using a proxy but still taking me to the portal page, what does that mean I'm using, a proxy or the VPN?
  • Can I join in ? See 1. my recent experience with Zotero and EBSCO, and 2. today's update and 3. general information that students and faculty have on our web site about our proxy at Kent State University.

    1. Wednesday, I could not save search results from EBSCO search. I got the message “An error occurred while saving this item. See Troubleshooting Translator Issues for more information”..

    Then I got home, clicked to connect to the same EBSCO database, was shown our "KSU Proxy" login screen, and logged in with my KSU ID and PW. I then did the same search that I had run on campus and *was able to save search hits (references) from EBSCO to Zotero standalone. That is, I ran the same search I had used on campus (which does *not require *me to log in to search EBSCO).

    2. Today (Friday) I repeated those two searches. On campus I got the same error message trying to save EBSCO results to Zotero. Then at *home I logged in to that EBSCO database using Proxy login and it all worked.

    3. Here is general info that we have for students and faculty re: our Proxy connection at Kent State:
    __________________________
    How does KSU Proxy work?

    The connection to KSU Proxy is coded within the links to databases, electronic journals, ebooks and media on the library’s web pages and in KentLINK. When you click on a link to an online resource, KSU Proxy checks whether your computer is on or off campus.

    If you’re on campus, you’ll bypass KSU Proxy and be sent directly to the resource. If you’re off campus, you’ll be presented a Kent State University login page and prompted to enter your FlashLine username and password. Once entered, you’ll be linked to the resource.
    _____________________________

    Does this suggest what I might look for to talk to someone about my experience with EBSCO and Zotero ??

    I am on a Mac OS 10.10.5 Yosemite, in Google Chrome Version 58.0.3029.110 (64-bit). Zotero standalone 4.0.29.15.

    I have been doing ok with using Zotero plug in for Chrome to capture references from EBSCO databases (e.g. Academic Search Complete) until recently. Same thing using Safari Version 10.1 (10603.1.30.0.34).

    Thanks again for any help you can give.
  • I too have been able to capture EBSCO references fine (no issues in two years) until recently (yesterday morning). Same issues arose today. My work-around has been to search the articles I want to save elsewhere online from other databases since the problem seems to only be present with EBSCO.
  • Thanks mgcoffee !

    We recently had to move from supporting RefWorks on our campus to supporting alternatives. I have used Zotero for a number of years, and hope to continue. We are reliant on EBSCO for a large number of databases across disciplines, and I was/am to be involved in promoting transitioning to Zotero, etc. I am a librarian and so am used to looking for alternative sources for articles. But I am really hoping to get back to a workflow on campus that matches what it used to be....and what it still is when I connect from home. A puzzle.... Step at a time...

    Thanks again for comments !
  • I too use EBSCO daily so it's become quite a frustration. I'm hoping this can get resolved soon.

    @adamsmith and @adomasven any updates?
  • I'll be back at school next Monday and can see if I can reproduce the issue there. I think Adomas has some additional ideas, but at least for me it's quite hard to troubleshoot until I'm able to reproduce this myself (not saying that this isn't a real issue -- but it's hard to fix something without being able you're not seeing).
  • Thanks again all....for whatever's possible.
  • Greetings again. This noted is a bit convoluted. This morning I did the same search in EBSCO to capture refs to Zotero standalone. It worked across several of the databases that we have (EBSCO). That is, it captured the first 30 refs to the Zotero folder. I do not recall doing anything to my "set up" over the weekend. Also though, while pdfs seemed to be captured with refs, they did not open in Adobe Reader (as they had). Instead, a window popped open that asked me to choose the application to open pdfs. I choose Adobe Reader and I also tried to choose Preview. I don't recall the sequence of those choices now. Then pdfs would open when I clicked on the ref...but first *showed Adobe responding....and then switching and opening the pdf in Preview. I was wondering if I could open the prefs to just make pdf open in Adobe...so that I can tell others of that routine. I looked for where in prefs to do that, but did not find (my lack of skill). I shut down Zotero and Chrome, restarted all. And it is all working now. Refs are captured in the EBSCO database Ed Research Complete, Ac Search Complete, PsycINFO, etc. Also the pdfs open in Adobe Reader. Any ideas on how this reestablished itself ?? I do have the screen dumps with the error message in the Zotero box that appears showing what refs are being captured. Those dumps show what I was seeing at those points where no refs ended up in standalone. Anyway...it's working this morning. Thanks again for comments and guidance. Any info would give me comments I can share with others when I talk about Zotero. Again thanks !
  • There were no changes on Zotero side both to break capturing form EBSCO or fix it, so it is likely that EBSCO themselves both broke and fixed whatever the issue was over this period.

    @mgcoffee can you confirm that it is working for you?
  • Thank you for the update adomasven. Also over the weekend, I contacted our IT folks here. I am waiting for their response. I also wonder if they took some steps. Will post anything that I learn. Again, thanks !
Sign In or Register to comment.