[Zoter 5] link to PDF attachement not open with default reader

In note, I'm using links that point to attachment like that (source):

"Marine Pollution" (Caldwell and Weiland 1996:244)

Those link are generated using http://zotfile.com/ extract annotation feature

When I click on those link, preview app is used on MacOS even Acrobat is my default PDF reader.

Also an white empty zotero windows is opened first, and stay around.
  • edited May 3, 2017
    I apologize if this isn't helpful but ever since the second most recent MacOS upgrade I've also had this problen unrelated to Zotero. The problem is intermittent.

    Because my bank, accountant, and my attorney send me pdf documents that are password protected (and will not open in Preview) I have set the default viewer to Acrobat. I have this Acrobat setting in system and individual programs. In some cases I have done this by adding several pdf-related extensions to the open-with lists. Nonetheless regular pdf files as well as special extension pdf files _sometimes_ open Prieview. In the case of the password protected files this is especially frustrating because the password dialog box is difficult to close and must be closed before I can quit Preview so that I can view the file in Acrobat. To open an email attachment, for example, I must save the file, right click, and open-with Acrobat. (Hmmm... I cannot be certain that I have tried opening the file in Finder by double-clicking it. Next time I'll try to remember to test that. I have a habit of opening files in Finder -- xml and html files in my editor with right-click .) Occasionally, clicking on a link at a publisher's website (Firefox) also opens Preview, not Acrobat.

    edit. I haven't tried reporting this on Apple help sites because it is an intermittent issue and such things quickly become unpleasant there.
  • There is another report of this. I would suspect this is a change in Mac behavior indeed, but regardless of what caused it, the place to fix it would be Zotfile, which has specific code in place for opening those links to PDFs (and specifically the right page in a pdf). I'd report it in the ZotFile thread or on the ZotFile github.
  • edited April 18, 2020
    I have this issue too. Any updates on this matter?

    Zotfile developers seem to have deprecated the extensions.zotfile.pdfExtraction.openPdfMac preference flag, and at Github I'm being told that the issue is in Zotero's end.


    What do you reckon is the solution for this bug? Also, I'm cross-linking this thread to the other one. I hope you don't mind, and that it may help.
  • 1. Make sure you've installed the latest versions of Zotero (5.0.85) and Zotfile (5.0.16). (Note that zotero://open-pdf links are now exclusively handled by Zotero. Zotfile removed its function in version 5.0.13.)

    2. Set Acrobat Reader as your custom pdf viewer in Zotero:
    "Edit" -> "Preferences" -> "General" -> "Open PDFs using"

    3. Create an annotation in a pdf file and extract it to get a zotero://open-pdf link that you can test.

    4. If opening this link doesn't work, could you open a new thread, providing a Report ID after triggering the link? The Zotero developers should then be able to have a look.
  • @qqbb Thank you for the comments. As you instructed, I did a debug run, and posted the Report ID in a new thread here:
Sign In or Register to comment.