CSE (Council of Science Editors), Name-Year (author-date) style problems

The CSE, 8th edition, Citation Quick Guide [http://www.scientificstyleandformat.org/Tools/SSF-Citation-Quick-Guide.html] indicates a number of elements that can be in the Name-Year (author-date) citation style, including issue number, doi, article url, and access date. For example:

Savage E, Ramsay M, White J, Beard S, Lawson H, Hunjan R, Brown D. 2005. Mumps outbreaks across England and Wales in 2004: observational study. BMJ. [accessed 2005 May 31];330(7500):1119–1120. http://bmj.bmjjournals.com/cgi/reprint/330/7500/1119. doi:10.1136/bmj.330.7500.1119

In Web of Science, I added to Zotero the metadata for the following article:

The inside and outside: topological issues in plant cell wall biosynthesis and the roles of nucleotide sugar transporters
By: Temple, Henry; Saez-Aguayo, Susana; Reyes, Francisca C.; et al.
GLYCOBIOLOGY Volume: 26 Issue: 9 Pages: 913-925 Published: SEP 2016

The metadata in Zotero included both an issue number and a doi. However neither showed up in the CSE Name-Year citation generated by Zotero:

Temple H, Saez-Aguayo S, Reyes FC, Orellana A. 2016. The inside and outside: topological issues in plant cell wall biosynthesis and the roles of nucleotide sugar transporters. Glycobiology 26:913–925

And if I manually added to the Zotero metadata the article URL and accessed date, Zotero did not include that information in the citation.

Can this CSE Name-Year (author-date) Zotero output be improved?
  • edited December 31, 2016
    @keithstanger The Issue should definitely be included and hence fixed in this style.
    Re the DOI. I am not sure how these things are generally handled. It's an optional thing, so I am not sure if this should or shouldn't be added. (it's doable for sure though).
    There is currently nothing in the code that it puts the issue or doi in.
    To fix the issue thing, you'll need to add this line after line 248:
    <text variable="issue" prefix="(" suffix=")"/>

    I can make a pull request for this to update it, but the style was created in 2014 and I'm not sure for which revision of the style. Currently it seems to be the 8th revision. Maybe this needs general updating?
  • With CSL, we err on the side of including DOIs -- it's the right thing to do.
    We also try to stay atop the most recent version of major style guides, so you should update anything that seems amiss.
  • To add to @adamsmith's comment: if DOIs are optional, we tend to include them because we wish to encourage the use of DOIs, and more generally, because it's always easier to manually delete information from generated references than it is to add it.

    And for versioned style guides with multiple editions, we usually only have a CSL style for the latest edition, which is then be updated when a new edition is published.
  • The Council of Science Editors presents three systems for referring to references: 1) citation–sequence; 2) name–year; and 3) citation–name. These end references have essentially the same format in all three systems, except for the placement of the date of publication in the name–year system.

    The Zotero Style Repository contains 3 CSE styles:

    Council of Science Editors, Citation-Sequence (numeric)
    Council of Science Editors, Name-Year (author-date)
    Council of Science Editors, Citation-Name (numeric, sorted alphabetically)

    The issue number is required for both printed and online journal articles. This element is lacking in the Zotero styles and should be added.

    The CSE, 8th edition, Citation Quick Guide [http://www.scientificstyleandformat.org/Tools/SSF-Citation-Quick-Guide.html] indicates a number of elements that can also be included for online journal articles in all three CSE citation styles:
    access date
    article url

    It would be appreciated if metadata added to the Zotero fields of:


    would be inserted into CSE citations with the proper surrounding formatting, e.g.,

    For author-date:

    Savage E, Ramsay M, White J, Beard S, Lawson H, Hunjan R, Brown D. 2005. Mumps outbreaks across England and Wales in 2004: observational study. BMJ. [accessed 2005 May 31];330(7500):1119–1120. http://bmj.bmjjournals.com/cgi/reprint/330/7500/1119. doi:10.1136/bmj.330.7500.1119.

    For citation-sequence and citation-name:

    Savage E, Ramsay M, White J, Beard S, Lawson H, Hunjan R, Brown D. Mumps outbreaks across England and Wales in 2004: observational study. BMJ. 2005 [accessed 2005 May 31];330(7500):1119–1120. http://bmj.bmjjournals.com/cgi/reprint/330/7500/1119. doi:10.1136/bmj.330.7500.1119.

    Thank you.
  • both DOI and URL in a citation? That seems rather unnecessary/excessive to me. Do they really ask for that?
  • Both examples I provide above were copied/pasted from the cited:

    The CSE, 8th edition, Scientific Style and Format Citation Quick Guide (University of Chicago Press) [http://www.scientificstyleandformat.org/Tools/SSF-Citation-Quick-Guide.html]

    I admit that at this time I do not have access to either the full text 8th Edition printed guide or the full text 8th Edition online guide.
  • @keithstanger
    Check out the edited style: https://www.zotero.org/styles?q=id:council-of-science-editors-author-date
    (I was able to sign up for a 30 day test account to get the guidelines)
  • I will be teaching a Zotero session for an undergrad class that uses CSE author-date, and I noticed some discrepancies between the repository examples for both the Council of Science Editors Name-Year (author-date) style https://www.zotero.org/styles/council-of-science-editors-author-date and the Taylor & Francis - Council of Science Editors (author-date) styles https://www.zotero.org/styles/taylor-and-francis-council-of-science-editors-author-date and what is generated in a reference list.

    1. Both styles make it look like the accessed or cited date information will be provided. However, in practice, once I try and create a reference list that part of the citation isn't populated. Presumably it would draw on the Accessed field?
    2. The T&F version makes it look like the bracketed format of the source will appear (e.g., [Internet]). I don't see that field being populated in my Zotero library or showing up in the reference list. While I hate that CSE requirement with all my heart, the style does specify its use.
    3. The other thing that seems to be wonky is that while the T&F repository example of CSE makes it look like the URL will be provided, the URL is not actually showing up in the reference list. The DOI isn't showing up for the T&F version either.

    The examples provided in the repository for the journal styles are correct (similar to what keithstanger uses above) - it's just that the reference list isn't actually generating citations that match those examples.

    As always - thanks for all your work keeping Zotero and all its odds and ends running so well! I love the new PDF options. Thanks for any help on this CSE hiccup.

  • I think checking the "include URL" box under Cite--> Styles in the Zotero preferences will sort all of these issues.
  • Great! My favorite kind of fix - one that already exists (and my eyes were just skipping over).

  • It's not exactly my favorite type of fix -- if even you're struggling to find it, I'd say that means significantly <1% of users will -- but I'm glad this will work for you for now.

    We've talked about getting rid of that box and doing this properly in the styles, but that's a massive amount of work updating old styles, so there's some trepidation.
  • worked for me too. hanks
  • Have tried the little URL checkbox many times and it has never gotten the job done. Journal articles get their URLs, but not websites, which is completely counterintuitive. Is there another field we could put the URL in to "trick" Zotero into including it? We are citing online sources but can't provide URLs. Yikes, please help!
  • @refs4me -- typically webpages will appear with URL regardless of setting, but this depends on the style. You'd have to say which one you're using.
  • My message was part of the Council of Science Editors (CSE name-year) comment stream. That's the style we're using. Meanwhile, I discovered that URLs appear (in CSE name-year bibliographies) IF AN ACCESS DATE IS ENTERED, but not if it isn't. We often do not want to use access dates. Is there any other way to force the URL to appear?

    Also, is there a help line I could call and speak to you (or someone) "live"?

  • You'll need to change the "access" Macro:

    <macro name="access">
    <if variable="accessed" match="any">
    <group delimiter=". ">
    <group prefix=" [" suffix="]" delimiter=" ">
    <text term="accessed"/>
    <date variable="accessed" delimiter=" ">
    <date-part name="year"/>
    <date-part name="month" form="short" strip-periods="true"/>
    <date-part name="day"/>
    <text variable="URL"/>

    Currently, it tests if there is an access date (if variable=accessed) and only then it prints the URL with the accessed date information.
  • That seems like an odd requirement—usually this test is for URL, not accessed. @adamsmith do you know why this one is this way?
  • No idea and this seems wrong to me. I think this should be <if variable="URL" match="any"> as it is for essentially all other styles.
  • edited August 20, 2019
    We have updated all the CSE styles.
    You can update the styles via the preferences or redownload them via the repository: https://www.zotero.org/styles?q=cse

    Let us know if it's all working now.
  • That's fantastic! Thank you!!
    I'll let you know if I find any more hiccups. But one thing at a time. :)
  • Hi everyone. Thanks again for your help on the URLs. Another question:

    CSE wants us to spell out the full agency name in the author area of references, in addition to using the acronym, e.g.:

    [EPA] Environmental Protection Agency. 2019. Report name. etc.

    The problem is, we/they don't want all that in the text citation, which should just be (EPA 2019). Zotero, however, puts all of it in the citation if it's all entered in the author field. I have figured out two work-arounds, but neither seems great:

    1) In some item types, like Reports, we can just put EPA as the author and Environmental Protection Agency as the institution, and it'll show up after the report name in the reference (which I actually prefer to CSE style). But that field isn't universal (I don't think there's any field that works for Documents, even though you'd think publisher would work). We have to fudge each entry to figure out where to put it so it'll show up in a reasonable location in the reference (e.g., tacked onto the end of the title).

    2) We can leave the entire [EPA] Environmental Protection Agency in the author field, and when we go to add a citation, we can suppress the author and then add EPA as a prefix. Not only is this clunky and a bother in a long report, but sometimes the a, b, c after the year doesn't work; I haven't figured out why it seems to work sometimes but not others.

    If we use one method for one EPA (2019) reference and the other method for a second EPA (2019) reference, Zotero will of course see them as two different authors.

    Any ideas?
  • Two options for this:
    1) The better way would be to enter "EPA" as the author and "Environmental Protection Agency" as the publisher/insitution. For item types that don't have a publisher field, you can add it to Extra like this:
    Publisher: Environmental Protection Agency

    2) A more hack-y way: Enter the author in two-field mode (Last, First; like for personal authors). Enter "EPA" as the Last name and "[Environmental Protection Agency]" in brackets as the first name. That will show up in the bibliography as EPA [Environmental Protection Agency]. 2019. Title. and in the in-text citation as (EPA 2019).

  • Thanks, bwiernik.

    Your suggestion #1 doesn't seem to work for "documents," which has a Publisher field but it doesn't show up in the bibliography. I also can't get Extras to show up.

    In your suggestion #2, the bibliography works as you said (brackets are opposite of CSE but okay), but the in-text citation shows up at least some of the time as ([Environmental Protection Agency] EPA 2019). Sometimes I can delete the "bad" citation and get it to work the next time, though. Very weird... don't know why it's not consistent.

    This is for CSE author/date, which may be different than what you were trying?

  • In general, avoid "Document". It's not well-supported in citation styles.
  • Would love to. Unfortunately, we have several thousand entries and many of them are already documents. I also got some inconsistent results when I tested with reports. But thanks, your advice has been very helpful.
  • Hi all. Following bwiernik's advice, I've made an exception to the CSE style and am "allowing" the author to read as EPA [Environmental Protection Agency] in the references. I actually like it better than CSE's (reverse) style, so it's fine! But here are two more CSE mysteries.

    1. If I check the MEDLINE journal abbreviation box in Zotero's document preferences (in Word), it wipes out the hanging indentations throughout the entire refs list, which I worked so hard to get! Zotero's default for CSE seems to be Times New Roman, flush left.

    2. Hitting Ctrl Z for MEDLINE or any other Zotero step (e.g., entering a citation) completely freaks things out... with each repeat hit of Ctrl Z, the refs go to Times, then lose all spacing, then disappear, then come back!


    Thank you!
  • 1) When you update a style in Document Preferences, Zotero re-applies the default formatting for the style. You can modify it by changing the Word "Bibliography" style: https://support.office.com/en-us/article/Customize-or-create-new-styles-d38d6e47-f6fc-48eb-a607-1eb120dec563
    (Though I don't think CSE requires hanging indents, does it?)

    2) Due to some Word bugs, it's not possible to undo all of a Zotero action with one click of Undo or Ctrl-Z. If you click the Undo dropdown menu in the Word title bar, you will see about 10 Zotero actions in a row. Undo all of them at once to undo the Zotero steps.
  • Thanks!

    Yes, I did modify the Bibliography style to get my hanging indents. It's disappointing that it doesn't "stick," though.

    No, CSE doesn't require hanging indents, but even their online style guide shows it in use. I think it's the best way to go.

    Interesting about the Undo dropdown. That sounds better than hitting Ctrl Z multiple times and temporarily losing your entire refs list while it sorts itself out!

    Thanks again.
  • It only changes when you reset the style through Document Preferences. Otherwise it sticks.
Sign In or Register to comment.