Zotero 5-beta.r91 + QuickLook

Hi everyone,

Has anyone managed to load up QuickLook add-on with Zotero 5 betas?

I am getting an 'incompatible' message.

Thanks
James
«1
  • edited December 8, 2016
    QuickLook works fine with Zotero FF here – mostly. Every few weeks it seems to stay unresponsive, then a simple re-install brings back the functionality. (OSX 10.11.6 / FF 50.02. / Zot 5-beta.r92

    Had no success installing it in Zotero Standalone - the dialog box informs me that this plugin is not compatible with this version of Zotero Standalone. Would definitely love to have Quicklook functionality in the latter. Still trying to warm to Standalone as the move in the nearish future will be inevitable.
  • I'm on Zotero 5 standalone. So sounds like Quicklook needs an update.
  • The Quicklook developer has long since stopped working on it. I doubt it will be updated again.
  • If all it needs is a compatibility bump in the install script, that would be very easy to do, especially since Zotero doesn't require add-ons to be signed.
  • I've updated Quicklook's compatibility to include Zotero 5. It currently works on Mac. I haven't checked it on Windows or Linux--I've never been able to get Windows to work in older versions of Zotero and don't have the time currently to troubleshoot. Happy to accept pull requests.

    https://github.com/bwiernik/ZoteroQuickLook
  • Great work bwiernik! I installed your revised file, and it works for me on Mac

    For those unfamilar with how to manually install extensions:
    1. Download the Zip file from Github using green button at https://github.com/bwiernik/ZoteroQuickLook.
    2. Unzip the downloaded file 'ZoteroQuickLook-master.zip'.
    3. Go into the 'ZoteroQuickLook-master' directory.
    4. Create a new zip file with all the files in the folder.
    5. Rename the zip file to have a .xpi extension.
    6. Drag & Install as normal via the Add-Ons screen in Zotero 5.
  • @bwiernik -- would you be interested in a build script that pushes this to a gh-site?
  • @adamsmith -- any chance of building this light, useful and popular add-on into Zotero 5 as standard?
  • That'd be Dan's call -- since it really only works reliable enough for production on Mac, that might be a reason not to.
  • edited February 13, 2017
    Thanks bwiernik, very appreciated! Have installed your version (Z50.beta136, Mac) and it works nicely. It currently opens pdf, rtf and djvu attachments flawlessly – though fails silently on doc, epub, snapshot and zotero notes. (I seem to recall at least the latter two worked at some stage in ZoteroQuickLook's Firefox career.)
    Very happy to be able to preview pdfs via the space bar again – if anything it seems more snappier in standalone than I know it from Z-FF.
  • I don't have the time or expertise to fix those bugs, sorry.
  • Thank you! This version of quicklook worked for my current version of Zotero 5.0 173.
  • kb
    edited October 10, 2017
    For all who are using Zotero 5 (so standalone of course) on Windows:

    I could get it to work for PDFs (which is enough for me). For installing QuickLook use jamespl's instruction from 13/02/2017.
    In the past we could type about:config in Firefox and copy the link to our preffered reader in "extensions.zoteroquicklook.customviewcommand" (e.g. the Adobe Reader for PDFs). Now you have to go to edit>preferences>Advanced>Config editor to do the same.

    * and ** - thanks to bwiernik for the translations
  • The relevant words are “Advanced” and “Config editor” in English.
  • There still seems to be a problem with Quicklook under version 5.0.25 of Zotero. When I install the QuickLook plugin, it works for a couple days, then all of sudden, it gets disabled and shows following message: "ZoteroQuickLook is incompatible with Zotero 5.0.25"

    I can't turn QuickLook back on and I have to delete the .xpi file and reinstall it for it to work for a few more days.

    Any idea on how to fix this?

    Thanks in advance
  • I’ve not encountered that. Can you find steps to reproduce?
  • I'm not a code-writer by any stretch, but when I encountered the same problem I turned off the automatic update check function on the Quicklook plug-in and it stopped being an issue.
  • Can confirm this issue. Have to reinstall ZoteroQuicklook every few days with exactly this message see snapshot. After a re-install it works fine for some time, then the message pops up again. (macOS 10.12.6, Standalone latest beta.)

  • Have you tried to re-download the QuickLook plugin and then re-install? I got another report from a user that doing that has made the repeated incompatibility problem go away.
  • edited November 16, 2017
    Just tried doing exactly that after your suggestion. So far everything works fine – Zoterquickook opens pdf, rtf and jpg formats. (Djvu, epub, doc, snapshots and zotero's notes still fail silently)
    Will report here if the incompatibility message pops up again. Thanks
  • The issue with the incompatibility message persists after having re-downloaded and installed the latest version of the plugin. After a smooth and successful reinstall the plugin works for a while and then for no apparent reason begins to fail silently; when I check in tools>extensions it is declared to be incompatible with this version of Zotero as in the above screenshot.
  • have you checked if the Quicklook version changes?
  • I have the same problem. The add-in functions well until I restart Zotero, then it reports being incompatible and is disabled. I think I read on the forums that someone had made a version that was compatible, but I can't find that anymore.
  • we don't quite understand why the version shows as incompatible. It really should be fine.
  • Be sure that you are downloading it from here
    https://github.com/bwiernik/ZoteroQuickLook
  • I'm not on the beta but I'm getting the error:

    ZoteroQuickLook is incompatible with Zotero 5.0.28

    ZoteroQuickLook 1.3.1.1-signed.1-signed (disabled)

    After I reinstall the version reports it is 1.3.1.

    Not sure if that adds any information. Thanks
  • Oh, that’s actually really helpful. I think I know what is going on. Should be able to fix.
  • edited 18 days ago
    My ZoteroQuickLook (downloaded from bwiernik's repo) stopped working after updating it by "Tools -> Add-ons -> Check for Updates". I do not know where Zotero got that update from (perhaps from Firefox Add-ons website?). Turning off the option "Update Add-ons Automatically" and reinstalling ZoteroQuickLook (or dragging it to the Add-ons panel) may help.
Sign In or Register to comment.