Attached PDFs stopped displaying within Firefox (see code characters)

I upgraded to 1.5 Beta from working installations on: (1) my Mac and (2) on a Portable Firefox Windows installation running from a USB drive.

All was fine on the Mac after the upgrade; all was also fine on the Portable Firefox USB installation at first.

Then I copied the Portable Firefox Windows installation from the USB drive onto the main drive of a Windows computer. I repeated the set up steps, using "Restore from the Zotero server" to bring in the data. The library looks OK in the Zotero panel, citations intact, but if I attempt to open attached PDFs, I get a page of text in Firefox that looks like the PDF code. The PDFs themselves are OK in the Storage folder: I can navigate to the new storage and find a PDF there and open it OK in Acrobat.

At some stage in trying to also 'restore' my USB Portable Firefox, that copy also started exhibiting this behavior.

All is still OK with the non-portable installation on the Mac: it is syncing and attached PDFs display OK.

Any suggestions of how I can fix this? Anyone else having this problem?
  • I still cannot view attached PDFs on the Windows portable version of Firefox running the beta Zotero. It worked at first, then something got corrupted(?).

    Instead, I get computer code filling the browser window. If I click "Show File" and open the PDF from inside storage it looks OK in Adobe Acrobat. On the Mac version on another computer the PDFs look OK. I only see this on the Windows Firefox portable version: the same installation works OK viewing ordinary PDFs I follow links to on the web.

    I generated a report ID 67848600 for this.
  • the same installation works OK viewing ordinary PDFs I follow links to on the web.
    Do "ordinary" PDFs open in a plugin in your browser or do they open in Acrobat externally?

    And have you tried anything recommended in:
  • Yes, other than from Zotero, PDFs on the web that I go to by following links do indeed open in a plugin in my browser. That seems to be working OK.

    Thank you, but those discussions seem to be about something different from my problem.
  • Here is what I see at the top of my browser when I try to view a Zotero-stored PDF:

    %PDF-1.4 %âãÏÓ 67 0 obj<> endobj xref 67 29 0000000016 00000 n 0000001302 00000 n 0000000876 00000 n 0000001395 00000 n 0000001436 00000 n 0000001641 00000 n 0000001792 00000 n 0000002499 00000 n 0000003672 00000 n 0000004343 00000 n 0000004377 00000 n 0000004434 00000 n 0000004870 00000 n 0000005065 00000 n 0000005449 00000 n 0000005547 00000 n 0000006260 00000 n 0000006979 00000 n 0000007736 00000 n 0000008444 00000 n 0000009127 00000 n 0000009816 00000 n 0000010478 00000 n 0000011022 00000 n 0000013691 00000 n 0000021275 00000 n 0000035831 00000 n 0000040422 00000 n 0000040854 00000 n trailer <<694ac97e1f732d07a7cdd1781e445773><2dd250a9d8ab2e438e753c0968851e44>]>> startxref 0 %%EOF 69 0 obj<>stream xÚb```¢“¬¬ù ÌÀeaàØÑÄÐÀÀÀ$�ZÌàØwüÃåµ}Ìv©¸ÿ3.:`Ô5Wö/ï +¦W¢&Þ*¼;Îœ9�3MR%0¬ñÕÔ­g&é2/ÍI™èÅîu뙧Xã¥mF‹Ö2/Í-VÈTz VwiÛÎI®JÖöLÒXíð2:æ¤Ò«°cž"¡@±u)³´ÀzaÜ©n ×á’«(‚û�d'GÐÝÌf‚ &£@)c 6A% ‹HPH¡@DBŒdR¶èh :$€ÀœAêV–bi°ˆƒ×Y§…‚gÔ/00ˆ³yp „78pÍѺ°åÐ".sÿiê^§7ñ,›‹‚/, -¤^îÒL@ìÄR··iF6 æa`xÐð À�%†ŒW endstream endobj 68 0 obj<> endobj 70 0 obj<> endobj 71 0 obj<> endobj 72 0 obj<<>/Font<>/ProcSet[/PDF/Text]/ExtGState<>>> endobj 73 0 obj<> endobj 74 0 obj<> endobj 75 0 obj<> endobj 76 0 obj[/ICCBased 90 0 R] endobj 77 0 obj[/Separation/30#25#20Black 76 0 R 94 0 R] endobj 78 0 obj<> endobj 79 0 obj<> endobj 80 0 obj<> endobj 81 0 obj<> endobj 82 0 obj<>stream H‰ŒSÛrÓ0}÷Wì£4S+Òʲ侵)t(ÐRbfÚ>¸¶“¸¸6$Τý$þ†Obe'Ô(C2ñE9»çè¬Îät†°XÇi0y­@A:ôõWëÒû@‚~iî/Û€Oï‚ÉtC¾î¡ÖyaAHwm-¤'Ò_rÅÒe oš®\5YWµMVÃ7’µ›•nç<´R8çÙ¦«rZ:ZñH³œ£bˬlëvÁ• {ä7éiÅA«—FŒÚÆ#âéÄXX—¨„Â5C)í5‡‘QidŒûo¦DX«Ü˜‰é¸Ç>ÓO8%ñ¨íKµ×.ðšýDmû=„h„E—@¨„¢OOP´Õ!(Ù/Lî„’‰ ¤!øÝ)Uäăñ*õ:œ×¡z “Ó™öGÆH¡]±EºG9%‘ Ve0ʦ3*›MÏi§g´‰; [¢†÷pu#¡T°ïf%iu÷ífÁ÷=Æ8Ú|ò¡WøÍàQŽyZô´Â3zá8nŒ@Œà>0’‡»…š¸.ƒ)®oæ(»<ü9—Ñ10BY@f Óð÷#RÃŒ~€7|Ž¸‰éDoºe»â±aÂg÷™˜¶÷ߪ:ã˜0ŸŽC¢($C@|T0kóªì¹R¾c�¤Ÿ<¹NRBÒ"MŸe¥ãAÔ‡Í퐮ºZ/Ën9JJšdp\gù×-WýYÖ5<>stream H‰|TËv›0Ýó³”zl"‰wwÄ%±süh^äøtA±‚i1äX8ÿl·í¯tØmœ¶G‹Ñ¹£{k2K‹ âfO¹E¤l
  • Thank you, but those discussions seem to be about something different from my problem.
    I agree they are not identical to your problem, but they do provide work-around (e.g. disabling the plugin & launching the PDF in acrobat). They also contain a few tips on how to diagnose the problem (e.g. obtaining debug output to see if Zotero is correctly sensing the mimetype of the file & that there is a plugin for it).
    Anyone else having this problem?
    Other people have reported more general problems with the Acrobat plugin ( I do not know why that plugin would sometimes work for you and sometimes not, but reinstalling it seems to be a reasonable thing to try.
  • Thanks again. I followed your suggestion and changed Firefox preferences so PDF documents now open directly into Adobe Acrobat, rather than appear in the browser through the plugin. That will work fine for now--in fact I quite like it!
  • Maybe I wrote too soon: that worked for a while. Then, with quitting and restarting Firefox several times, I ended up getting a message about a sync already running, and did I want to reset or cancel (could not figure out what I wanted, I think I tried cancelling). Shortly after, even though I had not knowingly changed the Firefox prefs, all PDFs started opening with the plugin (in the browser) showing the same raw code.
  • I accidentally found a way to repeat this problem. First, on the Windows installation that was giving me the problem, I had gone back to my latest good Zotero folder backup that had worked with the v1 plugin. I uninstalled the beta plugin, reinstalled the v1 plugin and pointed it to the restored folder: the installation worked fine.

    Then I installed the beta plugin and pointed Zotero to a copy of this old Zotero folder: Zotero updated it, backed up the documents to my WebDAV server, and successfully negotiated several syncs with new citations/documents. This beta installation worked fine.

    Then I successfully 'restored' this data to my Mac, by reseting that installation to download all data from server. That installation worked fine.

    Problems began when I tried to rename my Zotero folder in the beta installation on the Windows machine. It had been called something inelegant like 'copy of old Zotero folder to be used to restore beta version' and I wanted a nice name like 'zotero-beta', so I renamed it to that in Windows Explorer.

    The next time I opened Zotero it came up with a dialog saying it could not find the zotero folder and offered to let me find it. I did so, pointing to the newly-renamed folder.

    I restarted Firefox. Then, opening Zotero, while my citations looked OK, all my PDFs that I tried to view in the browser, using the plugin, showed the raw PDF code again.
  • Still don't know why this was happening, but I 'fixed' it by restoring a complete Portable Firefox installation folder that I had backed up, then set Zotero preferences of the restored Firefox copy to point at the same zotero folder that had appeared to give the problem. PDFs then displayed fine in the browser window.

    I conclude that the corruption, or whatever it was, was somewhere in my Firefox installation, and not in the zotero folder.
Sign In or Register to comment.