Zotero standalone unable to update, need permission

I'm on a Macbook Pro running Yosemite.
I'm getting repeated notifications about needing to update Zotero standalone (I'm using 4.0.20) but when I click update it says it is unable to update, due to my not having permission. How did I lose that permission and what do I do to get it back?
  • edited September 28, 2016

    But there may also be something else happening and someone else will need to help with that.
  • No, Disk Utility won't help here. (That's mostly always been a superstition. Among other things, it only ever worked on programs with installer receipts.)

    @Larisa: 4.0.20 is 2.5 years old, so this isn't a new problem. Your best bet is to just delete Zotero from /Applications and reinstall it from the download page. Your existing data won't be affected.
  • Thanks, yeah I don't think disk permissions is the issue, the full message is:

    "A recommended update is available but you do not have permission to install it. To update automatically, modify the Zotero program directory to be writeable by your user account."

    I'll try deleting and reinstalling (scary!), but I hope that it will be automatic in the future?
  • At the risk of repeating a post from elsewhere, I am having the same problem (running Zotero under OSX Yosemite and El Capitan). Even "chmod 777 /Applications/Zotero.app" does not get rid of the problem - Zotero still thinks I don't have the requisite permissions. Having to manually delete and reinstall every time there is a Zotero update is not really a great long-term solution; it would really be better if Zotero were able to update itself.
  • Obviously, Zotero is typically able to update itself and this is particular to your case.

    I'd do the delete and re-install and see if the problem persists for future updates. If this is a one time thing, this is much faster than diagnosing permission issues in your applications directory. If this keeps being an issue, we can take a closer look.
  • @adamsmith: OK, I'll try that and see what happens. Thanks.
  • I also have this problem. If I delete and reinstall what happens to my pdf files that my database contains and are stored on my computer. When I reinstall does zotero find the old files on my computer? Has anyone had success delete and reinstall for this error message? Mac OX 10.11.6 (El Capitan)
  • Replacing Zotero in /Applications has no effect on your existing data.
  • I have this problem, with the added issue that my desktop version of Zotero is no longer syncing with the web-based version, so I'm concerned that if I delete and reinstall I'll lose some of my data. (Zotero crashes anytime I try to sync, or do anything more complicated than add a new item—so I can't export the library either.) Using Zotero version 4.0.11 with Mac OS 10.14 (Mojave).
  • edited April 1, 2019
    @krm2152: Just make a backup of your Zotero data directory (unnecessary, but to be safe) and install Zotero 5 from the download page.
  • @dstillman that worked perfectly. Thank you!
Sign In or Register to comment.