Papership and online library are not syncing

  • Just tried it. Still not working - I can't get it to recognize I've tried both the option and WebDAV option, but it doesn't seem to want to recognize any address, username, or password I put in.
  • I am having a similar if not the same issue. Only some of the PDF attachments from my Zotero library are syncing to Papership, though my libary is synched and updated...
  • Can you see the attachments on If so, then this would be a PaperShip issue and you would need to contact them (but do know that the next app receives very little support anymore).
  • yes and that's a shame. I am trying to optimize the ipad mini I bought for fieldwork to be able to read and annotate papers on the subway without needing a connection. Not having wireless is proving to be a hindrance in this setup. So far I've been moving the ones I want to read offline to onedrive or google drive before leaving wireless but it gets disorganized easily...
  • Are you using Zotfile to send PDFs back and forth from Zotero to a folder in your cloud drive? That would make the organization easier.
  • I'm frustrated to find out that, with ZotPad error message "v1_retired" returned from Dropbox, ZotPad's API in use is out of date. Now I'm in a situation that, there is no iPad App that can both read the notes and downloads the PDFs at the same time.
    What a pity! What if the ZotPad or Papership can revive~
  • The Zotfile code is open source, so it would be possible for someone to revive it, but it is now several years out of date, so it would require major updates to work with current iOS versions:
  • I can happily tell you that I'm using Papership with Zotero syncing through "" just fine. Works on iPhone as well as iPad. I've had issues, no doubt, but I've resolved all of them so far.

    The two major ones are:

    1. Syncing. I had to manually put an empty and editable txt file called "lastsync.txt" in the zotero folder in my box (i.e., in your root box there needs to be a folder called zotero, corresponding to your sync settings in Zotero standalone). In that folder, there also happens to be an empty folder called "papership", but I'm not sure whether it actually has to be there or not. The lastsync.txt is updated on every sync, containing only a string of some 30 characters, which changes with every sync.

    2. Getting PDF's found when researching on the iPad to upload Zotero (i.e., Even though the entry will always show up in Zotero, the PDF will not, necessarily. Here's the solution: Essentially, don't use Papership's built-in browser to find PDF's, but use iOS Safari and share the PDF to Papership. This way, uploading and further syncing after annotating is fine.

    Good luck!
  • Thanks, guys for your comments! It was really valuable.
  • @Zbotnik thanks so much for solving the syncing problem!
  • edited April 4, 2018
    @Zbotnik I find the is an alternative. I'll try and use it.
  • @Zbotnik This was genius, thank you so much! Fixed the sync issue perfectly!
  • @Zbotnik Is the solution with "lastsync.txt" still working for you? I remember it used to work for me when I found your comment some months ago. But now I'm confronted with the same problem again: Papership will not sync annotated PDFs back to
    Quite frustrating. Uploading a new, empty "lastsync.txt" didn't solve the problem this time. Is this happening to other Papership users as well? Has anyone found a reliable solution?
  • I've moved over to pCloud because Box webdav is going away at the end of this year ( I haven't tested Papership with pCloud yet, but I'm hoping that it works, with or without these "hacks."

    Not sure if its allowed (if not, feel free to remove it), but here's my pCloud referral link (gives me an extra 1gb for every user that signs up):

    I've found the service very good. 10gb base, plus its easy to grab another 4gb through their "tutorial" and the option to refer and win up to 500gb more. Hopefully this service lasts a long time.
  • I've just installed the on iPad and synced with Zotero online library with more than 9000 entries and 4 group libraries. It took near 1 hr to sync all data, but it performed well currently.
    I did not purchase PDF Annotations Pack, but basic changes such as adding tags works and synced back to Zotero online library as expected.
  • I can confirm that Papership is working with pCloud, although it's not ideal. It does seem to have some problems syncing (freezing, going through the motion of syncing but not actually downloading things), so it's a bit off and on. I also can't seem to find all my notes for items. In fact, clicking on one reference that has ~10 notes (chapters in a book) brings up notes for Chapter 7 seemingly at random.
  • When I added "lastsync.txt", the syn between Zotero-wins, Zotero-mac and Papership is OK.

    But I cannot load PDF documents in Papership. And I also cannot import PDF from safari in iOS, the err is ``cannot create document'' (413).

    Could please someone tell me how to do annotation in ipad that can easily syn to Zotero?
  • I recommend using Zotfile to send PDFs between your Zotero library and a cloud-drive folder, such as Dropbox or iCloud. You can then access the PDFs in that cloud folder using iPad apps such as iBooks, Adobe, GoodReader, or Goodnotes.
  • How do I go about this. I want to have the referencing ability on PaperShip app on iPad and my Zotero on windows laptop .

    My problem is I can see the updloaded PDFs on papership but papership isn’t picking the citation
  • Papership isn't really actively developed anymore, and it isn't reliable in its syncing. I recommend you not use it.
  • I paid for the annotation function and then I does not do anything
  • PaperShip and Zotero are separate projects. Zotero has no influence or affiliation with PaperShip. PaperShip was once a very useful utility for use with Zotero. That time has past.
  • in short: As of today, it possible to sync Papership again!

    1. adding just an empty lastsync.txt file to the zotero folder on the WebDAV storage still makes it possible to sync Papership.
    2. you need to make the lastsync.txt file writable to the WebDAV user on the server
    3. as worst case it has to be "touched" wit a new modification date after every Zotero or Papership sync, because if Papership sees no change it will refuse to sync.
    4. For occasional use I recommend using the commandline via Terminal and the unix "touch" command on Linux and OSX Servers via ssh and/or automate it eg. using a cron job or watcher on the zotero folder.
    5. Using graphical WebDAV Clients is cumbersome because of the huge amount of files to be listed.

    If someone has missed the details, see my comment here:
  • Great! It’s been working for me the last couple of weeks though, haven’t experienced any issues. In any case, has anyone tried PaperShip under iPadOS 13? I won’t update until I’m certain PaperShip won’t die on me!
  • edited October 14, 2019
    @Zbotnik I can confirm that Papership sync works (using the lastsync.txt workaround) on a brandnew iPhone11pro max with iOS 13.1.2 and a restore from a backup of an iPhone6 without noticeable loss (errors) regarding the library. And yes speed is awesome (I have a 40GB WebDAV storage now in usage for 10 years.) and it finds stuff from 2009 lightningfast.

    I have not tested if the PDF features are still functional in depth. My usecase ist finding entries offline in the field as reminder for my brain. Download to the device most of the time is limited and not often necessary. But in case it works usually if it works in standalone.

    One more thing: Starting the standalone even on lame desktop machines is improving constantly in 5.x. Good Job. I hope and guess the new iPad App experience could exceed our expectations.
  • I can confirm Papership works fine on an iPad Pro together with the standalone iOS as well as the web version of Zotero. Annotations in PDFs and Memos are updated.
    But: I use the zotero storage, not WebDAVs.

    (At first it seemed not to sync well, but at least after logging in to and after checking the properties of the APIs for Papership it works perfectly.)
  • It didn't work initially because I had the iPad open with new PFD annotations while I also had both the Zotero desktop and web versions open. PaperShip must have been confused. I closed them all. And then just oped PaperShip. It synced all the way through. I am not sure if this had anything to do with it working, but I also set the iPad to house the files locally (not cache) right before it started working.
  • Hi guys,
    Struggled with this for a bit so I thought I'd share my experience. I synced my library on Papership before acquiring the PDF annotation toolpack. Then when I was making annotations on my PDFs, I could not get them to sync, although the API for papership was fine on Zotero's side.

    The only way I found to fix the issue was to delete the API key for Papership. Problem with this was that I had to log again in papership and it caused the whole library to upload again, and more annoyingly, I lost the annotations I did previously. Fortunately it was only one paper but think about it before you do this if you already annotated a lot of paper in Papership!!

    Now it works like a charm (I use Zotero storage, not WebDav), I can annotate my PDF on my iPad Pro, see/edit these on my MacBook and everything is kept in sync. Finally a good workflow to use my iPad with Zotero!!! Shame it seems that the development has stopped...
  • An update on a syncing bug I just noticed: Syncing of annotations from Papership (iOS) to Zotero (MacOS) seems sometimes to be interrupted by empty entries (i.e., lacking attachments) in the trash. Emptying the trash might solve it, as it just did for me.
  • eddes91, can you share how you were able to delete the "API key for Papership"? Thank you
Sign In or Register to comment.