LO word Processor Plugin failure (OSX 10.11.6, LO

Everything was working with current Zotero / Plugin ( / 3.5.12) for FF and LO plugin on LO 5.0.1 with JDK 8 - 92 on OSX 10.11.6, FF 47.0.1

I updated to JDK 8-102 and LO hung.
Ended up turning JRE off, installing LO 5.1.4.
Started LO and it requested a JRE and with JRE turned on (Location: /Library/Java/JavaVirtualMachine/jdk1.8.0_102.jdk/Contents/Home/jre) , LO operable again, but Zotero not functioning anymore.

FF then indicated plugin was not allowed. Removed plugin and reinstalled latest from here (3.5.12) and tried to reinstall automagically. Failed. Tried to install manually, and process hung (did not get LO not responding, but process would not respond).

Rebooted machine and tried again. No Joy.

I know LO chokes on java regularly, and Zotero needs the Java to work. It appears that the Java itself is not hanging LO, and it is the JDK installed (though LO decides it is pointing to the JRE in the JDK install).

What now? Getting to the point where this is becoming too much trouble to recommend to my students. SUggestions?
  • Repeated Install.
    Found Plugin via LO extension Manager in disabled state.
    Attempted to Enable.
    LO stops responding.
  • edited July 28, 2016
    I can get this to work on 2 Macs but not the 3rd. The one I'm on now works AFAICT. It is running LO 5.1.2 and Java 1.8_91 rather than 101 or 102. I will try this combination on the other Mac and report back. But it may be a week or so because of an upcoming trip.
  • I was at Java 1.8_92 when it was working. LO apparently accepts 102 as adequate to start, but even if I turn Java off in LO, plugin install hangs.
  • It's Java JDK (Java Development Kit)

    I just reinstalled 1.8_91 on the computer where the Zotero plugin did not work with LO. First I tried an older version of LO 5.1.2. Before I downgraded JDK, it did not work with the plugin. After installing 1.8_91, AND SELECTING it under Preferences/LibreOffice/advanced, it worked fine.

    Then I did the same thing with the newest LO (i.e., selected the older JDK) and it also works fine with the Zotero plugin. Perhaps 1.8_92 works too, but I don't have it.

    IMPORTANT, this is not JRE (Java Runtime Environment). I was unable to downgrade that to 1.8_91, but it didn't matter. It is JDK that is the problem. Fortunately, you CAN have more than one version of JDK.

    So just install JDK 1.8_91 (or maybe 92), and select it in LO, and the plugin seems to work fine.

  • Installing the JDK did NOT fix this problem for me. This is a serious hindrance and should be addressed as soon as possible oh zotero team!

    Either via explicit instructions or a more "forgiving" plug-in that does not have the JDK/JRE version dependency we're seeing here.

    My students are suggesting that they wish to go back to EndNote!
    Gah! Help us!

  • Did you install the specific version of JDK that I mentioned? It looks like later versions are the cause of the problem, at least for a couple of us.
  • Nope, not yet. My point is that I shouldn't have to deal with a relatively small version increment/decrement to get the plug-in working.

    I realize that this is Oracle's fault as much as anyone's but I'm not sure what the nuances of the plug-in dependencies are that require a downgrade.

    What is the difference between the JDK versions that has caused this incompatibility?

    I'll downgrade when I can find it. Right now the JDK page has _101 and _102 so I'll have to poke around for the _91 and _92.

    Thanks though!
  • All programs depend on other programs to run correctly. Every time there is a major upgrade to any OS, there is the possibility of some (sometimes many) programs that do not function correctly because some functionality they depended on is no longer available in the way it was before. Robust program design attempts to anticipate such problems and avoid them as much as possible. But as someone who has designed and written software, I know that it is impossible to predict how every change to a 3rd party dependency can affect a program. That is, there is no way for the Zotero team to know in advance what Oracle might do with its Java JDK, how that might affect LibreOffice, and how that might affect the functionality of a plugin that is an addition to the main Zotero software.

    That said, the first thing that is needed to solve a problem like this is to find out what is causing the problem. In this case, it is looking likely that a change in JDK, which does not have any obvious effect on LibreOffice, but which seems to interact with LO in such a way as to prevent the Zotero LO plugin from working correctly. If this can be verified by others testing it out, then the dev team will have something to work with for isolating and fixing the problem. It also seems to provide a potential workaround that will let people keep using Zotero and LibreOffice together until this issue is resolved. To make this easier, here is a link to the older version of JDK for the Mac on my DropBox:


    I cannot guarantee how long this link will remain stable, but I don't plan to change it in the near future.

    FWIW, the reason I switched to Zotero some years back was because of all the bugs and periodic non-functionality of EndNote. Commercial software is not inherently more stable and bug free than open source software. In fact, this comparative (not absolute) reliability of LibreOffice over alternatives is what pushed me to use it more and more.
  • Yes, yes, I know, I know. I understand the complexity of interrelated dependencies. No need to get your back up! :-)

    I, personally, won't switch but my students complain. That was my point.

    This does not appear to be a major change in the JDK so it is puzzling to me how that minor change affects LO. I realize it's going to take work but, as you see, we can't necessarily rely upon Oracle to keep the older, compatible versions of the JDK up on their website so the Zotero support team is going to have to either keep a mirror or fix these dependencies.

    Look, I know it's a hassle. Lots of us depend upon Zotero for our professional output so my urgency and stridency is merely because of that.

    I love what you guys do, keep at it! I'll keep supporting you. Getting the plug-in working needs to be easier and better documented or we need to have fair warnings given during the install process. That's what I'm asking for.

    Thanks for the Dropbox link! :-)


  • I'm not feeling grouchy about this at all. In fact, this was a potential disaster for me too, since I depend on Zotero so much for writing paper, writing grants, doing research. So I fully understand your concern as well. For the record, I am not a Zotero developer (I've developed on GRASS GIS) but a dedicated Zotero user.

    My only point is that a problem like this is really impossible for any dev team to anticipate. This seems (from the numbers) like this is a minor change in JDK. But as is the case in general for complex systems like this, tiny changes can sometimes have big effects (and big changes can also have no effects). Now that the source of the problem has been identified, it will be possible to try and track down exactly what it was that cause it. Hopefully, the plugin can be made robust against the same kind of change in the future. But there will always be another, unexpected gotcha. It is a constant arms race.

    The big thing that OS software has to help it is its ability to use potentially apply large-scale crowd sourcing to this evolutionary scenario. That is, the availability of a large and active user base can rapidly help ID and fix problems. By getting to step one here, it will enable the dev team to more effectively do its part.
  • Yeah, I think that the "gap" for me is that the Zotero developers realize the strong reliance of LO on Java so documenting these bugs and seeing some dialog from the Zotero developers re: this problem (more transparency??) would be helpful.

    Perhaps I'll frequent the developers forum.... :-)

    Thanks for the help!
  • FWIW, I just now talked with a colleague who uses Linux and warned him about this issue. He said he already knew about it. The JDK upgrade messed up a number of other programs on his system and he had to roll back to 1.8_92.
  • (FWIW, there's no one currently on the Zotero side who monitors the word processor add-ons as closely as should be the case. I try to provide help as I can, but I didn't write them, don't know the code, and don't have a Mac to even test solutions. To make things worse, while Zotero now has significant coverage for unit tests for the software, doing this for something like word processor integration with as many moving parts as it has may not be possible.

    I don't think this is great situation and there's other work that should happen on the word processor integration (e.g. speed improvements), so I do hope Zotero either convinces Simon (the dev who wrote all the code) to check in more regularly or puts someone else on it. There might be capacity to do so after the 5.0 release, but I have no internal insights on this.

    All this said -- the bugs here are almost certainly on the Oracle/LO side of things, so all Zotero could have done would be to monitor&warn.
  • Thanks cmbarton for the Dropbox link.

    When I updated LO for Mac to, it no longer recognized my JRE (which seemed sufficient in previous versions) so after a bit of digging I installed the latest JDK (102). The Zotero extension was suddenly disabled and LO hung whenever I tried to reinstall it. The rollback works fine.

    I just wish there were a more efficient way to get that information out there, because probably every single person using Zotero and LO for Mac now is digging around trying to solve the same problem.

  • Thanks also cmbarton for the Dropbox link.

    I also downgraded the JDK to _91. It worked in the sense that I can add citations again in LO, but I can't produce a bibliography in the LO document. So overall I am still not operational.

    Not sure what to try next. I've lost more than half a day on this, and this thread has been the only thing I've found that gets near helping.
  • Same problem with LO on Mac (actually, I've had similar problems in the past months with different versions of LO and Java...). I solved it by installing Java _91 with brew cask following this guide:


    But I installed the _91 version directly with this command on the terminal (it installs the _91 version, not the most updated):

    brew cask install https://raw.githubusercontent.com/caskroom/homebrew-cask/0e78df41e8a27672e313fd7b0d1d7041573a12b3/Casks/java.rb

    The JRE could not find later, this was solved with this command:

    jenv enable-plugin export

    I also had to downgrade LO to 5.0.6, with 5.2 It freezes in the installation of enabling of extensions (in El Capitan):

  • Hi!

    I was going to start a new post about all this and then I found this thread! My goodness, I've been trying to fix this issue on my macbook pro for 2 days now!! Lost so much time on this... I finally downgraded to JDK 1.8_91 and its works fine. Tsk cmbarton for the Dropbox link!

    Zotero forum or plugin troubleshooting page should have a dedicated place for this issue apart from this thread, which is very informative BTW.

    joehill is so right! Probably "every single person using Zotero and LO for Mac now is digging around trying to solve the same problem" and so this info needs to get out there on the troubleshooting page at least!!

    I have all the latest versions of everything I'm running LO 5.2.04, MAC OS X 10.11.6 El Capitan, Zotero, LO Zotero plugin 3.5.9, JDK 1.8_101 and I just found out it's the 101 that's the problem.

    On the troubleshooting page: https://www.zotero.org/support/word_processor_plugin_troubleshooting, we can find these instructions below, but of course the step 3. is not working as LO hangs when I click enable.

    These instructions should be changed and warn users not to install a more recent version of JDK than 1.8_91 for now.


    LibreOffice 5.1 on Mac OS X El Capitan: No response from plugin

    Issue: The out-of-the-box installations of JRE are not being recognized by LibreOffice 5.1 and therefore Zotero's Office plugin doesn't work.

    Current Solution: Java Development Kit (JDK) is now needed for the plugin to work – this is different from the Java Runtime Environment (JRE) previously necessary.

    1.Download and install Java Development Kit (JDK) v. 8 JDK

    2.In LibreOffice: Check in Prefs > Advanced if v 1.8.0_77 is actually selected in the box

    3.Go to LibreOffice Tools > Extension Manager, scroll down to “Zotero LibreOffice integration” and select; you should see an “enable” button appear.

    4.After enabling, the plugin-in will be responsive to the the Buttons in LibreOffice's toolbar.

    Tested on: Libre Office / LO Integration Plugin 3.5.11 / Zotero / JDK 1.8.0_77 / OSX 10.11.3
  • edited September 1, 2016
    @alexandrearley: Have updated the documentation with information about the newest version of JDK that still works. (See here)
    @ cmbarton: thanks for the link to jdk 1.8_91 in your dropbox. Since the JDK sites only offers newer downloads, I've linked from the documentation to the file in your dropbox – if you could kindly leave the .dmg there until this issue is hopefully resolved. Should this be no longer possible, please give Zotero's LO/Mac user's a heads up in this thread here and I'll remove the link from the documentation.
  • edited September 1, 2016
    Just found Oracle's archive for older JDK versions here. Changed the link in the Zotero's docu accordingly.
    @cmbarton: Please ignore my request from the previous post.
  • (thanks kithairon, both for updating docs and for finding the JDK archive.)
  • I just updated to LO and it seems to work with the latest version of Java (102). For me the incompatibility happened when I updated to LO but went away with this most recent update.
  • edited September 13, 2016
    I can confirm joehill's solution. Updating LO to the 5.1.5 branch resolves the problem presented by the upgrade to Java 1.8_102.

    I think most of us are aware that LO on the Mac has had a bit of a bumpy ride because of java friction. And searching for threads on this forum can be a bit easier if the subject is comprehensively stated (I believe the search function in this forum only does searches of subject lines -- @adamsmith?). I am required to pay nothing to use any of these components, but, as was pointed out, if one wants students to use these products they need to aggressively avoid such issues (though I actually had an LO peep advise that since LO was not used by students, they had no concern for student experience, lol).

    So while we need to keep inter-product QA in mind now, we also need to recognize that Java 9 is some six months away, and will undoubtedly break everything ;-)

    Thanks all for working the problem. Three days to confirm a work-around, and 6 weeks to confirm that upgrading resolved the problem is not the worst experience one could have.
  • This is great news that a very scary situation is actually fixed now.
  • @joehill and @netbuoy , this issue is still present with LO so I'm not sure it's completely fixed.

    Would you be "brave" enough to try to upgrade to and see if the issue comes back? You could always roll back to 5.1.5 branch afterwards if you want it to work again.
  • Just now downloaded and tested I have not updated JDK/JRE. But it seems to work fine with Zotero (made a test citation and bibliography).

    Note that 5.1.5 is the stable version and is the dev version.
  • There IS a LO Fresh version at 5.2.1 (http://donate.libreoffice.org/home/dl/mac-x86_64/5.2.1/en-US/LibreOffice_5.2.1_MacOS_x86-64.dmg) which is not a dev version. Perhaps you should upgrade to that @cmbarton

    Everyone needs to remember to indicate the versioning of all the components when indicating something blew up as it gets very confusing when you are talking about the versions of an OS, two applications, and two plugins.

    @alexanderfarley writes that things went sideways with LO, but did not indicate what was set for Java, nor whether with JDK or JRE. There are I think a number of possible glitches at work. @cmbarton downloaded and says it works, and I am assuming that he means it works with Java 1.8_102, yes? As mentioned above, perhaps test with LO Fresh 5.2.1?
  • FYI, I just did a download of 5.2.1 LO Fresh. I am running JDK 1.8.0_102 and all works correct (Zotero, Zotero Integration 2.5.12, and OSX 10.11.6).

  • Here's another working setup - I’m using a Macbook Pro running Mac OS X version 10.9.5 (two versions back because I didn't want to have to recompile a large amount of custom scientific software I use). Just after I very recently updated LibreOffice from to, the Zotero bibliographic plugin stopped working. Following is my current workaround that requires only downloading and installation of an archival (outdated) version of Oracle’s Java Developer Kit (JDK) and an archival version of LibreOffice - all other software can be left as it currently is including up-to-date versions of LibreOffice (now you’ll have two versions), Firefox, and you don’t have to reinstall either of the Zotero plugins (for Firefox and for LibreOffice) if these were previously installed.

    Firefox 48.0.1 (current version as of 15.09.2016; available at: https://www.mozilla.org/en-US/firefox/all/#en-US )

    Installed plugin: Zotero for Firefox version (available at: https://www.zotero.org/download/ )

    LibreOffice (available at: https://downloadarchive.documentfoundation.org/libreoffice/old/ )

    Zotero LibreOffice Plugin 3.5.12 (The latest version of the LibreOffice plugin for Zotero 3.0+ is 3.5.12 (compatible with all versions of LibreOffice, all versions of Apache OpenOffice, and OpenOffice.org 3.0-3.3.x; available at: https://www.zotero.org/support/word_processor_plugin_installation ).

    Java SE Development Kit 8u91 (available from Oracle at: http://www.oracle.com/technetwork/java/javase/downloads/java-archive-javase8-2177648.html#jdk-8u91-oth-JPR ) You must click on the radio button “Accept License Agreement” (I downloaded: Mac OS X 227.29 MB jdk-8u91-macosx-x64.dmg); you will be redirected to an Oracle login window and you have to create an oracle.com account to be able to download archived versions (this is a safety feature intended for allowing software developers access to old versions that do not possess up-to-date safety features!) After you open the .dmg image, direct the installer to install the JDK software at: /Library/Java/JavaVirtualMachines . This will create a new directory “jdk1.8.0_91.jdk” filled with the working files that include the Java Runtime Environment (jre).

    Now open LibreOffice and in the Mac menu bar go to LibreOffice>Preferences…>LibreOffice>Advanced . Under Java Options be sure to check the box for “Usse a Java runtime environment”. You will likely see at least two entries for runtime environments in the menu - click the radio button in front of the entry “Oracle Corporation 1.8.0_91” and finally click the blue “OK” button to save the settings. (The newer/updated version of JDK on my Mac is “Oracle Corporation 1.8.0_102” and this does not work with the LibreOffice/Firefox/Zotero constellation.) Please not that the Mac OS operating system is still going to use the latest version of Java JDK (and its associated Java runtime environment) - you can verify the current version used by Mac OS X by opening a terminal and typing: java -version . Also, for general security, you should be sure that under the Update tab of the Java Control Panel( that appears when you open the SystemPreferences window for Mac OS X) has the box checked for “Check for Updates Automatically”.

    You should be good to go now for using Zotero with Firefox and LIbreOffice for inserting literature citations and formatting bibliographic citations for your manuscripts.

    - - - - -

    I'll try the solution that netbuoy came up with yesterday and see if this works for me too (will repost to confirm....)
  • Today I confirmed (similar to what netbuoy reported 2 days ago) that all Zotero functionality is working for the most current sofware constellation as follows:

    1) LibreOffice with: a) the latest Oracle JDK version 1.8.0_102 installed and selected in LibreOffices>Preferences>LibreOffice>Advanced>JavaOptions, and b) Zotero's LibreOffice Plugin 3.5.12 installed;

    2) Latest Firefox 48.0.1 with Zotero's LibreOffice Plugin 3.5.12 installed.

    Thus, for this software constellation, all versions are the most up-to-date and you only need the very newest version of Oracles's JDK (with its embedded Java runtime environment) on your Mac OS. (Hopefully, future updates to Oracle's JDK/jre will not cause Zotero to stop functioning! But now we at least know in what direction to look if this should happen.)

    Best wishes to all affected!
  • edited September 22, 2016
    Hi all,

    I think other people have posted this, but here is the set up I got to work:

    Mac: 10.11.5
    Zotero Standalone:
    Java JDK: 1.8.0_77 (91, 101, and 102 did not work)

    It runs a little bit slowly, but it works. Hope this helps other people.
Sign In or Register to comment.