Enabling Sync = Spinning Wheel of Death

I really wanted to try out 1.5b because of the sync function, but after numerous tests I have determined that this is precisely what is causing my problems. At first I thought it might be my large database of over 4,000 citations, but that isn't it. Zotero can handle that just fine. What kills Firefox and makes it completely unresponsive is enabling sync. It doesn't matter how long I wait - even if the spinning wheel of death goes away and I use FF for a bit longer, it comes back.

I tested this on FF 3 and 3.1, with my existing install and in a "clean" profile, and with Sync on and Sync off. It seems clear that allowing sync simply kills FF, and makes it unusable.

I don't know if my geographic location matters, but I am in Taiwan, and sometimes the connection to US based servers is slower here, even though I have a super-fast fiber-to-the-home connection.

I am using an Intel MacBook running the latest version of OS X.
  • I think I may be having a similar problem. I'm running FF 3.0.7 on Ubuntu 8.10, and my library is just under 2700 items. I can sort-of use Zotero (e.g. opening Zotero, scraping items), but very often when I try to perform a non-trivial action (e.g. click on a stored PDF), my CPU usage shoots to 100% and Zotero hangs for a long time (say a minute or two). Sometimes my whole system hangs as a result. I'm not sure I've yet succeeded in syncing for the first time; in the upper right corner of my Zotero window I see a little rotating arrow icon, and when I mouse over it I see in black "Sync with Zotero server" and in gray "Last sync: not yet synced". However, I can't actually get anywhere clicking on the icon, with the left or the right mouse button. I've also tried turning off automatic syncing, with the result that instead of "last sync" I get a message that says the previous connection with the server led to an error ("Last error: invalid response from server"). Clicking on that area again leads to a long period of 100% CPU usage and an unresponsive Firefox/Zotero window. (Oddly enough, network activity stays quiet while CPU is pegged at 100% [and memory is stable at 1.3G total used], so it doesn't seem ?? that network clogging is the problem?)

    I don't have great connectivity at home or in the airport (as at the moment),
    but I'm in the US and it doesn't seem to make that much difference whether
    I'm home or at work ...

    Sorry to be so vague about this; I would welcome any clues about further
    diagnostics or troubleshooting.

    Ben Bolker
  • With the latest upgrade (1.5b2) I no longer get the spinning wheel of death. Actually, I do, but it goes away fairly quickly and starts syncing without consuming too much in the way of resources. Now the only question is how long the sync will take to finish. Its been syncing for hours with nothing much to show for it... but I'm trying to be patient.
  • Now the only question is how long the sync will take to finish. Its been syncing for hours with nothing much to show for it... but I'm trying to be patient.
    Metadata sync can't take longer than a few minutes—there's a server timeout. (You should generally get an error when that happens, though.) I'd restart Firefox and try again.

    WebDAV sync can take longer, but you'll see a progress bar that provides some progress information on hover.
  • I did a browser restart after 24 hours of Zotero trying to sync with Zotero.org (not WebDAV). That didn't work, so I tried a reset-replace data on server. That seemed to result in a shorter amount of time before getting an error message, which simply said "not yet synced." So now I'm trying again.... I have a little over 4,000 references and I'd love to get sync working.

    Update: still spinning. There are relevant errors listed in the "report errors" window, but the spinning arrow has an error message in the pop-up which says that one of my tags was too long. Is this what's causing the problem?

    It would be nice if there was better error reporting for the sync component. I couldn't find any way to access these errors other than the pop-up which appears when the mouse is hovering over the spinning arrow, and that only lists the most recent error.
  • I've given up on sync. I hope the next update solves the problem...
  • I also have experienced problems with "Snyc" recently. Snyc has worked fine for me for several weeks but suddenly I receive the error message:

    The green spinning arrow runs for some minutes and ends with a "!" saying: "Last Error: Tag '....' too long". I did delete the entrance and started a resync, but still: a sync error.
  • I'm having the exact same problem as mkerres and also deleted the entry and tried to resync. I'm getting the same error saying the tag is too long...and it's referencing a tag that has been deleted. I even went as far as deleting the file with the associated tag from my library and resyncing. I am still getting the sync error "tag too long" and the referenced tag is still the same, even though the tag and file have been deleted completely. Heeelllpppp...
  • I'm getting "Abstract field ... too long" error (Reference number 2137647937). Sync just can't handle the sizes that the rest of Zotero can.
  • Sync just can't handle the sizes that the rest of Zotero can.
    It's not really an issue of not being able to handle it so much as one of design.

    The client currently places very few restrictions on data coming in, the assumption being that it's better to allow data to be easily input and corrected than to simply reject it. The underlying database engine that the Zotero client uses is also unusually flexible, which makes this design possible. Unfortunately, some sites produce bad data, and some of Zotero's site translators don't properly handle certain pages, and this can lead to incorrect data in Zotero that needs to be fixed.

    The server uses a more traditional database engine that requires, among other things, length limits to be placed on fields for performance reasons. And since server data may (based on usage and privacy preferences) also be displayed on web pages, shared with others, aggregated, etc., it's more important for the data to be correct.

    If you hit a "too long" error when syncing, it's generally because there's a problem with the referenced data: the tag is actually many tags concatenated together, data was put into the wrong field, etc.

    In your case, the length limit on abstracts is 65,536 characters, so it likely means that full-text content was incorrectly put into the Abstract field. (If it is legitimate, certainly do let us know.) Abstracts that long can also cause a large slow-down in the Zotero interface. You should be able to search for the text referenced in the error message and shorten it. Also let us know where that item came from so that we can fix the translator if necessary.

    For people who are still getting tag-related messages after deleting tags referenced in sync errors, I previously posted a workaround, which still may be necessary in Beta 2 in some situations. (The first step is to just try closing and reopening the Zotero pane.) We'll try to fix some remaining issues for Beta 3.

    At some point we may also offer a better interface for dealing with multiple sync data limit issues at once.
  • Dan,

    I'm also here because I get the spinning wheel of .... well, not death (Firefox is working just fine as I type this) but of not really doing anything in the last 12 hours or so (I have about 4700 records). At least I am not getting any more error messages yet.

    I think that if there's a way to overcome the 65,536 character limit in syncs, this might be a good thing. I imported a lot of stuff from Endnote, and have been using Endnote for over ten years, and its earlier iterations had limited note taking capacity. So I did sometimes put a lot of stuff in the "abstract" field.

    That said, I will try to clean out my abstract fields and put the data in a proper field in each record. This will take some time, of course
  • birkland: Have you verified that you're actually experiencing a problem related to abstracts?

    An eternally spinning sync icon shouldn't really ever happen—if there's an error, the sync should stop and you should be able to to see the error if you hover over the sync icon—but, if it does, you may be able to find the actual error in Report Errors. (And you certainly don't need to wait 12 hours. If it's still spinning after 10 minutes or so, check Report Errors, and then restart Firefox, because it's not going to recover.)
  • Dan,

    I've not verified the problem is related to abstracts. And the error report I can generate seems remarkably consistent. I will say that Firefox is hanging more than usual, although I figured out that if I launch and then launch Zotero, and go do something else for a while, when I return about 10 minutes later, FF and Z are working. (I do check back every two minutes-it takes five to 10 min to become functional).

    Here's the error report if that helps.


    [JavaScript Error: "Location is null" {file: "chrome://skype_ff_toolbar_win/content/tb.js" line: 4776}]

    [JavaScript Error: "[Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIAutoCompleteController.getImageAt]" nsresult: "0x80004005 (NS_ERROR_FAILURE)" location: "JS frame :: chrome://global/content/bindings/autocomplete.xml :: _appendCurrentResult :: line 1030" data: no]" {file: "chrome://global/content/bindings/autocomplete.xml" line: 1030}]

    [JavaScript Error: "[Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIAutoCompleteController.getImageAt]" nsresult: "0x80004005 (NS_ERROR_FAILURE)" location: "JS frame :: chrome://global/content/bindings/autocomplete.xml :: _appendCurrentResult :: line 1030" data: no]" {file: "chrome://global/content/bindings/autocomplete.xml" line: 1030}]

    [JavaScript Error: "no element found" {file: "http://mail.google.com/mail/lssc/?auth=DQAAAJwAAACOmw3pot6OvykNvq8WcfUiTugMin9TnDLQcVwiNcAikCE2H1MyKSbGNLXDimggcx6FDQjDDma_fW-FRRRGch2KzXGmMNNInAGxJaxBey2gGW3qZJ3PCxRW1NB4iVHkSWZnoytGOnRoKIjOh4y03xZ-6OO-QfToLjvYg_eZTudUge4PrY0T1YoLohb4Ns01BTBa3i4-Vq15MRZB_cWcqc8d" line: 1}]

    [JavaScript Error: "no element found" {file: "http://mail.google.com/mail/lssc/?auth=DQAAAJwAAACOmw3pot6OvykNvq8WcfUiTugMin9TnDLQcVwiNcAikCE2H1MyKSbGNLXDimggcx6FDQjDDma_fW-FRRRGch2KzXGmMNNInAGxJaxBey2gGW3qZJ3PCxRW1NB4iVHkSWZnoytGOnRoKIjOh4y03xZ-6OO-QfToLjvYg_eZTudUge4PrY0T1YoLohb4Ns01BTBa3i4-Vq15MRZB_cWcqc8d" line: 1}]

    [JavaScript Error: "no element found" {file: "http://mail.google.com/mail/lssc/?auth=DQAAAJwAAACOmw3pot6OvykNvq8WcfUiTugMin9TnDLQcVwiNcAikCE2H1MyKSbGNLXDimggcx6FDQjDDma_fW-FRRRGch2KzXGmMNNInAGxJaxBey2gGW3qZJ3PCxRW1NB4iVHkSWZnoytGOnRoKIjOh4y03xZ-6OO-QfToLjvYg_eZTudUge4PrY0T1YoLohb4Ns01BTBa3i4-Vq15MRZB_cWcqc8d" line: 1}]
  • This is my first time using Zotero, and I must say that I am not having a very good experience. I have just imported about 600 references and I am now trying to sync them and it is telling me that the tags are too long! Is there a way for it to automatically split the tags for ALL of the references without me having to click it for every single one???? These references all came from my universities library database.

    Any help would be greatly appreciated. I am trying to start writing my dissertation using Zotero instead of Endnote.
  • please start a new thread - this one is entirely unrelated & almost three years old.
    If you let us know where exactly you got the references from we may be able to fix this on the import side.
This discussion has been closed.