Zotero and Word 2016

Can you tell me why it is when I download and install Zotero, it does not appear to insert itself into my Word document? Where is it? Or is there something that I still have to do like install 2013 Word.
  • If you are using the Firefox add-in you must also download a plugin for Word. If you are using Zotero standalone, the connection with Word is built-in.

    You will need to provide more information. See:

    Without additional information such as your Zotero type and version number, the experts here (I'm not one of them) cannot be of much help. What operating system?

    In the meantime, help for word processor plugins is here:
  • I am sorry but I do know about the Word plugins. What I am asking is whether the current plugin will work for Word 2016. If not should I download Word 2013 that I know the current plugin works?
  • the current add-on works for Word 2016 (both on Windows and Mac), yes, but to say more we'd indeed want the info that DWL asks for.
  • I have been fiddling with this program for awhile now wondering why zotero does not work on my Word 2016 program. I cannot find it anywhere since the addons for 2016 are included under the Insert tab in Word.

    I have a Windows 10 system. Is there any other info you need to know?
  • Zotero should have its own tab in Word. Are you using the Standalone version of Zotero or the Firefox add-on? Either way, which version number (under about Zotero in the gears menu).
  • Zotero version And I do not have a Zotero tab on Word 2016. It is not like the Word 2013 where Zotero is added and also on my Word 2010. This time when I downloaded it for my Word 2016 on the Samsung laptop. It did not install. I am using Zotero-Firefox, not the standalone.
  • and just to be sure -- you have the 3.5.4 version of the Zotero Word add-on installed in Firefox, yes? And you have tried re-installing it from the Cite tab of Zotero?

    If so, check if Zotero.dotm is listed and activated under the templates in the Developer tab of Word.

    If it's not, follow https://www.zotero.org/support/word_processor_plugin_troubleshooting#toolbar_does_not_appear_in_word_for_windows_or_is_incompatible (even if you're using an English version of Word) and go through manual installation, making sure to install in Word's startup folder.
  • No Adam the version you quoted is not what I show for Zotero-Firefox which is For Word I installed whatever the version is that you have on this site currently. There is no Word site tab for Zotero currently on the 2016 software. Did I explain that clearly enough (and I am not trying to be smart).

    I will try your suggestion above and let you know if it works.
  • as DWL explained above, you should have two things installed in Firefox: Zotero, with the version you have, and the Zotero for Word add-on. The latter should have version 3.5.4
  • You are correct on the versions. Now getting back to the "extensions file" located found under the link that you provided found on my computer. The contents from that file reads as follows:


    Extension0=C:\Program Files (x86)\Mozilla Firefox\browser\extensions\{972ce4c6-7e08-4474-a285-3208198ce6fd}


    I have a "Key 3" file on my computer which appears to mean that Zotero is not compatible with Word 2016. Do you get the same reading? If so, if that one command were removed along with the actual file, will I be able to install the Word Plugin?
  • I'm a little confused by those multiprocess incompatible extensions. Where are you getting that file? Are you running any unusual Firefox? A beta or aurora version, say, or somehow have E10s enabled otherwise?
    I have a "Key 3" file on my computer which appears to mean that Zotero is not compatible with Word 2016.
    sorry, I have no idea what you mean by that.
  • The file "Key 3" is from the Firefox profile folder in the "extensions" file in Windows 10. You saw the version of Firefox I am running which says that my profile on Samsung recognizes Zotero-Firefox extension in the browser. From the browser I have my library, which does me absolutely no good if I cannot get that document into a Word document. Likewise, after installing the Word extension, Word is not picking up the Zotero connection because (it appears) Zotero is not one of the apps recognized by the Microsoft apps store to use in Windows 10. Hence, as shown in the content of the "extensions" file.

    Or if not the Microsoft App store; then using "JavaScript API for Word."

    May I suggest that you put your hands on a Windows 10 computer and see what your Word program looks like on it.
  • really, I promise Zotero works with Word -- both 2013 and 2016 -- on Windows 10. We have dozens of reports from people doing just that (and we'd have hundreds if it didn't work). I don't have Windows 10 here, but the changes between that and 7/8 aren't that big, so this shouldn't be hard.

    The quickest way for you to get this to work is to try to follow the linked instructions and say where you struggle rather than trying to diagnose things that are unrelated.

    Specifically, you should be able to find the zotero.dotm file in

    and then place it in the Word startup folder. Restart Word and the Zotero toolbar will almost certainly show up. If it doesn't, you may need to enable it under templates in Word.

    Incidentally, I'm not sure how I saw your version of Firefox? You don't mention it in this thread nor your other recent thread. E.g. the new 64-bit version of Firefox likely won't let Zotero communicate with Word, even if Zotero itself works with it (see https://forums.zotero.org/discussion/55898/word-plugin-has-trouble-with-firefox-64bit/#Item_0 ).
  • (I can definitely confirm that I've been running Zotero with Word 2013 and Word 2016 on Windows 10 with no issues.)
  • I have not installed the new version of Firefox 64-bit. If you say it works, then I will try your suggestion and then your link.
  • bwiernik,

    How did you get Zotero to work with Word since Zotero does not display on the tabs when initially installed?
  • it does appear in Word automatically in most cases. If it doesn't, you have to run through the specific troubleshooting steps we have about that and then it will appear.
    There's really no mystery about this and I'm a bit puzzled why, instead of running through the steps specifically designed to address this issue, you keep wanting to guess?
  • adamsmith,

    When I use the path instructions you gave I do not find that file on my computer.
  • meaning you don't have anything under that file path? Remember, I can't see what's going on on your screen and I wouldn't give you those instructions if I didn't think they worked. If they don't, you'll have to be more precise as to where they fail: you don't find that folder? You don't find the Zotero.dotm file inside of it?
  • OK. Under my profile default, I do have an "extensions" file. When I double click on it. The following is located within it:

    a folder named: zoterowinwordintegration@zotero.org
    3 files named: zoompage@dw-dev.xpi

    The folder I recognize as being part of the one that you wanted me to install. The files I do not recognize at all.

    Inside of the default profile is a Zotero file folder, but not a Zotero.dotm file.
  • ok. Open the zoterowinwordintegration@zotero.org folder. In it should be a folder "install". In it should be Zotero.dotm (though Windows may not show you the file extension)
  • In that folder I have 2 Microsoft Word filetypes named Zotero. One if for the Word 97-2003 template and the other is for Word Macro-Enabled Template.
  • cool, the second one is the one you want, that's Zotero.dotm
    Copy that to your Word startup folder. The link above has instructions for how to find that or you can google.
  • Thank you adamsmith, I have Zotero in 2016 Word. What a trip!
  • edited June 20, 2017
    Hi Adam (or anyone else?)

    I have a somewhat related problem. I recently got a new PC (Win 10, x64), and all programs were freshly installed. I have MS Word 2016 (32 bit), Firefox 53.0.3 (32 bit) with Zotero Addon and Zotero Word for Windows Integration 3.5.6.

    I didn't see the Zotero tab after installing the integration plugin, so I followed the troubleshooting instructions - re-install plugin, copy Zotero.dotm from Firefox Profile to Word Startup folder. This did not seem to do anything. I then noticed that there was a 'blank' tab in word, and upon clicking on this tab, I got the Zotero ribbon menu (the tab still appears unnamed or blank in the ribbon).

    I now have the buttons to "Add/Edit Citation" etc. But nothing works. Clicking on the buttons does not do anything. No error message or windows alert sound. I do have Firefox open in the background.

    Any help?
  • @nitesh Begin by updating Zotero to and reinstalling the plugin from Preferences -> Cite -> Word Processor Integration
  • edited June 21, 2017
    @adomasven Thanks for responding.
    I had a typo in my description. I actually have version (I have auto update turned on).
  • Make sure you allow Macros in the Trust Centre
  • The Trust Center setting was "Disable all macros except digitally signed macros".
    I changed it to "Enable all macros..", and this solved the issue. Thanks @adomasven.

    However I am concerned - how safe is this and are there any precautions I should be taking against malicious code? Is the Zotero macro not digitally signed? Why not?
  • Unless you use templates with macros with Office, it should not be an issue, but you could switch to the option that shows a notification for unsigned macros, which will prevent malicious code from running in case you ever encounter it.
Sign In or Register to comment.