ZotFile - Advanced PDF management for Zotero

1313234363761
  • It seems to be doing something right if Windows picks it up as the default PDF viewer. What were the default values?
  • AcroExch.Document
  • Nitro PDF appears to set the default as we expect on Windows XP. You can try re-associating Nitro PDF as the default reader and see if it helps.
  • edited June 1, 2014
    .
  • Nvm i think I figured it out. Patch coming
  • I just merged aurimas's patch. Thanks! It's now part of the github version.
  • The annotation extraction is really improved, thanks so much for all your hard work on Zotfile. 3.3 is great.

    Like some others were posting, I had some issues getting the pdf annotation link to work properly in Win 8.1 - my default reader is the stock Microsoft Reader, which I like and would prefer to keep as my default. Changed the setting in config to use Acrobat, but like someone posted above, though the link works properly now and opens on the right page in Acrobat, I still get a blank Zotero window pop up at the same time. Anyone know how to make that go away? Pretty minor annoyance really, seems like it should be easy to fix too though.
  • What is the problem with the windows 8.1 default pdf viewer? Is the viewer not correctly detected as the default or does it not support the command line arguments to open files on a specific page? If you can figure out whether the win viewer supports some other argument, I can probably make it work. Here is how it looks for Acrobat:

    Acrobat.exe /A "page=3" "C:\PATH_OF_FILE.pdf"

    I agree about the opening of the blank window. It get's pretty annoying but I think it has to be fixed from the Zotero side. The same happens when you use other zotero:// links. I recently opened a thread about it:

    https://forums.zotero.org/discussion/37171/opening-zotero-links-zotero-from-notes-also-opens-an-empty-window/#Item_8
  • There are no command line switches for Windows Store apps, so no way to make the go-to function work with Microsoft Reader.
  • RE: Zotfile Rename - Show File?

    I've noticed that after renaming my files via Zotfile (v3.1) in Zotero Standalone (4.0.20; Win 7), the "Show File" option in Zotero no longer opens the directory containing the linked file. Is this the expected behaviour for linked files? I've found the Show File option very useful when attaching PDFs to emails, and would like to recover this option if possible. Is this problem already known?

    If you'd like any further information, just let me know. Thanks for your help.
  • anthonybrucewilson, I can't reproduce this problem. Can you still open the pdf by double clicking on the attachment in Zotero? If that is the case, your problem seems to be unrelated. What are your settings (linked or imported attachment etc)?
  • Joscha,

    I can open the linked PDFs without any problem. All PDFs are initially imported to Zotero and then renamed as linked files by Zotfile. Renamed PDFs are stored in a single directory "Journal PDFs" with subdirectories according to journal name. All of this is done automatically when renaming files with Zotfile. When I try to open the file location via Zotero, nothing happens. Interestingly, before renaming the files, this function works without any problems. Any suggestions? Does Zotero generate a log file that could help in narrowing down the problem?
  • edited June 15, 2014
    Does Zotero generate a log file that could help in narrowing down the problem?
    https://www.zotero.org/support/debug_output

    edit: although I doubt this has anything to do with Zotfile. You can test manually linking to a file and see if "Show File" works for that. I'd guess it doesn't. In that case, make sure you disable all add-ons, including Zotfile, see if the problem still persists and if it does report it in a new thread, including debug output.
  • Adam/Joscha,

    I've replicated the error while storing the error log (D59861732). I can't see anything obvious from the error log to indicate the cause of the problem. FYI - I attempted to "Show File" for two linked PDFs. The first of these (an older file) opened the directory as expected, while the second (a more recent file) failed to open the directory. What this indicates is that its not a consistent behaviour for all linked files, but that its restricted to files that have been more recently added to the database.

    File 1 (Directory Opened; File Linked in 2013):
    D:\Journal PDFs\Aquaculture International PDFs\Aquaculture International13-175-186.pdf

    File 2 (No Response; File Linked on 5/3/2014):

    D:\Journal PDFs\Acta Zoologica Bulgarica PDFs\Acta Zoologica Bulgarica66-127–131.pdf

    Best,

    Tony
  • please post this to a new thread then so that Zotero devs can take a look. You can copy most of your last post here, but you should explicitly confirm that the Acta Zoologica Bulgarica66-127–131.pdf file opens when you use right-click -->View PDF
  • Will do - Thanks!
  • nb. After some initial troubleshooting by Dan Stillman at Zotero, he's suggested that the problem seems to be Zotfile specific, as it is not generated when manually linking a file through Zotero. The original message follows below:

    I'm experiencing an inconsistency in behaviour when using the "Show File" option in Zotero Standalone (v4.0.20; Win 7) after renaming files using Zotfile (v3.1). While I am able to view all PDFs using "View PDF" and/or by double-clicking on the PDF link, the location of newer files fails to open when selecting "Show File". I've generated an error log for (1) a file which generates the expected behavior for "Show File", and (2) a file in which the file location does not open. Unfortunately, the error log is not particularly helpful in identifying the source of the problem. I'd appreciate any suggestions you might have, and would be happy to troubleshoot anything that might help to pinpoint the source of the problem. The file details follow below:

    File 1 (Directory Opened; File Linked in 2013):
    D:\Journal PDFs\Aquaculture International PDFs\Aquaculture International13-175-186.pdf

    File 2 (No Response; File Linked on 5/3/2014):

    D:\Journal PDFs\Acta Zoologica Bulgarica PDFs\Acta Zoologica Bulgarica66-127–131.pdf

    Thanks,

    Tony
  • Thanks Dan. Tony, can you update zotfile to the most recent version on github? You can install it from here (some manual steps are required though): https://github.com/jlegewie/zotfile
    I haven't made any changes specific to your version but just making sure that you still have the problem.
  • Hello,

    I have encountered quite a serious problem that I have no idea how to resolve: how can I move the folder with my pdf's? I have recently installed an SSD for my system (Windows 8.1), but am keeping my data on the hdd, so I moved the Documents library, where I keep all the pdf's linked to my zotero records. Changing the path in Zotfile Options doesn't change anything...
    Please help!
  • Are your attachment linked attachments? Zotfile can help you with that. Just change the setting for "location of file" to the new folder, select a couple of zotero items, right-click, manage attachments, rename attachments. That should move your files to the new folder. Theoretically, you can select all files and batch move all attachments but I highlight recommend to do it step-by-step (maybe slowly increasing the number of attachments) to check that everything is correct.
  • Hello Josha,

    that "An error has occurred. Please restart Zotero." This is what the error looks like:
    NS_ERROR_FILE_NOT_FOUND: Component returned failure code: 0x80520012 (NS_ERROR_FILE_NOT_FOUND) [nsILocalFile.isDirectory]
    (undefined, 355)
    And this is the error code. I don't think it is directly related to changing directories, because suddenly I can't rename attachments at all!
    What should I do?
  • Hello Josha,

    something ate the beginning of my message. It went: when I try to rename any attachment Zotero states that etc.
  • Are you using zotfile to rename? Which version? Can you open the pdf by double clicking on it?
  • Hi Joscha,

    yes, I am using zotfile 3.1 - thanks for looking into this!
  • And yes, I can open the pdf's by double clicking!
  • I still need more information to that I can try reproducing this. What are your settings (e.g. what is the 'location of files'), does it happen when you use 'attach stored copy of files' instead of 'custom location', is it possible that the file is locked? etc. Right now, I have no clue...
  • Hello Josha,

    I have no idea what caused these problems, but yes, with 'attach stored copy of files' everything worked fine. What I did was backup the data directory and uninstall zotero purging all data files. Then, I re-installed the program with zotfile & zutilo, and restored the database from the server. It is only then that I managed to move all the attachments to the new location. Now everything works fine!

    Thanks again,
    Krzysztof
  • I'm looking into using zotero. I would have to import my library from another reference organizer (papers 3), and I would want a new copy of the pdf library, for several reasons. The old pdf library has a hierarchy.

    I would like to be able to batch import, rename, and organize the pdf's in new hierarchy.

    Is there a way with zotfile to select all references imported to zotero and import, rename and organize the associated pdf's? Supposing I get the renaming and organization wrong the first time around, which seems likely, is there a way to batch rename and organize the pdf's according to a new scheme?
  • Zotfile has nothing to do with importing references from another reference manager. So from that perspective, no. Zotfile only does the "rename, and organize" part. If you have linked attachments in zotero, zotfile file can change them to "import attachments" but that has nothing to do with other software.
Sign In or Register to comment.