Cannot grab references from ProQuest and Ebsco on 1.09

I had this problem with the previous version and it was hoped that with the new release it would be solved. Still, using either of those two database services, the icon for Zotero appears on the search bar, click and Zotero tries to download the reference data but then says that there is a translation error. I am using the latest Firefox browser on a MAC (latest OS).
  • I don't get an error for either Ebsco or Proquest on Zt. 1.09, FF 3.05 and ubuntu linux, but it does fail to download .pdfs for associated articles for both databases, although the box is checked in the preferences and it does work with other databases.
  • Stan: Please provide URLs that aren't working for you.
  • I do not even get the icon on ebsco...
    Here for example :
  • Dan thanks for your response. I am not sure that if I cut and paste a URL that you can trouble shoot through it. I access EBSCO and ProQuest via a route that goes like this: My university VPN - Athens Authentication - EBSCO. So if I copy and paste it to you I don't think you can get there because you don't have my University server passwords and Athens authenitcation codes which of course I must not disclose. The icon is still on the browser and when I click it, it does call on Zotero which says it cannot dowload look on the forums for known translation issues.
  • Stan -
    try disabling all other add-ons for FF and then retry. Often these types of errors are due to conflicts with other add-ons. If Zotero works fine on Ebsco/proquest then, try re-abling one after the other to find the culprit.

    Also, for Dan to help you, you could just point to a particular reference that you've tried and that isn't working.

    Finally, you could create a debug output
    and post it here (that now includes, if I'm not mistaken, all your active FF add-ons).
  • This will need to be an answer in two parts as the debug routine is new to me. So let me address Adam's comments:

    1. I disabled the only other add in (pdf download 2.1.0 and that has not made a difference

    2. is a URL offered on the EBSCO site as a permanent URL marker for an article that I tried to capture directly into Zotero: the article is by Pullman and Gross (2004) in Decision Sciences fyi.

    3. I will need to close this down to go through the debug output and see if I can manage it thanks
  • Part two - sorry I fail to understand the first instruction: n Firefox, go to about:config in the address bar - I do not see an about:config in Firefox. I think this is a case of the site's instructions assuming a level of expertise that I don't have. So I cannot send a debug file unless someone provides much more explicit instructions.
  • In the address bar where you would normally type a URL, type "about:config" without the quotation marks and press enter.
  • THanks for that. I copied out the instruction on the URL you sent me and then managed to get into the Firefox config and made sure the output was on true. I closed down, openned up the terminal application and then I clicked on new command (hope that was right because I saw no other way to enter the run line) and then typed the command line as per the instructions but nothing has returned - not even the erorr that command has not been found.
  • edited January 4, 2009
    Are you sure you quit Firefox completely (and that you did not just close all open browser windows) before running the command?
  • Yes made that mistake first time around but did quit firefox completely. Tried it on two different computers.Then went back into firefox to make sure the change to "true" remained on the config.
  • sorry, would love to help further, but don´t have a mac here for troubleshooting.
    Only thing I can say is that I just pulled the gross and pullman piece into Zotero, this time on Windows XP - so this is either a Mac problem or one specific to your computer/settings - but at least someone mac-savy should be able to guide you through the debug steps?

    P.S. ebsco still doesn´t download the pdf, though.
  • edited January 5, 2009
    Stan: Don't worry about debug output—we don't need it in your case. The problem you're seeing is due to a slight difference in the HTML you're getting on the Export Manager page from what the translator expects. We can fix that, but there's no guarantee that that alone will fix the problem for you, since the Juniper proxy does some crazy things to URLs.

    The new proxy support in 1.5 will likely be able to handle such URL-rewriting proxies, however.

    In the meantime, using, e.g., "Direct Export to EndNote, ProCite, or Reference Manager" on the EBSCO export page should cause the selected references to be imported directly into Zotero, assuming the RIS/Refer pref is enabled in the Zotero preferences and the site is serving the files correctly.
  • Thanks for that - not sure why I had a second thread. Most likely a mistake.

    I found a few references to Juniper proxy and if I understand it, this is something you build into Zotero to support downloading information when the user is accessing the data via sites you call proxies. So the long chain from my University VPN, through Athens through the provider of the database creates issues. I think you are working on the Juniper proxy and that might help but it might not.

    The 1.5 release seems to offer the hope of addressing translation issues and citation in Word 2008. For someone not used to Beta environments such as myself, is it best to wait for a few months?
  • No, Juniper is the VPN you're using, which adds "DanaInfo" and the like to URLs, making them generally incompatible with Zotero's translator architecture.

    I just pushed a new version of the EBSCOhost translator. Go to the General pane of the Zotero prefs, click Update Now, and then try to save from EBSCO. You'll probably still get an error, but, if you do, post the exact URL you tried to save and we can see if it at least fixed the initial problem you were seeing.
  • Result - I was able to download two seperate references from EBSCO directly from the top browser bar just as promised. Well done! That seems to sort out the problem. I can start to appreciate the magnitude of the task you have making it all work seamlessly.

    I tried the same on the ProQuest ABI Inform service we have but that one does not even show the Zotero little square in the top browser bar on which to click. So I take it ProQuest has not yet joined in with Zotero or you have yet to build ProQuest ABI Inform translators. Or would you like me to forward a URL.

    Thanks for sticking with it
  • URL, please.
  • I'm having similar problems but have still have problems in another database. I'm on a PC. Have downloaded new versions of everything, have disabled all plug-ins. I was in Ebsco and did get it to work if I exported the citation but could never get the address bar icon to work. I've also had problems in the Gale databases. I did get it to export in the citation manager, but Zotero is not pulling all the information from the record (no title--I've tried twice).
    Web address:

  • Mary: You're using a different proxy server. Please start a new thread with any problems you are having saving, and include any relevant URLs.
  • For Dan: is this what you need,
  • edited January 7, 2009
    That article saves fine for me from ProQuest, but it won't work for you in 1.0 due to the URL-rewriting your proxy does. You'll need to wait for 1.5, which has advanced proxy support.

    In the meantime, on ProQuest you can mark some items, go to My Research, and then use the "Export directly to ProCite, EndNote or Reference Manager" option, but the metadata won't be of as good quality (may display as a Web Page item, be missing some fields, etc.).
  • Thanks; what I do as a work around is to export directly to Refworks and from Refworks export as a bibliographic file and import that to Zotero. A bit tedious so I will use EBSCO first. I guess the one question you are reluctant to offer guidance - when might 1.5 be ready for the timid!
  • If I may reactivate this one; with the move to 1.5 I have not been able to reactivate the link to EBSCO that is I cannot aumatically export from EBSCO to Zotero. In fact, I have lost almost all abilitiy to see the download icon in the browser bar now.
  • With Version 2.0 the export from EBSCO through the browser seems to be working now.
Sign In or Register to comment.