sync error message 201567869

I get varied error messages when attempting to sync my zotero library (created in zotero standalone with chrome plugin) about 33,000 references imported from endnote library via RIS. Have tried various proxy servers available at my workplace. I suspect it is a proxy problem but don't know what. Have not yet checked my workplace to see if zotero server is barred. Will try tonight at home (linux mint installation) with no proxy hopefully that will work but i still need to sync at work. Any clues would be appreciated. thanks, bye, Robin
  • (by the way, the verbose error report from that number is):
    [JavaScript Error: "bad script XDR magic number"]
    [JavaScript Error: "bad script XDR magic number"]
    [JavaScript Error: "Error: Error connecting to server. Check your Internet connection." {file: "chrome://zotero/content/xpcom/sync.js" line: 652}]

    version =>, platform => Win32, oscpu => Windows NT 6.1, locale => en-US, appName => Zotero, appVersion =>, extensions => Zotero LibreOffice Integration (3.5.9.SA., extension), Zotero Word for Windows Integration (3.1.18.SA., extension), Google Update (, plugin), Shockwave Flash (, plugin), Java(TM) Platform SE 8 U45 (, plugin), Java Deployment Toolkit 8.0.450.15 (, plugin), Shockwave for Director (, plugin), iTunes Application Detector (, plugin), VLC Web Plugin (, plugin), Google Earth Plugin (, plugin), Silverlight Plug-In (5.1.20913.0, plugin), Adobe Acrobat (, plugin), Intel® Identity Protection Technology (, plugin), Intel® Identity Protection Technology (, plugin), QuickTime Plug-in 7.7.4 (, plugin), Citrix URL-Redirection Helper Plugin (, plugin), Citrix ICA Client (, plugin), Microsoft Office 2010 (14.0.4761.1000, plugin), Microsoft Office 2010 (14.0.4730.1010, plugin)
  • If your work computer is set to detect proxy servers automatically, see this post for an explanation and workaround.
  • Thanks Dan but still no go. I can send you wireshark packet capture for your two IP addresses if that would help?
  • No go meaning your system isn't set to using use automatic proxy detection, or that setting the proxy manually in about:config didn't help?
  • edited May 21, 2015
    quick response, impressed! No, in about:config changed to 4 and didn't help. System proxy is off thanks to my IT support. used alternative IP address used for direct access to the internet.

    this is the latest error report when attempting to sync:

    [error report removed — D.S.]
  • edited May 21, 2015
    Well 4 just turns on proxy autodetection within Zotero itself. If you're not using proxy autodetection, you should leave that at 5 to use the system proxy settings.

    But I'm still not clear on how exactly you're connecting to the network. Exactly which settings are enabled in your system proxy settings?

    (The report text isn't necessary, by the way — those messages aren't relevant to anything.)
  • edited May 21, 2015
    My IT friend temporarily gave me an IP address with direct internet connection (doesn't use a proxy) but system settings back the way they were now since he has gone home: proxy server now back in place from [...] port 3128 and in place for all protocols http: secure ftp:

    If you need other information tell me what screen to find it on

  • When you had a direct connection, had you tried restarting Zotero? I suspect most networking changes would require a Zotero restart.

    In any case, with the proxy back on and the Zotero proxy setting at 5, restart Zotero with debug output enabled and look for a line near the beginning about a proxy, direct connection, and/or PAC file and let me know what it says. (If you have Cygwin, start from that instead of cmd.exe. It's much faster.)

    You can also play with the proxy settings in Zotero directly, restarting after each change, though if set to 5 it should automatically pick up all settings other than automatic proxy detection.

    Do you normally have to enter a username and password to use the proxy? Do you have Firefox installed on that system? (Zotero uses the same networking stack, so it's worth trying with Firefox if you can.)
  • I did restart zotero each time network changes were tried. with proxy back on and setting at 5 restarted with debug protocol. No lines say anything like proxy or PAC. the only error messages relate to bad script XDR magic number and are as follows. (Other messages in the debug screen appended further below but I don't think they are relevant)

    I'm using zotero standalone but do have firefox installed. I have to leave now so can't try that just yet but will explore options with firefox tomorrow (I think however firefox and chrome both grab system network settings from IE?)

    thanks again (also for judicious edit of my other post)

    Timestamp: 21/05/2015 5:44:04 PM
    Error: bad script XDR magic number
    Timestamp: 21/05/2015 5:44:04 PM
    Error: bad script XDR magic number

    Could not read chrome manifest 'file:///C:/Program%20Files/Zotero%20Standalone/xulrunner/chrome.manifest'.
    Timestamp: 21/05/2015 5:44:04 PM
    Warning: mutating the [[Prototype]] of an object will cause your code to run very slowly; instead create the object with the correct initial [[Prototype]] value using Object.create
    Source File: resource://gre/modules/Preferences.jsm
    Line: 381
    While creating services from category 'profile-after-change', could not create service for entry 'MobileConnection Service', contract ID ';1'
  • Sorry, those instructions were out of date for Standalone on Windows. See again. If you're using cmd.exe and the initial text goes off the top, you may need to adjust the scrollback buffer by going to the text console window's top-left icon -> Defaults -> Layout -> Screen Buffer Size and setting Height to 9999.
    I think however firefox and chrome both grab system network settings from IE?
    Firefox and Zotero use the same networking code, with the same options available via about:config. (In Firefox they're also available via the UI.) When set to 5, they should both get proxy settings from the system, with the exception of the proxy autodetection setting.

    You can check Firefox's proxy settings in Advanced -> Network preferences. Those correspond with the network.proxy. settings in about:config. With Standalone set to the same, it really should work.
  • Hi Dan
    I was barking up completely the wrong tree. There is no problem with proxy or network settings. There is a problem within my library of 33,000+ items. I deleted the library file zotero.sqlite and inserted a couple of test items. Now my libary of 2 items syncs no problems. However I really wish to re-import my full Endnote library preferably from .RIS exported by Endnote. Somewhere within that there is an item or items that cause the sync to fail (or perhaps it is a file size issue?). Do you have any hints or tools to find problem items within a library? I set Zotero not to import attachments (although I might look into that eventually). Sorry i didn't think to test first with a small library.
  • Well, there's a pretty good chance it's still a network issue, just one caused by upload size. It's definitely not a specific item.

    Your best bet is to import in batches of a few thousand items, syncing between each one.
  • Many thanks. I'll do that.
Sign In or Register to comment.