New Australian Legal citation style

I've just added a modified version of the Bluebook style to suit Australian legal formatting conventions to the repository (install link:

It's similar to, but not identical to the Australian Guide to Legal Citation 2 style, which is just too finicky for me. If enough people are interested, it could be developed towards this goal.

I'll be using it for my PhD thesis, and have tested it on my library - it seems consistent so far. Please feel free to try it out, and if you have any problems, or want to give any feedback, either do so here, or send me an email to anton dot hughes at utas dot edu dot au.

Note I did find an issue with volume number handling (see but for an interim fix just delete and re-type the volume number.
  • edited November 23, 2008
    Your style is invalid CSL: the first macro ('name-macro') is missing an if-conditional. You can find some info on validating CSL styles at
  • Fixed. Thanks for the tip.

    I found the stuff on validating CSL a bit too brief for someone with no understanding of RelaxNG. I'm on OSX, and I like TextMate, so didn't really want another editor to buy/install. I installed an XML plugin for textmate, but it doesn't support the compact syntax unfortunately. So after mucking around with rnc2rng converters with no luck, I eventually settled on jing as a command line validator, which you just use like this:

    java -jar jing.jar -c csl.rnc australian-legal.csl
  • For what it's worth, Trang generally works for converting from .rnc to .rng:

    java -jar trang.jar -I rnc -O rng csl.rnc csl.rng
  • edited November 23, 2008
    I found the stuff on validating CSL a bit too brief for someone with no understanding of RelaxNG. I'm on OSX, and I like TextMate, so didn't really want another editor to buy/install. I installed an XML plugin for textmate, but it doesn't support the compact syntax unfortunately.
    Aqua Emacs is Mac native, and includes the excellent NXML mode (which supports the compact syntax) out-of-box. I realize you're happy with TextMate, but you might find emacs/nxml the better solution for XML in general, and CSL in particular.

    It's really painful to treat validation as a separate step, compared to what you get with realtime validation.
  • @Dan: I did try converting the RNC to RNG with Trang, but it didn't seem to work when I tried to use it with the validator. Will try again with the command as you've set it out.

    @bdarcus: I like the sound of real time validation. Will give Aqua Emacs a go.
  • I should add that there's one annoyance with real-time validation and how the zotero repository handles CSL files: your document will never be 100% valid since the repo expects the updated element to be empty. I'd still like to see this changed, as it's both annoying, and unnecessary.
  • Bruce: That's not the case. A post-commit script just updates the timestamp when generating the repo version regardless of whether or not there's a timestamp in the committed file, which is why I've suggested that leaving the timestamp empty when committing is fine. But leaving in any arbitrary timestamp so as to pass validation is also fine—there's just no reason to bother updating it manually.
  • Ah, great. But has that always been the case? I could have sworn I previously ran into problems when committing files with valid (non-empty) timestamps.
  • I could have sworn I previously ran into problems when committing files with valid (non-empty) timestamps.
    It's entirely possible. That part of the post-commit code has been buggy in the past.
  • Hi all,

    I am having trouble with the Australian legal citation style. In particular when using the citation type 'statute' Zotero does not have a jurisdiction field and so I have been trying to substitute 'last name' field. Also the 'name of the act' field does not display in the document when used and last name is then incorrectly italicised. Can someone offer me either better substitutions for the fields, remedy the style or tell me where I am going wrong.

  • Hi all, can you also help me on 'section' it does not display as a pinpoint reference with ALC?

    I have tried both adding the section to the record or adding as a pinpoint when inserting a citation. I can add by hand after the inserted citation but this does not work with the period at the end of the auto citation when I refresh.

    I hope this all makes sense. I'm not a coder. I would like to help improve ALC. I can test and do requirements gathering.


  • Hi - for the problems that you have - could you tell me what you currently get and what you should be getting? Including in which field you have the information that is included?
  • Sure, BTW, thanks Adam.

    1. high priority (for me) resource translator does not work
    2. 'statute' record type does not contain a 'jurisdiction' field type. After experimentation I have discovered that field type 'extra' does the job
    3. Footnote for AGLC2 or zotero ALC 'statute' citation style should be:
    3.1 <i>name of act</i> <i>date(year only)</i> <>jurisdiction(in brackets) or extra(fudge)</> <>pinpoint</><>.</> note: option to leave off URL and accessed date, I don't want it but others might?
    3.2 example: <i>Crimes Act 1900</i> (NSW) ss 19A, 442. Note: pinpoint can be 'part' 'section' 'div' 'page' etc I would prefer the field was just "pinpoint" and not include the high degree of granularity that exists. That way within the field I can include a wide range of pinpoint options and multiple pinpoints without too much complexity.
    4. ALC does not include a bibliography.
    4.1 Bibliography should include all records in a folder
    4.2 It should sort records by type and alphabetically:
    4.2.1 articles/books/reports
    4.2.2 case law
    4.2.3 legislation
    4.2.4 treaties
    4.2.5 other sources (interviews/letters/memos/emails etc)

    The discovery of the 'extra' field has solved my jurisdiction problems. The pinpoint problems still exist though I am including pinpoints in the footnote after the zotero field entry. Before publishing I will run a find/replace on ".s" and replace with s and everything will be sweet for me. Finally, I personally would prefer that the statute record type was called 'legislation' but that's just me and I can certainly live with it.

    Thanks again Adam.
  • OK
    1 and 2 have nothing to do with the style - I suggest you bring them up in a different thread (each individually)

    3. not sure I understand this one, partly because I don't have time to go through the moves to see what the Zotero ALC does currently. What you call "pinpoint" (which is not a csl/zotero variable, is it?)- any reason that couldn't be just section? Section is a free text field - you could put anything you want in there.

    4. Zotero/csl cannot as of now sort bibliographies by type/ create subject bibliographies and the like. I'm not sure what the status of this is for csl 1.0 (i.e. the near future), but it has certainly be discussed a lot.

    As for "legislation" - there are item types for "bill" and "statute" - I'm not a lawyer, I don't really even understand the difference - but both appear to be legislation, so they are more finegrained.
  • I'm responsible for the style as it stands at the moment. There are (sometimes good) reasons for the limitations you have picked up on - I'll try and address them as best I can:

    * Re jurisdiction field: not all Zotero fields are available to CSL (just not implemented yet) - extra is one of those few fields that is, so that's why I've used it for jurisdiction.

    * Re statute: can you give an example of how it currently (improperly) outputs pinpoint references? Oh and the jury is out as to whether the year should be italicised or not. Some say yes, some say no. I don't care, but like the look of it italicised, but if there's a more people using the style who want it changed, I'm happy to do it.

    * Re bibliographies: you're right, I haven't even got that far yet. Glad I didn't since CSL/Zotero don't handle it yet. It might be possible to get around that by generating a properly formatted bibliography document for a particular collection as an RTF or the like.

    Hope that helps - thanks for the feedback.
  • I've made a few hack changes to some minor issues in line with the AGLCv2. I am testing this with my thesis, and will probably make more as I go along. Not knowing the etiquette, though, I have not checked in to SVN. If you want to incorporate any of these changes, you can find them at

    1. removed final comma in journal article names
    2. removed ‘at’ in pinpoint references and replaced with commas
    3. for pinpoints in legislation and books, just use a space instead of a comma
    4. don’t use ‘above’ for legislation, only ‘ibid’ or a new ref
  • Not knowing the etiquette, though, I have not checked in to SVN.
    Feel free to submit your changes to the SVN. It's appreciated if you first validate your modified style(s), though (see ). Thanks!
  • edited January 19, 2010
    Ok, I've checked my modifications in. Main additional changes so far:

    * added speeches, oral conference papers etc (events)
    * added report (AGLC 6.16)
    * added interview (AGLC 6.11)
    * added edited books (books with no author display as "editor (ed), /title/ (date)" (AGLC 5.1.2)
    * style uses the 'authority' ('court') field to distinguish between US and Australian cases; legal_case with a 'court' field has the 'court' listed.
    * several sets of formatting - italics and quotes fixed, according to AGLC
    * new rule for newspapers (AGLC 6.2)
    * updated rule for webpages (AGLC 6.14)
    * new rule for theses (AGLC 6.7)

    I have a problem validating with the change to handling of cases:

    australian-legal.csl:227:3: error: attribute ^variable with invalid value "authority"
    australian-legal.csl:242:7: error: attribute ^variable with invalid value "authority"
    error: some documents are invalid
    However, the style still works, so I'm not sure whether this is a real problem. I check the value of 'authority'. If it exists, I write the reference as a US style ref (with court) (AGLC Rule 11.1); if not, then I use the australian style (Rule 2).
  • the style you uploaded validates fine for me. How do you validate? What you did looks perfectly alright.
    Also nice working commenting your work so thoroughly.
  • Thanks; I validate with rnv: "rnv csl.rnc australian-legal.csl". It throws up the errors above, but the script still works.
  • yeah - I just saw that the repository doesn't think it's valid either, nor does
    I validate with nxml on emacs and that says its valid.
    weird. Maybe someone else has an idea?
  • edited January 20, 2010
    It's a bit weird. The "authority" variable was added one day before 0.8 was tagged:

    but it doesn't appear in the released version:

    I think Dan uses a slightly modified copy of the schema ... [edit: apparently not :P ]
  • Nope. We just pull from that URL and validate.
  • I think I've found a small bug with repeated citations of books and journal articles - although it may affect other source types (but cases and legislation are not affected). Basically, if you enter a pinpoint in the 'Page Number' field in the 'Add'Edit Citation' dialogue it seems to muck up proper handling of 'Ibid' and 'above n' in subsequent repeated citations. If you enter a page number for, say, a journal article citation, and then in the very next note re-cite the same article, instead of correctly using 'Ibid', the 'above n___' form of the footnote is generated. Leave out the page number or use the suffix field when adding a citation and it will use 'Ibid' correctly.
    Putting the pinpoint in the 'Suffix' field does work as a work-around, but then it's necessary to include a comma and space manually.
    And, Anton and Nic, thank you both so much for your work on this style - it finally means I have a decent referencing tool to use in OpenOffice on Linux - it's been a long time coming.
  • I think the problem is that there is no option defined for "ibid-with-locator" in the style, I think that might mess things up - I'd like to help, but I really try to stay away from Law styles, which I just don't get and don't want to mess up -
    but maybe nic or anton can take it from there?
  • @jake451: Are you sure that's the wrong form? In Bluebook style, a "supra" backreference is required in the following case:1. Bloggs, "My Article", 123 L.J.R. 456 (1957).
    2. Smith, "My Longer Article", 789 L.J.R. 123 (2000).
    3. Bloggs, supra note 1, at 457.
    4. Bloggs, supra note 1.
    Note 4 of this example references the entire work (which I think is the kind of reference you are describing), and the Bluebook ibid equivalent ("id") can't convey that meaning, since when used solo, it would refer to the same page as the preceding pinpoint ref (i.e. it would refer to page 457 in this example).

    Probably worth checking the style guide to be sure, at least, and post the specific requirements here if a cross-check shows that things are not right with the style.
  • see, that's why I don't touch law styles.
  • fbennet and adamsmith - thanks for your responses.
    @fbennet:The Australian Guide to Legal Citation does not (even slightly, it would seem) follow the Bluebook format. It requires for any source other than legislation the use of Ibid in an immediately following note, with a pinpoint if required, and 'above n X,' with pinpoint if there are intervening footnotes.
    The actual example given in 1.2.1 of the AGLC is as follows:

    18 Matthew Collins, The Law of Defamation and the Internet (2001).
    19 Ibid.
    20 Ibid 62-3.
    78 Michael Walzer, 'Philosophy and Democracy' (1981) 9 Political Theory 379.
    204 Walzer, above n 78, 384.
    205 Ibid 385-6.
    291 Ibid 311, 313-14, 320. He told the Court, 'with an air of superior rectitude', that the Bible teaches that 'foolishness is bound up in the heart of a child and the rod of correction will drive it far from him': at 307.
    292 Ibid 307-8, 309-10.

    While none of these actually pick up the point you're making in the difference between your note 3 and 4, the AGLC doesn't include instructions for such a case. Arguably in such a case it might be appropriate to use 'above n' instead of Ibid,
    The problem is, as it stands, that the style is using 'above n' incorrectly when a pinpoint is used in the page number field. adamsmith's suggestion that the problem stems from a lack of "ibid-with-locator" sounds like it might be the reason this is happening, but I don't know anything about creating or modifying styles, so am not competent to attempt to change it (or even to know if this can be fixed?).
    It may be that this is a feature not a bug, as antonh did indicate in his first post that he had modified the AGLC rules a bit, but the way it's working when I insert citations seems to be more like a bug.
  • @jakes451: The citation style started life as the Bluebook.csl file created by Bruce Darcus. That's why it has picked up the bug you point out (and it is a bug, not a feature). My point in the initial post about

    @nicsuzor: Thanks for all the extra additions - I just haven't had the time to spend on it lately, and am locked into IE at work at the moment, so have to do citations manually.
  • Adam Anton Nic and everybody, else!
    Awesome stuff guys! I have been off for a while and come back to huge progress on AGLC2. I'm really loving it.

    I am having a problem with 'above n __.' For some reason zotero is not writing the reference to the above citation number in.

    Am I doing something basic wrong?

    See example:
    35 David A Hughes, “A Classification of Fusion After Harris v Digital Pulse” (2006) 29(2) University of New South Wales Law Journal 38.
    36 Bailey v Namol Pty Ltd (1994) 53 FCR 102, 112.
    37 Hughes, “A Classification of Fusion After Harris v Digital Pulse,” above n ___.
    38 Harris v Digital Pulse Pty Ltd (2003) 56 NSWLR 298, 457.
    39 Yerkey v Jones (1939) 63 CLR 649, 683.
    40 Kirstie Dunn, “'Yakking Giants': Equality Discourse in the High Court” [2000] Melbourne University Law Review 16.
    41 Kirby, “Equity's Australian Isolationism,” above n ___, 454.
    42 Warburton v Whiteley [1989] NSW Cony R 55 453.

    I am using:
    Word for Mac 2008
    Firefox 3.5.6
    Zotero 2.0.2
    Zotero MacWord Integration 3.0b2

    Hope this helps and keep up the great work!
Sign In or Register to comment.