JSTOR Not Working (January 2015)

Over the last few weeks Zotero Standalone (4.0.23) hasn't been able to grab citation information from JSTOR, even in cases when the article I'm trying to save includes a DOI (for an example, see http://www.jstor.org/stable/info/10.1525/jams.2013.66.1.129). I get a message that the article is being added to my library, but nothing happens. Zotero seems to be working nicely with other providers, so this appears to be an issue specific to JSTOR. I've done some searching on the forums to see if anyone else is reporting this, but I've mostly found older discussions.

I'm using Safari 7.1.2 and Zotero Connector 4.0.21.
  • Here it is: D77104012
  • My wife was just having this problem also, using the most recent version of Standalone and Safari on Mac (OS 10.9). I found that rolling the JSTOR translator back to the commit from 1 June 2014 solved the problem. I'm not sure if it needs to be rolled back *that* far - I didn't test any of the more recent commits, but randomly selected an older one - but it did the trick. Obviously there is something from a recent change causing the issue, but I'm not savvy enough with regard to scraping the JSTOR site to look into it in depth.

    The translator in question can be found at https://github.com/zotero/translators/blob/4e4907551c68a06f3c482908c03a8cc65a266a2c/JSTOR.js

    It can be added to the Zotero Library translators folder (I just overwrote the newer version).
  • jws02459: Can you provide a Debug ID from Safari (rather than Standalone)?
  • OK, here it is: D795417608
  • I'm also not able to import from Jstor. When I try to import via the Safari "save to Zotero" button, the "saving to my library" message appears. But nothing new appears in my library (the standalone Mac application). Documents from other sites do appear. Please advise.
  • Until this gets worked out you can get the JSTOR article _citation_ metadata by going to the table of contents for the issue that contains the article. From the ToC, find the "citation tools" then click the export link. This will take you to another screen where you may select the export format. Select RIS. Accept the request to import the record(s) into Zotero. Unless you are signed-in JSTOR will not export the abstract (if the JSTOR record has an abstract). The ISSN is provided without the hyphens and the article language is not included in the metadata.
  • I'm also seeing a failure against JSTOR. I'm not sure if it's the same issue, or something specific to our network.

    With Zotero 4.0 built from source (fa75be), accessing JSTOR via our University proxy, translation fails without issuing an error. The Debug ID is D86936079.

    When JSTOR is accessed without the proxy, translation succeeds.

    I'm not sure what to make of the self-signed certificate error. If the certificate is the problem, should I complain (1) to our Uni computing office, (2) to the resolver service, or (3) to JSTOR themselves? (Sorry to be clueless.)

    If this should go in a separate thread, just say the word.
  • @Dan - can you reproduce this on Safari? I'm unable to reproduce it on either Firefox or Chrome, including with proxy.

    Anything in jws's debug that'd be helpful?
  • Here's jws's output:
    (4)(+0002289): Translate: Parsing code for JSTOR

    (3)(+0000000): Translate: Beginning translation with JSTOR

    (3)(+0000001): Translate: Converting JID 1209605 to JSTOR DOI

    (3)(+0000000): Translate: Converting JID 1209605 to JSTOR DOI

    (3)(+0000000): Translate: JID found 2 10.2307/1209605

    (3)(+0000000): HTTP POST noDoi=yesDoi&doi=10.2307%2F1209605 to http://www.jstor.org.ezproxy.[...].edu/action/downloadSingleCitationSec?userAction=export&format=refman&direct=true&singleCitation=true

    (3)(+0000000): HTTP POST {} to

    (3)(+0000003): Connector: Method getSelectedCollection succeeded

    (3)(+0000150): Translate: Creating translate instance of type import in sandbox

    (4)(+0000003): Translate: Binding sandbox to http://www.jstor.org.ezproxy.[...].edu/stable/1209605?origin=crossref&seq=1#page_scan_tab_contents

    (4)(+0000000): Translate: Parsing code for RIS

    (3)(+0000002): Translate: Translation successful

    (5)(+0000000): Translate: Running handler 0 for done

    fbennett: Your IT department, I guess. I've never seen an institution use a self-signed cert for a proxy — seems like a strange choice. You could whitelist the cert on a common domain, I guess (though I don't actually know if wildcard self-signed certs work). But I think your case is specific to your network.
  • edited January 10, 2015
    Dan: Thanks - I'll get in touch with them next week.
  • I'm getting this problem as well. Can't import citation and pdf from JSTOR to Zotero using the plugin for Chrome.

    I'm using Chrome on Windows with Zotero standalone on a uni network. It was working perfectly just a few days ago but yesterday stopped. I need this to import dozens of papers and citations at the moment so it's a bit of hindrance to say the least.

    The debug ID is D2114274435
  • What's the URL exactly as you see it in the URL bar?
  • This is an example:


    I'm connecting through the National Library of Scotland. Always worked perfectly before.
  • Can you access the page via https://www.jstor.org.connect.nls.uk/stable/1800252?seq=1#page_scan_tab_contents (note the https) and does it remain as https?
  • When I try going through https Chrome delivers a security measure, clicking through this I can access the page via https (although there is a red line through https in the URL bar). The Zotero plugin can then download the citation but not the PDF.
    UPDATE: the plugin now works fully (citation and pdf import) on the pages it previously failed on (but this isn't going through https). What's going on there, then?!
  • So I was trying to fix the original issue reported above by making Zotero retrieve metadata from JSTOR via HTTPS even when the pages are accessed over HTTP, but this introduces additional issues with proxies that do not properly support (or don't support at all) secure HTTPS connections. I'm guessing that your previous attempts to save data from HTTP urls were failing when Zotero was fetching metadata over HTTPS due to the SSL certificate issues. When you visited the HTTPS page, you told Chrome to ignore the issue with the certificate. Now, when you visit pages over HTTP, Zotero is no longer blocked from accessing the HTTPS pages for retrieving metadata.

    In any case, this is not an acceptable solution and I will be reverting it shortly. We'll have to come up with something better for the original issue.
  • @MikeGruz, if you're still following this thread, can you confirm that after replacing your translator with an older version the page is actually detected by the JSTOR translator? (i.e. if you mouse-over the URL bar icon, it says JSTOR and not DOI)
  • Is there any update to this problem?
  • Dan: I got in touch with our Uni IT Department, who referred me to the Library IT staff, who referred me to this page.


    The link was accompanied by an apologetic note saying that they would like to set up a proper signed certificate on the proxy service, but that there is no timetable in place for making that happen.

    So ... well, yeah.
  • I wanted to check in to see if there's been any progress on this since I'm still encountering the issue whenever I try to use JSTOR (it isn't a problem with other providers), so the problem must lie in changes that JSTOR has made. I'd be happy to do any further troubleshooting at this end.
  • We've been having problems since last week downloading JSTOR pdfs to Zotero and also downloading pdfs directly within the JSTOR database. When trying to download within JSTOR (not using Zotero) JSTOR chat recommended we check our version of Adobe, but it was current. JSTOR ended up sending the pdfs to us as email attachments.
  • I'm a librarian and was helping a patron troubleshoot a similar issue today. Using Safari on a Mac Zotero would show that it was downloading citation info from JStor but nothing would make it into Zotero. I was unable to replicate this issue on my Windows machine. The workaround we came up with was to install Chrome - no issues, everything works perfectly there.
  • Thanks @chriseay ! The Chrome suggestion helped me on my Mac!
  • Using Chrome solved the problem for me as well (though I'd rather avoid having to use Chrome).
  • (Firefox will work, too, in case someone is particularly averse to Chrome; this is a Safari-specific issue.)
  • Also confirming that this is a Safari-specific issue. Chrome saves a JSTOR article into Zotero just fine.
  • Regret to report that I'm having this exact issue on Chrome.
  • no, let's keep this thread on the Safari issue, please start a new one and provide more details (URLs, version numbers, debug ID for a failed attempt--see the questions we're asking people above).
    Since for most people here switching to Chrome fixed this, any issue that exists on Chrome is by definition not the same.
  • It's not a safari specific issue only though: formosaman reports exactly the same issue for Chrome above on Jan 10th 2015.
Sign In or Register to comment.