Remove Field Codes (as in EndNote)

I'd like to be able to totally remove the field codes in a given document. In EndNote's system, this creates an entirely separate document where all references and macros have been replaced with absolute text.

This means that when I send a document to a technophobe professor running an old or borked version of a text editor, I don't have to worry about him/her coming across field codes rather than references.

I'm new to Zotero, and there may yet be a way to do this, but I don't see it on the list of macros.

  • In Word, you can select all the text in the document then press ctrl-shft-F9. This will flatten all the field codes. I'm not sure how to do this in OpenOffice.

    Caution: at the present time there is no way to restore the codes to Zotero friendly codes, so only do this when you completely finished with the document AND the bibliography.
  • How do you do this on Word 2004 Mac?
  • Try selecting the text of which you want to flatten the fields, and press CMD + Shift + F9.
  • It worked - thanks!
  • didn't work on my mac pro (Word/MS Office 2008). any other ideas?
  • didn't work on my mac pro (Word/MS Office 2008)
    Depending on your keyboard configuration, you may need to hold down "fn" as well.

    In the Zotero 2.0–compatible plugins, there's also a new dedicated command for this that flattens only Zotero fields.
  • edited April 14, 2010
    I installed the 2.0-compatible plug-ins (using Mac Word 04...installed pythonext and macword plug-in 3.0b2), but I don't see a button on the toolbar for "remove field codes" or something similar. Am I missing something? (I did figure out how to do it using the Word keyboard shortcut: cmd+fn+shift+f9). thanks for any help!
  • there is a button - icon is a broken chain link - to the right of "Set Document Preferences".
    If you're sure it's not there post a link to a screenshot.
  • yes there is, it is in the zotero menu, which is behind the flag-symbol, to the right of the menubar
  • edited April 14, 2010
    thanks for the help... I definitely don't see a button in the menu. There are 6 buttons: edit citation, insert citation, edit bib, insert bib, zotero refresh, zotero set doc prefs. I also can't resize the toolbar though, which is weird (even though it has the re-sizing hash marks in the lower right corner). I don't have a flag menu...but isn't that a MacWord 08 thing?

    ps: after I installed everything and restarted Firefox, I also restarted Word. Is there something else I need to do to install the updated plug-in?
  • edited April 14, 2010
    casehouse8: Does the plugin work otherwise? Because that might not be the latest plugin version—see Incompatible Plugin. If you're sure that's the right version, have you tried dragging to the horizontal toolbar?
  • I'm pretty sure I installed the correct version (MacWord Integration 3.0b2...installed after also installing pythonext). I was worried about the same thing, so I manually deleted the toolbar (as suggested on the page you linked to), and re-installed everything, to no avail. (The plug-in works otherwise, but no "remove field codes" button.) Also, I was completely mistaken about the re-sizing problem. I can drag it to make it horizontal, vertical, etc. (sorry)
  • edited April 14, 2010
    if the plugin works you've installed the correct one, so that's not the problem.
  • So you're saying that when you resize it you still don't see the button?
  • yes, that's correct: when I re-size it I still don't see a button.
  • I have the same problem here: not seeing the remove field code button in the tool bar.
  • which Word/OS/plugin version?
  • thanks!
    Word 2004 for mac/OS 10.6.3 Snow Leopard/plugin 3.0b2.
    Any help much appreciated!
  • hello,

    i'm hoping we can reopen this discussion. i've read through the entire thread, but there doesn't seem to be a solution posted. i've installed the 3.0b2 plugin but also have no "remove/unlink field" button.

    is there another plugin that should be installed?

  • have you tried cmd+shift+F9 or cmd+shift+fn+F9?

    I don't know why the button is missing from the plugin.
  • hi,

    "cmd+shift+fn+F9" seems to have worked fine on my word document (mac version), so i guess i won't worry about the toolbar button.

    thanks and take care.
  • Hi,
    I think I accidently clicked on the "remove field code" button, because when i try to insert a new bibliography in my document zotero starts a new bibliography and doesn't re-organise the other citations.
    Is there a way to undo that?
    Thank you
  • That depends on what you did since clicking the button. If you haven't saved the document, there is a chance that you can undo. But if you saved, it will be difficult to go back and you would have to look for a backup copy of an earlier version or reinsert the references.

    To clarify, are you inserting a new *bibliography* or a new *citation*? Inserting multiple bibliographies is always possible.
  • Thank you for your answer. I was trying to insert a new citation. I finally used my latest back up copy and everything works again!
  • Thank you so much arggem!It helps!
  • You guys are awesome. Zotero forums win again.

    Cmd + Shift + Fn + F9 worked in Word 2011 on Macbook air with Os X. (Fn is necessary to get the F9 to work).

    I have Zotero now, but used to have endnote, and needed to get those pesky endnote fields out of an old document.
  • edited September 6, 2017
    Hey, just a follow up: remember that if you press Ctrl + Shift + F9 you remove ALL fields, that means also the one you may want to keep (e.g. tables, figure, table of contents etc.) To remove just Zotero fields, use the plug in, or the combination on the portion of text you want codes to be removed. Cheers.
Sign In or Register to comment.