Proquest, EBSCOHost broken?

No icons in Proquest, only folder icon in search results for EBSCOHost. Or maybe it's just me? FF 3.0.1, Zotero 1.0.7, Mac OS 10.4.11, catalogs accessed through proxy.

I don't get any icons in the URL bar when visiting Proquest. Sample URL reached via search:

Document URL for the same record:

Also, EBSCOHost shows the folder icon on the search results page, but no icons on single record page. Looked like there were some earlier posts about this being broken, so I'm guessing a fix is in the works...

Sample URL reached via search:

Permalink to same record:
which takes me to:

recent threads about EBSCO

And a slightly older post on Proquest
  • EBSCO fix will be out shortly.
  • The fix for EBSCO is now out. Your copy of Zotero should auto-update within 24 hours, or you can update manually by clicking Update Now in the General pane of the Zotero prefs.

    To open the preferences pane click the gear icon, this will open the actions dropdown menu. Select preferences from that dropdown menu.

    There is still an issue with Permalink pages but we should have that resolved shortly.
  • I too am having problems with ProQuest. No icon shows up in the URL box in any view of Proquest. I also access Proquest through my university proxy.

    Platform: Zotero 1.0.7. Firefox 3.0, OSX 10.5.4

    Example links (that don't work):
    Publication search...

    Article List...

    Specific Article...

    Abstract View...

    Citation View...

    Note: at first glance you might think that the problem is with how MIT's proxy creates a new domain name for the site, but I don't think this is the problem since Zotero is happy to work with other sites, including Jstor, in this form ( and that others, including the original poster, have had problems with out the proxy renaming.
  • I am also having a problem with proquest going through my university's proxy - we use ezproxy. In my case, I get teh abstract in a note, which I guess is ok. However, when I try to get a snapshot of the page, I get an error - reported using gear menu with Report Id: 910161603. Furthermore, if I set it to automatically download any attached PDFs, I get the error logged as Report Id 628658499. Hope those reports help.

    I unfortunately am not in a position to set without the proxy, but these options work fine for other sites JSTOR, Blackwell etc. so i do not think that the proxy is an issue.
  • Thanks for your report. A new version of the ProQuest translator is now available. Your Zotero client will update automatically within 24 hours, or you can click "Update now" in Zotero preferences.
  • Seems to be throwing the same error after doing an 'Update Now'. Error shows up when I try to click on the item. This only occurs if I enable 'automatically download PDF'. New Error report is 770477505
  • We're not getting errors saving PDFs. Please provide a specific permalink or article.
  • tsoloane: You're getting a database corruption error, so you need to run your database through the DB Repair Tool. The corruption is most likely left over from using Firefox 2, which had database instability problems, and you shouldn't get it again in Firefox 3 after repairing your database.

    That's unrelated to the PDF-saving issue, though.
  • Wicked. Seems to work like a charm. Only thing, now when u select download pdf, it give me the proquest login page. Almost as if it is not going through the university proxy. This works properly for JStor and other repositories.
  • I appears that EBSCO updated its interface today, and the translator is now broken in the same manner as in the original post from 2008.

    I got an email from a colleague about this and confirmed it on my own machine using FF 3.6.8 and Zotero 2.0.3 (on Linux Mint, but I think my colleague is using Windows).
  • I am new to Zotero this summer and am now dependent on it and Ebsco. What is the usual timeline for site translator fixes like this?
  • Judging by the two previous cases in which this problem came up, the Zotero folks are pretty fast about fixing this translator (a matter of a day or two). But it is summer, after all.
  • does the usual work-around - going through the "export to Endnote" option (with Zotero set to open refer/RIS files in the general tab of the preferences) still work?
  • @adamsmith -- It does work if you do the work-around you suggested
  • Ditto. Works for me.

    I actually updated my translators and restarted Firefox, and now things are working as normal except for multiple search hits. I can take in a citation at a time normally.
  • At some point, shouldn't EBSCO have to provide its own translator if it's going to keep breaking things like this. There probably is a quick fix, but I wasn't able to get it fixed in first shot at it. The translator code is rather hairy, but I will try to find time to try again in the near future. Of course, others should feel welcome to work on a fix as well.
  • And dowens -- are you sure that you're not defaulting to the DOI translator? The detect code for EBSCO is broken, in addition to some other logic, so individual articles probably aren't working.
  • people who use EBSCO should send them a note pointing out this issue - chances are they'll ignore it, but it's worth a try
  • Yes, it is the DOI translator. I noticed that when I was using it, but I didn't know what it was, nor did I carefully check the result. The workaround is good for now.
  • Any update on the translator for EBSCO? School is starting soon and we've been doing a big push in teaching Zotero for the entering grad students. Having EBSCO not working with Zotero has been a bit of a bummer as we're trying to teach.

    If there is something that I should email to our EBSCO rep that they can do on their end? Please let me know and I'll do it ASAP.
  • This is not really a good time for me to be working on difficult translators like EBSCO, since I'm really over-committed. I've been doing a lot of the translator maintenance recently, but I don't know how soon I will be able to work on this.

    I'll post to the developer list and see if someone can give it a try.
  • As for contacting EBSCO reps, they don't provide us with the translators, but we would be very appreciative if they could give us a heads-up before making site changes or otherwise engaged with our developers. If we really do have hundreds of thousands (one million?) of users, then perhaps they'd be willing to help us use their site. So yes, we would be very glad if their people could talk to us about making metadata extraction and PDF downloading more reliable.
  • @efilgo - I was referring to my secret hope that at some point database providers would provide Zotero with translators, because they don't want their database to be broken with Zotero ever - you can certainly write them about that - but I wouldn't get my hopes up.

    Having given Zotero presentations I would actually take this as an opportunity to demonstrate how Zotero can import Endnote data - in EBSCO what you do is
    Add to folder---> View Folder ---> Export --->Save citations to a file formatted for:
    Endnote, ProCite .....

    unfortunately that produces some ugly attachments, but oh well.
    Zotero translators do break occasionally and it's good for users to know that there is a workaround that works in almost all cases.

    By the way - I just discovered that Sage is, to my knowledge, the first major database provider who provides an explicit "Export to Zotero" option (it's just clean RIS) - not that that should be necessary when translators are working, but I thought it was neat.
  • Actually, EBSCO did contact us (albeit after the design changes), but they did so via private e-mail at inopportune times for getting responses. We're directing them to the dev list. Not sure how much they'll be able to offer in terms of dev support, though.
  • Any news yet on a translator? I've got a slew of new classes scheduled in the next two weeks and I'm going to be showing Zotero in all of them and not having EBSCO working is a big hurdle.
  • I really can't work on this now. I understand that it is very important that key databases be working as the academic year starts, and I hope we can make this happen.

    Can anyone else step up?

    I should note that selecting results in EBSCO and exporting them as Endnote/RIS will get them into Zotero fairly efficiently, if it comes to that.
  • An EBSCO rep named Robert Pomerleau contacted me to ask for more info about the problem. At Avram's prompting I've asked him to comment on this thread or to the zotero-dev list.
  • The academic year starts and and EBSCO is the main database used by students and researchers.

    I hope the problem will be solved as soon as possible. It is very important for the Business School
  • @jasonpuckett Thanks for pointing the EBSCO rep you spoke to to this thread. If anyone else has contact with EBSCO reps please give them the same advice.

    @ajlyon do not feel bad about not having the time to dig into the translator at the moment. Last time the EBSCO translator was fixed it took a ton of work and involved some intense experimentation with a series of random variables. The best step forward at this point is most likely going to involve some very minor tweaks on their end that result in us being able to make a much more simple translator that is far less prone to breaking.

    @michelm while problems persist with the translator keep in mind that you can use EBSCOs clipboard function, and its export to reference manager link, to add items to Zotero. See earlier in this thread for some more details. In other words, Zotero does work with EBSCO. It works exactly the same as any other reference manager interacts with it. With any luck, in a little while it will be working through the location bar icons as well.
  • Thanks for the workaround, it works, and it's clunky. I sent a message today to EBSCO Host saying the following:

    Dear folks at EBSCO Host,
    I'm almost certain you're aware of this problem, but wanted to add my voice to the chorus of appeals to you to help. Zotero, the best academic-reference management service on the planet no longer works with EBSCO Host since your recent changes. And because Zotero is run by volunteers, nobody can do the highly complex work your changes call for in their system. There are some suggestions in recent correspondence (see the link at that somebody from your organization might be able to make minor changes at your end which would be enormously helpful for those seeking to remedy this problem for the upward of 1 million users of Zotero.
    Thanks for your attention to this,
    Glenn Francis

    Perhaps if there were more voices heard at EBSCO a solution might occur..
This discussion has been closed.