Report IDs: 1803874051 &1803874051 - Libre Office Crashes using zotero integration plugin


I've been getting crashes when using the zotero plugin and libre office. I've attached two separate report IDs, but it's been happening more regularly than that. I'm using Debian Gnu/Linux KDE.

It crashes often when I try to insert a reference in libreoffice - the popup/zotero windows comes up but not properly, and libre office freezes and I have to end the process. More recently, I tried to remove the field codes, and doing this, it crashed every time (I had to submit an essay with field codes included). I even installed Zotero standalone and tried doing it using this and it still crashed.

  • one thing to check is whether you're just seeing these KDE issues:

    @Dan - anything relevant in the error reports?
  • edited March 15, 2014
    appName => Iceweasel, appVersion => 24.3.0
    And a lot of other extensions.

    (But those things probably aren't relevant if this happens with Standalone too, assuming "Firefox" was closed at the time.)
  • hmm, those KDE errors don't look familiar - could be that that is more opensuse/fedora specific? Note also that I'm getting the crashes when in the libreoffice window, not inside zotero 'itself'..
  • yeah, so the next thing would be to try to disable all Firefox/Iceweasel add-ons, including anything Zotero related except for Zotero itself and the LO plugin, and see if that changes anything.
    It's certainly not something we have seen reported before, but then how many people use Zotero on Debian/KDE?
  • Hmm, so I just checked and I'm definitely still getting the problem with zotero standalone, even when firefox/iceweasel is closed... I just tested it with a new document, and with both refmarks and bookmarks and the same problem occured (new report id from it from zotero standalone: 780043136

    I also previously got this error in zotero standalone:

    'An error occurred communicating with Zotero: Binary URP bridge disposed during call
    at Method)
    at com.sun.proxy.$Proxy43.execute(Unknown Source)
    ' when calling method: [zoteroIntegrationDocument::displayAlert]"

    I don't appear to be getting that every time, though.

    I can send you the screenshots of what the error looks like, but don't seem to be able to attach images here?
  • Yep, still getting the problem with all firefox plugins disabled except zotero and zotero integration.

    I've noticed that after libre office crashes, I also have to restart firefox / standalone in order to be able to add references in libre office again.
  • wait - it's LibreOffice that crashes? Even if triggered by Zotero, that's almost certainly not a Zotero issue. Report to them.
  • And neither firefox nor zotero standalone seem to be closing properly after this, I have to 'end process' them.

    Just noticed that - despite all other evidence to the contrary, in firefox --> zotero --> preferences it says that the libreoffice etc. plugin is not installed. on trying to install it it's giving me errors: JavaScript Error: "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIServerSocket.init]" {file: "file:///home/nick/.mozilla/firefox/9izv9x8p.default/extensions/" line: 83}]

    [JavaScript Error: "Translator with ID 47533cd7-ccaa-47a7-81bb-71c45e68a74d already loaded from "Bibliotheque nationale de France.js"" {file: "file:///home/nick/.mozilla/firefox/9izv9x8p.default/zotero/translators/Biblioth%C3%A8que%20nationale%20de%20France.js" line: 0}]

    [JavaScript Error: "TypeError: temp is null" {file: "chrome://global/content/bindings/preferences.xml" line: 1172}]

    [JavaScript Error: "[Exception... "'unopkg at /usr/bin/unopkg failed to install' when calling method: [nsIObserver::observe]" nsresult: "0x8057001e (NS_ERROR_XPC_JS_THREW_STRING)" location: "native frame :: <unknown filename> :: <TOP_LEVEL> :: line 0" data: no]"]

    [JavaScript Error: "uncaught exception: Don't know how to go back from intro"]

    [JavaScript Error: "TypeError: temp is null" {file: "chrome://global/content/bindings/preferences.xml" line: 1172}]

    [JavaScript Error: "[Exception... "'unopkg at /usr/bin/unopkg failed to install' when calling method: [nsIObserver::observe]" nsresult: "0x8057001e (NS_ERROR_XPC_JS_THREW_STRING)" location: "native frame :: <unknown filename> :: <TOP_LEVEL> :: line 0" data: no]"]
    (report id: 1344452270)


    Tried to install it manually and libreoffice crashed (a problem I've had before, but hasn't mattered so much since installing extensions for that is generally done elsewhere or in the package manager on debian).

    I've also just noticed that in firefox/iceweasel I have zotero/libreoffice integration 3.5.9 installed, whereas in libreoffice it insists I have 3.5.8 installed. Could that be the cause of the problem?
  • which LO version is that?
  • It's version

    I'll report it to libreoffice. Cheers.
  • could well be Java/JRE related. Java and linux has never been a happy marriage, though things have been going more smoothly with the most common distros lately.
  • Yeah, I think I've had libreoffice crashes before relating to java, and never really satisfactorily solved!
  • Libreoffice bug report here

  • I assume you have LibreOffice 4.2? Reinstall the LibreOffice add-in from Zotero Preferences->Cite->Word Processors in Firefox/IceWeasel. There was a change in LibreOffice 4.2 that makes displaying dialogs crash with older versions of LibreOffice Integration, so if you have LibreOffice Integration 3.5.8 installed in LibreOffice 4.2, that could well be the cause of your issues.
  • lib234 says they have LO installed (four posts up). Sounded like they tried re-installing?
  • Ah, sorry I missed that. Yeah, if manually installing is crashing LibreOffice, it's something else.
  • Will try it with 3.5.9 - but yeah problems with manual installation are making that difficult!
    I'm trying the reinstallation of libreoffice/ new profile route and seeing where that takes me.
  • Ok so really struggling to install 3.5.9 here and getting just the same problems appearing with a full reinstall/new profile on libre office - crashes starting to appear once the zotero plugin in libreoffice is installed.

    My last post to the libreoffice bugtracker:

    "OK thanks - i've tried this and it worked fine, apparently, until I installed the zotero plugin integration from the debian testing repo (haven't tried the other plugins - didn't really use them).

    As soon as I did this, I tried a) saving - and managed to get it to crash doing this, and then b) going to extension manager - again, trying the update option got it to crash. I also tried c) remove field codes, and it crashed, as before."
  • Anyone know of a way of removing field codes, as a workaround until I can get this part of zotero working?
  • save as .doc
  • Thanks!

    So I managed to upgrade the libreoffice zotero extension to 3.5.9, still getting crashing.

    So an interesting update – I logged out of KDE and into Gnome (on the same system – I have both installed though generally only use KDE) – and tried the same things in libreoffice, and it is working fine – inserting citations, removing field codes, etc.

    Only strange problem is that when I try it in gnome, with zotero standalone, rather than iceweasel/firefox open, and add a citation, it says:

    “ could not communicate with Zotero. Please ensure Firefox or Zotero Standalone is open and set to an online state and try again.”

    I realised that regarding the previous KDE problems, the reason I might not be experiencing them is that I don't have Oxygen-gtk theme selected for gtk2/3 (Zukwaito??). I do use the oxygen theme (a slightly customised version of this) for QT.

    I could definitely have a mess around with themes and see if that helps, though i've just changed them all and it doesn't seem to have changed anything in libreoffice – does it follow the theming? The gtk theming or the qt?

    (Also, Libre office are suggesting that the crashing appearing together with the zotero extension suggests that it is a bug in the extension:
  • edited March 20, 2014
    If the crash only occurs under KDE, it may be another issue related to libreoffice-kde, which seems to periodically accumulate bugs that prevent Zotero from working. You could try removing the libreoffice-kde package for now and see if that fixes things under KDE, although it will make things uglier.

    It is possible that you are got the communication error message with Zotero Standalone open because you 1) don't have Firefox and Zotero Standalone set to share data directories (the official version of Zotero asks if you want to share data directories on open, but I think we've seen another report that suggests that this prompt doesn't exist in the KDE package) and 2) you opened Firefox first, and then Zotero Standalone, and then closed Firefox. If you set Zotero for Firefox and Zotero Standalone to use the same data directories, this should be resolved.
  • OK, I will try those ideas - thanks. Got some urgent deadlines coming up so might be a few weeks though.
  • Hi, I updated the libreoffice bug report with some further findings and backtrace attempts:

    text copied here for convenience:

    "Hi, please find attached my attempts at getting a backtrace relating to this bug (or bugs). I was trying to get a bug report of the specific crash relating to removing field codes in zotero but I'm not sure that any of these bug reports are that.

    Whilst the specific aspects of this bug relating to Zotero, and in the extension manager, only appeared when using Libre Office in KDE, I still got irregular crashes when using it in Gnome.

    Shortly after I'd got these backtraces, my laptop irreparably stopped working (motherboard?) and I'm now using a new one - with Kubuntu 14.04 - I don't seem to be getting these errors on this. I failed at installing Debian on this machine so there's no chance of me testing this further.

    Thanks for your help."
Sign In or Register to comment.