Not signed in (Sign In)
 

Quick Links

Vanilla 1.1.10 is a product of Lussumo. More Information: Documentation, Community Support.

    • CommentAuthorCunio
    • CommentTimeSep 9th 2013
     
    Zotero standalone in Fedora 19 64 bit starts OK and when any menu
    is selected it crashes immediatelly.

    with the following error message:

    ###!!! ABORT: X_CreatePixmap: BadAlloc (insufficient resources for operation); 4 requests ago: file /builds/slave/rel-m-rel-xr_l64_bld-000000000/build/toolkit/xre/nsX11ErrorHandler.cpp, line 157
    ###!!! ABORT: X_CreatePixmap: BadAlloc (insufficient resources for operation); 4 requests ago: file /builds/slave/rel-m-rel-xr_l64_bld-000000000/build/toolkit/xre/nsX11ErrorHandler.cpp, line 157
    Segmentation fault (core dumped)
    • CommentAuthorDixieCom
    • CommentTimeSep 9th 2013
     
    I have the same problem, both on Fedora 19 and OpenSuse 12.3. Any attempt to render a menu causes an immediate and very ungraceful crash!
    • CommentAuthorDixieCom
    • CommentTimeSep 12th 2013
     
    Anybody there?!
    • CommentAuthorDixieCom
    • CommentTimeSep 12th 2013 edited
     
    OK - I've resolved it.

    I am using KDE 4.11 on OpenSuse 12.3 64 bit.

    If you set the GTK2 theme to oxygen-gtk, this causes a crash when attempting to render a menu in Zotero, although all other Firefox extensions are unaffected. Setting the GTK2 theme to Adwaita fixes the problem.

    So, looks like it's a KDE issues rather than Zotero!
    • CommentAuthoradamsmith
    • CommentTimeSep 12th 2013
     
    thanks for sharing that - I don't know for sure, but I don't think devs typically test Zotero on most distros, the default is probably ubuntu or mint, so things like that can happen.
    • CommentAuthorCunio
    • CommentTimeSep 15th 2013
     
    @DixieCom, good finding - thanks it helped, I have been changing oxygen-gtk to qtcurve and now zotero works OK.
    • CommentAuthorsean_1985
    • CommentTimeNov 29th 2013
     
    I am using KDE 4.11 on OpenSuse 13.1 64 bit. I checked /etc/gtk-3.0/settings.ini and /etc/gtk-2.0/gtkrc, both has gtk-theme-name = Adwaita. I still have the same error
    • CommentAuthorcyberace
    • CommentTimeDec 3rd 2013
     
    It helps me a lot, thanks!
    • CommentAuthorerget
    • CommentTimeJan 4th 2014
     
    @sean_1985 - That's because Zotero apparently uses GTK2 rather than GTK3. I changed the GTK2 settings to Adwaita and the problem went away.

    I'd also suggest using the Configure Desktop GUI to change your GTK settings rather than the config files in /etc/... You can find the settings under Application Appearance --> GTK.

Zotero Forums are powered by Vanilla 1.1.5a