Items not updating between personal and group library

I cannot get the changes I've made to items to update between my group and individual libraries. I've been editing entries in my personal library, such as abstract, tags, notes, etc. To try and get the changes to update in my group library, I've been deleting the folders in the group library, then dragging the updated entries folder from my individual to the group library, then syncing.

However after dragging the folder down it pops back up in the group library, but in the same state it was in before, i.e. without the updates. I've tried deleting both the folders in the group section of my Zotero add-on and on the Group website, then updating in this fashion, but they always come back the same way they were before. What am I doing wrong here?
  • When you drag an item from a personal library to a group, it makes an independent copy of the item. So they become different items.

    When you are writing about folders, you mean collections? When you delete a collection, the items in that collection are not deleted. (Like deleting a playlist does not delete the songs in iTunes.) You would need to delete the items as well. The problem with this approach would be that you loose liking between your citations in the documents that you are working on and your Zotero library.

    To summarize, there is no simple way to do what you are trying to do. There are some plans to synchronize changes between libraries, but this has not been implemented yet.
  • Ok, I tried this: I deleted all the entries in the two subcollection folders in the group library individually as well as the folders themselves. Then I synced so the collections and entries were also deleted on the website. Then I dragged the subcollections from my library into the group library, and then synced so they reappeared on the website as well. Tags and notes still didn't update.
  • Did you delete the items from the group library, or just remove them from the collections?

    If the former, did you empty the trash? If you don't, Zotero will just restore the trashed items if you try to drag the same items in.
  • I was kind of iffy about emptying the group library's trash. Maybe some other folks would want to restore items. I did it anyway though in combination with the above steps. The notes and tags still didn't update.

    Finally, having exported the collections in my personal library to a folder on my computer, I imported them back. They showed up at the top of my personal library folder, I dragged them down into my group folder, and deleted them in my personal library, since the collections were effectively duplicated there. Now the tags and notes are updated in my group library. Whew!
  • OK, but there's no need to do that. If the items are truly gone from the group library, dragging the source items in again will absolutely copy all data. The only way for what you describe to happen is if a copy of the item already exists in the target library.

    I'm guessing you didn't actually delete the original items from the group library and they're still (or were still, when you tried the copy) in the library root.
  • Yea that sounds right. I figured as much all along. But how to get to the root? Explosives?
  • The "root" is the brown box icon followed by the name of the group. If you have that selected you'll see all items in your group.
  • Oh, there is a ton of stuff in there. So I would have to sort through it and find the individual entries? Seems like they should also be deleted from the root when I delete them in the subfolder.
  • The misunderstanding here is equating Collections and folders. There are not the same (Zotero doesn't have folders). A collection is closer to a playlist:
  • Thank you for shedding light on this and pardon my ignorance. I noticed when I just pressed delete on the keyboard the items just disappeared, but right clicking and selecting delete from library prompted an "are you sure" box. So I also deleted the items individually following the latter approach but they still came back without the updates.
  • You have to empty the trash after you delete them.
  • Got it. Before I didn't try emptying the trash after I had deleted the items from the library (pressing ctrl delete). Instead I had emptied it after just removing the items from the collection. I dragged the collections back to the group library, the old versions popped up and I was able to delete them and they showed up in the trash. Thanks for your patience.
  • Please, and then after four years, What is the current solution?
  • Nothing new here.
  • @zinvemar Solution to what?

    An item can be "deleted" from a collection doing so will not delete it from a library.
    An item can be deleated from a library -- but there is a safety net.
    Items deleated from a library are removed to the Zotero trash. To completely remove it you empty the trash.
Sign In or Register to comment.