Migrating to standalone Zotero 3

The documentation thread suggests I start a new discussion. How does one move from our traditional use of Zotero as a FF plug in to the new stand alone application available cross browser? Much of the elements are in discussions groups but we might pull it together in one area for those of us, such as myself, are not truly expert in the technology. Like most, my Zotero library is an invaluable asset and I believe it is buried within Firefox - a copy on my hard drive and some of the data synced with Zotero's servers. It seems "neater" to down load the new app and import the library into that app, easily found on my hard drive, replicable etc... How would one do that? How would one install the connectors to Safari and Chrome? What the potential pitfalls? Will it still sync with Zotero servers? These are initial questions only but a fuller FAQ might be developed.
  • As a general statement for low-tech users - ZSA and its defaults are designed so that you simply install it and try it out. Accept the default options and you're fine. There are no risks. If you don't like it, you can un-install it without any harm done.
    It seems "neater" to down load the new app and import the library into that app, easily found on my hard drive, replicable etc...
    Already in the Firefox version you can move your Zotero database wherever you want on the computer (see advanced tab of the preferences) - note that if you change the database location, you will still have to manually move your database (i.e. the files) to that location.
    The default storage location for Standalone (ZSA) is not any neater than for Zotero for FF (ZFF).

    It is recommended that, on installing Standalone, you simply share the database with the existing Zotero for FF database - whether that is in its default location in the mozilla folder or in a custom location you placed it. You can also move the database at any later point - though I believe you'd have to change the location both in FF and Standalone.

    Syncing with ZSA works exactly like with ZFF.

    The connectors install like any other extension in Safari/Chrome, i.e. automatically when you're using the appropriate browser. They automatically recognize ZSA when it's open.

    There are no potential pitfalls.
  • Downloaded ZSA and sharing FF library. Citation and bibliography work fine. Installed the Safari connector but that does not seem to work. From within Safari, I got on my University's EBSCO service, exported a citation RIS format and instead of installing into ZSA it downloads into the download file as a text. Perhaps some configuration issue? Maybe I need somehow to make ZSA my default library? FYI the Z icon nicely designed and very distinctive!
  • the RIS export function doesn't work smoothly with standalone. But for EBSCO (and most other databases) you should get the Zotero icon to the left of the URL bar (in Safari; in Chrome it's in the URL bar on the right).
  • Almost there. In Safari browser on the EBSCO database, I saw the Zotero icon to the left of the URL bar along with all the other extensions (so far so good). Press it and a list of the articles displayed comes up, tick the ones I want, press and it says importing - BUT, the references are not in ZSA or ZFF library. A missing link somewhere? FYI on the ABI Proquest database I still get the missing link error message that has plagued me always. And when I try to export to RIS nothing happens.
  • And cannot seem to get the connector in Chrome - I get the following error message when I try

  • edited February 7, 2012
    And when I try to export to RIS nothing happens.
    Not related to Zotero, but it's probably just downloading the RIS file to your computer. Check the downloads list. Note that Standalone actually registers itself for RIS files, so in a browser that supports auto-opening arbitrary files (which Safari does not, I don't believe, but you can set Chrome to do so by right-clicking files in the downloads bar) you can essentially import directly into Standalone. The main downside currently is that it imports into a new collection each time.
  • For the Chrome connector - search the forum - there are a couple of threads on this, not sure what the current solution is, but in general this work. In any case, move that to one of those or a new thread.

    I have no idea what the "missing link" error message is.

    As for the problem with EBSCO - find the preferences/options for the Safari connector (in Chrome that's under tools-->extensions) and see what the Zotero Standalon Status is.
  • Confusing experiences. I repeated the experiment. In Safari and EBSCO. I did a search generating 10 items,clicked on the icon to the left of the URL bar, only two visible. Chose one and clicked OK - it saved to ZSA. Then I exported one to folder view and exported as RIS - that will not import int ZSA from Safari. With ZFF, when the little brown icon in the URL bar was not working, I could export to folder view and export into ZFF without fail. It seems that Safari will be very hit and miss for me and not really workable? I cannot get my Chrome browser to load the connector - see above CRX FIle Not Readable error message.
  • "Then I exported one to folder view and exported as RIS - that will not import int ZSA from Safari."
    As Dan explains above, that won't change anytime soon. You can still download the file and import it in ZSA using the import function, but no, this will never be as smooth as with FF. If that's a crucial feature for you, stick with Zotero for FF.

    But the folder item should work. If it doesn't in any reproducible way we can troubleshoot that.
  • Thanks somehow your previous response did not update before I emailed again... Anyhow. I will look for the Chrome connector problem separately of course. Re Safari I had thought of that one and the connector is enabled. I tried a third time with a new search with Safari, EBSCO and I generated about 20 articles. all articles showed up on the list when I clicked the icon to the left of the URL this time and downloading the citations worked as one would expect. The problem will arrive when the articles for some strange reason don't all list when one clicks on the Zotero icon - I have had that under FF with the little brown box in the URL. Random issue.
  • it's not completely random - it depends on the databases the respective articles are from - look for that next time you see that and you'll notice that all the missing articles are from the same databases.
  • edited February 7, 2012
    You can still download the file and import it in ZSA using the import function, but no, this will never be as smooth as with FF.
    It might be possible to implement equivalent auto-import via the connectors in the future—depends on what future versions of the Safari and Chrome extension architectures support. But even without that, with Chrome it can already be pretty smooth. It's just that Safari doesn't have a mechanism for auto-opening RIS files (at least without modifying a system file). You can still double-click on the downloaded RIS file in the downloads list, though, and it should open in Standalone.
  • Thanks - Adam - I will try to decipher the source of the documents. My naive view is that, for example, EBSCO is the database and I get a random experience on EBSCO. I suspect EBSCO is merely presenting the results from other databases but I am not sure how I would know which. I will discuss if I can with our Library.

    Dan, I followed the thread about fixing the installation in Chrome issue and merely clearing downloads allowed it to install and it generates that little brown box within the URL rather than an extension icon to the right of the URL box - I cannot figure out how to generate extension icons outside the URL box - and been on the Google site. But the little brown box worked fine. So the bottom line, if all the articles are rendered in the icon to the left of the URL (Safari) or in the little brown box (Chrome) the user experience is fine and the files work. If I download a RIS file in Safari and double click in downloads, I cannot get it to import directly to ZSA. But we are moving in the right direction

    One final question now - where is my library - is there a copy in ZSA (where) along with FF version?
  • Yes, EBSCO includes multiple databases - they're listed on the right of the screen usually.

    For Chrome - like in Firefox, Chrome only displays a Zotero icon in the URL bar when it detects a translator. If you need to get to the Connector settings (which in most cases you shouldn't need to) you get there through Tools --> Extensions.

    Your library - if you're sharing the ZFF library, there is no ZSA copy. You can find your libray in ZSA just as with ZFF:
Sign In or Register to comment.