Odd sqare character added to references

Just recently...when I create either single references or bibliographies from citations, Zotero is adding a small square character anywhere there is a space before a colon or semicolon. This happens for any title whether I've saved it from WorldCat, databases, or Amazon; and whether I create the references from within Zotero itself or using the Word plugin. No space before the punctuation, no square. I'm on Zotero 2.1.10 and have updated translators; can't think of what else to do! Anyone else seeing this, and/or been able to solve it?
  • Odd. What OS and Firefox version? Have you tried restarting your computer? Are you using any third-party extensions or themes? If so, try disabling them.
  • edited January 18, 2012
    Also, can you confirm that this is happening from all sources, or only some? Does it happen if you create/edit an item manually? If you delete the space from the citation but then add it back with the space bar, does the problem recur?

    If it only happens for some sources or manually edited items don't trigger it, it's an import issue, and we'll need specific URLs (including from Amazon, ideally) for items that cause it.

    If you can trigger it via manually editing, there may be a more general problem with your Zotero installation.
  • I'm on Firefox 9.0.1; Zot 2.1.10; Windows XP. I've disabled all the add-ons and everything else I can think of and it's still happening. I get the odd square character if there is a space preceding a colon or semicolon (but not a comma!) on any kind of reference (book, articles) from a variety of resources: Worldcat, Amazon, EBSCO. If I manually remove the space, the reference is created correctly. If I manually add the space back, or insert a space where there wasn't one before, I get the character. I just manually created a brand-new reference for a fake book, put a colon with no preceding space in the title, and got a perfect citation. I manually added a space before the colon, and then got the square character in the reference. So it appears not to be an import issue.
  • Does it matter which style you use?
  • Nope. It happens with APA style, which is my default. I tried it with Chicago, just to see if it made any difference, but I get the same results.
  • You may be triggering a bug in the version of the citation processor in 2.1.10, though I don't recall anyone else reporting this. It's probably worth trying the 3.0 beta, which has a newer version of the processor.
  • Ok, I will consider trying 3.0. It's odd, though, that I've been using 2.1.10 for quite a while now with no problems -- until now! Thanks for your help troubleshooting this.
  • If you still have 2.1.10 installed, you can generate a bibliography that shows the problem in RTF format and send the file to support@zot....org with a link to this thread, so that we can see exactly what character is in there. But it'd be good to know if this occurs in 3.0 as well.
  • Update: I installed 3.0 (not the standalone version) today. Am still getting the square character. I created a bib using items already in my Zotero library and still see it; then I added several new items from our online catalog and still see a small square added to any reference where there is a double space before a colon.
  • Cary: Received your document. The character being inserted is a Unicode "narrow no-break space", which isn't being displayed properly in some contexts in Windows XP. OS X and Windows 7 display it fine.

    It looks like citeproc-js, the citation processor Zotero uses, replaces regular spaces before colons with that character. This shouldn't be new, though—it looks like this dates to 2.1.6, and was done on purpose—so unless you switched to Windows XP from another OS I think it would've been happening for quite a while.

    In any case, this is really a bug in Windows XP, not Zotero, and I don't think we're going to make the output typographically incorrect for the sake of a 10-year-old OS. (At least, it would be typographically incorrect for French, according to that thread—it's debatable what should happen in other locales.)

    As far as I can tell, though, this happens only in WordPad and Word (2003, at least). If I save an HTML bibliography with that character and open it in Firefox, it displays fine using Times New Roman. If I then copy and paste that output into WordPad or Word, I get the square character, even in Times New Roman. But if I save that Word document and open it in Mac Word 2011, I don't get the square character. So this seems to just be a display issue on Windows XP and/or that version of Word.

    If you haven't tested it, you also might want to see what happens when you print the document—it's possible the characters will still print correctly.
  • Hi Dan...thanks for the reply. This really wasn't happening til recently (a few weeks ago); I had the same set up on my computer (OS, Zotero, etc) all along and frequently use Zotero either for my own work or to demonstrate to students, and was not seeing that odd character til a few weeks ago. I do have Word 2003 and Windows XP. When I copy and paste these references even into an email message, though, I see the character, and I just printed the document I sent you earlier today. The square character prints!

    I downloaded 3.0 an hour ago, and am still seeing this character whether it's with older references or things I just added today. If this is an XP issue or a Word 2003 issue (haven't tried this with Open Office, now that I think of it) maybe this will be an argument to help me convince our IT people to finally upgrade me!!!
  • Unless I'm misunderstanding something, though, it should be straightforward to just use find&replace in Word to get rid of that character when you're sending the doc somewhere.
  • This might be of some interest (especially the top answer, which suggests that using U+2009 and some CSS is more robust for HTML output): http://stackoverflow.com/questions/595365/how-to-render-narrow-non-breaking-spaces-in-html-for-windows
  • This really wasn't happening til recently (a few weeks ago); I had the same set up on my computer (OS, Zotero, etc)
    Well, something had to have changed on your system to trigger it, since Zotero 2.1.6, which started doing this, was released last April. Maybe you were somehow running an old version of Zotero?

    You shouldn't even really need to find and replace the character, though—you can replace it with a regular space if you want, but it's not actually incorrect as is. As long as the person opening the document is using a more modern OS/word processor, they shouldn't see the square.

    Rintze: This isn't about HTML output, though—the narrow no-break space works fine for me in Firefox on Windows XP. The only issue I see is with RTF/Word.
  • I think this is strictly Windows XP. LibreOffice 3.4.5 gets this wrong on XP too.
  • Yes, I can use find & replace to eliminate the character (and I've done this several times). I suppose it's possible I was running an older version of Zotero...which means I would have had to upgrade sometime last month? I'm not aware of having done that. Well, this is an annoying glitch but not worth exploring any further, I guess. If it would be fixed with Windows 7 and/or Word 2007, I'll see if I can get that installed! Thanks, all, for your help.
  • Probably not Word 2007, but Windows 7 fixes it based on my tests here. And just remember that this is a display-only glitch—the character is correct in the file.
  • Well yes, it's a display issue...but that's really where it counts! :-) And it does print.
  • @Dan: bug reported in this thread with Word 2000 and Win 7(!). Could you have a look? AFAIR you can read French but the issue seems to be limited to Word 2000 (no pb with HTML bibliography). It does not only concern nbsp but also non-breaking hyphen: hyphens are replaced by squares too.
Sign In or Register to comment.