Can't save item from ScienceDirect

Dear Zotero,

I can not save this item:

Tried with both standalone and FF version.

Report id: 1729020027
  • A ScienceDirect site update broke Zotero's ScienceDirect translator. We've just pushed an updated translator that disables the save icon in the meantime, and we're looking into a fix.

    Zotero will automatically import RIS exported from ScienceDirect—see the "Export Citation" link at the top left of article pages.
  • Thanks Dan, I looked at the known problems, but could not find anything about this.

    Importing RIS from clipboard was useful! However why is it not put directly in the library I have selected rather than in a separate folder? That seems inconsistent to me, but maybe there is a good reason?
  • Thanks. Done.
  • a fix is now up - it will update automatically within 24hs or you can manually update your copy of Zotero from the general tab of the preferences.
  • Well, the fix seems to capture the citation data but not the PDF, at least for me. Not sure if that's an issue at their end, though.
  • Update: the changes SD made over the weekend are causing issues with PDF download on FF. If you have Firefox set to save the PDF file not open it, it saves the file without the .pdf extension. Presumably this is why Zotero can't capture the PDFs from SD at the moment?
  • first, make sure you have updated your translator: We pushed two fixes, about 4hs apart, only the second one would get the pdf.
    Pdfs from Sciencedirect work for me. Could you give us a sample URL? Also, if you think this migh have to do with how FF saves pdfs, maybe try changing that setting back and forth to help troubleshoot.

    It sounds odd that sd would serve pdfs without file extension - especially windows systems would not be happy with that.
  • Translator is up-to-date. I've been using SD all day (UK) and downloaded around 60 pdfs. Same problem with each. Here's a URL:

    It's only a problem with FF (not Chrome or IE, which I've also tested on). FF can open PDFs from SD fine, but can't save them down directly. I've played with the save settings as you suggested, but no joy.

    Only been able to try with 3 computers (all on Firefox 9, all on Windows 7) as the SD "improvements" screwed up the login for a bunch of users in the UK, so most of lab group can't access SD at all. Submitted an issue to their customer support this morning so we'll see what they say
  • huh - if you hover over the URL bar icon on that page - do you see "Sciencedirect" or "DOI"?
    For some reason it looks like the newest version of the translator may not have gone out.
  • I had a look - I don't think the newest translator has gotten pushed - if you're seeing DOI I'm right about that)

    (technical note for Dan, Simon, or ajlyon - I have to leave, but it looks like Dan's disable fix had a timestamp after my full fix so the latter isn't getting pushed - could someone update the timestamp?)
  • Yeah, I see DOI. Yey troubleshooting!
  • OK, timestamp updated again. (Best to use UTC timestamps to ensure they're sequential.)

    steve: Your copy of Zotero should auto-update within 24 hours, or you can update manually by clicking Update Now in the General pane of the Zotero prefs.
  • It works! Thanks so much all.
  • Hi there,

    I'm also not able to download citations from SD. I've just updated zotero and restarted firefox, but still no luck. When I hover over the URL icon I see ScienceDirect, so I assume that this means that the full fix has been applied, but it still doesn't work.

    Here is one of the papers I wanted to save.

    Any help would be greatly appreciated,
  • (Best to use UTC timestamps to ensure they're sequential.)
    right. I usually don't touch the timestamp and just let scaffold handle it - I wonder if Scaffold could use UTC automatically?
  • @trelirodia
    works for me - note that sciencedirect doesn't work in guest mode.
    If you're sure you're logged in - individually or through an institution, please provide an error report ID immediately after triggering the error.
  • Shouldn't we (re-?)disable detectWeb in guest mode if that's the case, though? As a guest I get an error on that page.
  • edited January 9, 2012
    I thought we had guest mode working as of the last update, but if not, we should disable it, or fix it. I'll see if I can pin down the cause when I'm back off campus and am once again a guest.
  • I had forgotten about that and didn't test. I can have a look.
  • It works for me in guest mode on that and other pages - I'd need an error message to troubleshoot.
  • Error: newDoc.evaluate("//div[@class=\"icon_exportarticlesci_dir\"]/a", newDoc, nsResolver, XPathResult.ANY_TYPE, null).iterateNext() is null
    Line: 101
  • thanks - that's the link to the article export page. I have that on the site, whether I'm in guest mode or not, so this works for me.

    Ajlyon, can you take a look, I don't think I have a good idea on how to troubleshoot this blind.
  • Im also having problems with Sciencedirect.
    Whenever I try to save a paper the incorrect article is saved. The paper saved is always the same - something called "Leveraging personal metadata for Desktop search: The Beagle++ system" from a journal called "Web Semantics: Science, Services and Agents on the World Wide Web". The papers I am trying to save are completely different.

    This happens on multiple pcs.

    I have updated the translators in the preferences panel.

    I am logged into sciencedirect.

    When I mouseover the zotero save icon I see "Save to Zotero (DOI)"

    Any advice?
  • update translators from the general tab of the Zotero preferences.
    If that doesn't work, provide a sample URL
  • Hi adamsmith,
    I have done the update already. (and restarted the computer).

    All sciencedirect articles are saved incorrectly as the article I described above.
    For example each of these:

    What is particularly strange is that this is happening for me on multiple computers.
  • and all of these say DOI when you hover over the icon?
    That means the ScienceDirect translator isn't even used.

    Are you going through an institutional proxy? Are these exactly the URLs you're seeing in the URL bar?
  • All sciencedirect pages say DOI when I hover over the zotero icon.

    I just tried disabling proxies in the settings but still no change.
    (I also tried resetting the translators in the advanced settings and updating them again.)
  • i just saved a debug log of what happens when i save from sciencedirect. The log number is D223158366
Sign In or Register to comment.